Linux Problem

By teacon7 · 11 replies
Jun 28, 2003
  1. Hello!

    I recently installed Linux Redhat 8.0(pysche) onto a modified box I put together. That may be part of my problem, but I'll get there in a minute.

    I'm a linux newbie, having only messed around with my new system for a little while. Everything appears to be ok, except I can't start X, and thus can't start KDE, Gnome, or other nice-looking programs like that.

    Whenever I try to startx, I get the message:

    (EE) No Devices detected.

    and then later:

    Fatal Server Error: No screens found.

    Now, I don't have the exact logs onto my pc yet, but I could supply those if neccesary. Right now I'm just wondering what 's wrong. I've looked at the XF86Config file, modified it (after backing it up), and still have absolutely no idea what to do. It appears that X can't redognize my video card, but I don't know how to tell it where it is, nor can I thell where it is from looking at the innard of my computer! Can I, and How can I probe for the location? Please help, I'm trying to climb the everest of linux-- because it's there.
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You have a misconfigured X Server. Although you don't really need to, as a newbie it would be a good idea if you reinstalled Linux again, this time test the Windows configuration (during stage where you picked no of colors and resolution, etc) and make sure that it works before progressing. You can further tweak it when X Windows is properly up and running.

    Try settings for your Graphics card like "generic" or "standard", and also for the montor settings as well if that's not being detected properly.

    What make and model is your graphics card? (apologies if you have said and I have missed it...)

    If possible, upgrade to Red Hat 9 which is a lot better for first timers with this sort of thing, where you will be a lot more likely to get everything working with less intervention.

    Please don't be disheartened, and please don't give up. Its easy the first time you see Linux to be put off but if we all did that with new things, no one would ever learn anything and nothing would progress. Good luck.
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    cat /proc/devices
    should list your PCI and AGP devices, but for a newbie I recommend the same as Phantasm66 - reinstall and let it detect things automatically. It could also be that your gfx card is too new, in which case you might want to check from manufacturer's site if they have drivers for it.
  4. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    I don't know a whole lot about Linux myself but have been using it on and off for 3 years. Lately I've been using it a lot and I am liking it. I suggest the same thing Mict and Phant are saying; I would also just do a a reinstall. Just boot to the Red Hat CD and reinstall like you never installed it. That should fix the problem.

    Make sure you select that you want KDE and Gnome installed when you install Red Hat, also make sure you specify to install X.

    Linux can be a great learning experience. I am having a lot of fun with it.
  5. wicka_wicka

    wicka_wicka Banned Posts: 125

    Yes, but Linux can be hell. Just take a lesson from me: don't use Mandrake and everything will be fine.
  6. teacon7

    teacon7 TS Rookie Topic Starter


    Well, thank you all for your help. Unfortunately, it still doesn't load X. I keep getting the same error message after trying to start x, and now the man pages are kinda garbled (character substituting. an å instead of a dash, etc...).

    I didn't say anything about my video card, although it certainly isn't a case were the hardware is too new. possibly it is too old to handle X, I don't know. It's a Matrox Millennium, if that makes any difference. It came with the gateway pc that my dad got about... six years ago? it's pretty old.

    Here's something: Both times I installed I had to use the text installer rather than the graphical one, due to a lack of RAM. I only have 24mb, which probobly isn't enough. Did the installer mean actual ram or the ram on my video card? This might explain the lack of any graphical interface, yet my bootloader (GRUB) doesn't seem to have a problem. What's wrong?

    Do I just need to find a new system (or components) to reinstall linux on or is there something else that can be fixed?

  7. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    Your CD may be corrupt possibly. Linux doesnt need a very powerful PC to run on but to be sure -- what kind of system are you installing it on? RAM, speed, hard drive space, etc?
  8. teacon7

    teacon7 TS Rookie Topic Starter

    System specs...

    Pentium 1, 100mhz
    24mb ram
    Matrox Millenium Video Card, unsure how much video memory
    HD: It should be about 2gigs. For some reason it won't let me install past one and a half of them. Soemthing to do with swap space, I think, but then again I don't know.
    The BIOS is old enough so that it won't let me boot from a cd, I had to use a boot disk
    Generic modem, soundcard, and a serial mouse.
    I have a CD drive, a 3x5 floppy, and also a 5.25 floppy.
    That's about it. I can't think of much else.

    The libraries may be corrupt, although I see no reason why not. I'll get some others and try those, maybe that'll do something.
    any suggestions?

    thanks again,
  9. wicka_wicka

    wicka_wicka Banned Posts: 125

    Maybe it doesn't recognize the monitor/video card correctly? Maybe that's why it says "No Devices Detected." I know that before I installed my nvidia drivers, when ever I'd try to load a 3d game Mandrake would lock up.
  10. wicka_wicka

    wicka_wicka Banned Posts: 125

    I Googled for your prob and found this page:

    Maybe it will help, especially this part:

    "I used xf86config, trying both a generic VGA setup (i.e. skipping use of the
    video card database) and one that used the actual S3 chip set parameters as
    supplied in the video card database. Either way, startx still failed.
    Running xf86config again and choosing the generic VESA driver worked. Even
    though the video card database had parameters that matched my chip set
    exactly, I'm wondering if the fact that it is integrated on the motherboard
    (on an older Compaq Presario 4814) made it "hard to find" (hence the "no
    busID" comment in the log)? In any event, thanks for your help.
  11. teacon7

    teacon7 TS Rookie Topic Starter

    ok, I realize it's been a while since this was... whatever.

    anyhoo, thanks to all who helped. I ended up reinstalling, and obtaining a new video card. I think the problem revolved around a misconfigured x server and a video card that wouldn't display correctly. The first time I tried the new card, it worked.
    so anyways, now I'm enjoying the benefits of linux. thanks!
  12. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    When using a RedHat based distribution, it's easier to use redhat custom tools.

    Open a command prompt, or if you're stuck in console mode, just type redhat-config- & hit TAB twice. It'll list all the custom redhat configuration tools installed.

    For example, you have redhat-config-xfree86 that could've helped with your problem.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...