1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Linux, WinXP, and Partitions

By redfoxtx ยท 19 replies
Sep 1, 2003
  1. Hey, I've just reformatted my pc, and i went for putting WinXP Pro aswell as RedHat Linux 9 on the computer.

    I have 2 seagate 80 gb hdds, and i went in and partitioned them druing the windows set up into 8 or so partitions for varios things, and left 10 gigs at the start of the non-windows drive for linux to go on.

    Windows installed fine, and can obviously see all the partitions and access them, it can even see the linux partition, although it obviously cant access that.

    When I got around to installing Linux, i went throguh the redhat gui installer, and got it to format the left over space in its file system, and call it the boot drive (i think thats what setting it to / meant), at the time it saw all the other partitons and their file systems just fine. Then linux went ahead and installed, and the boot selector and linux are working fine.

    The problem is i cant find the other partitions in linux, so i cant acces that data. I think during the setup i should have mapped the partitions to folders for linux, or somthing like that, but i didnt.

    Worse case scenario, i can re-install linux (although it took a while), but i was wondering if there was an app i could use or even a command that would get it to be able to see those other fat32 partitions

    thanx for any help
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    Type these two commands into the terminal in Linux:

    more /etc/fstab

    more /proc/partitions

    post the results back here.

    However, in the mean time, check under /mnt , I think you might find something there! But you might have to manually edit /etc/fstab, which I can help you do if you post the information that I have asked for.
  3. redfoxtx

    redfoxtx TS Rookie Topic Starter

    here are the results:

    and i having a look in mnt had been my first guess, but alas it only shows my two cd rom drives and my floppy disk drive:
  4. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    ok, where do you think your FAT32 partition that you want to mount is located?? is it hde1, or example?

    if you don't know, then try to mount the partitions in a command prompt.

    first, make a mount point:

    mkdir /mnt/fat32

    now, try to mount what you think is your partition like this:

    mount -t vfat /dev/hde7 /mnt/fat32

    cd /mnt/fat32


    ...??do you see your files? if you do, post back here with the partition device name, i.e. hde7, etc....

    I will then tell you how to add that info into your /etc/fstab so that the partition is mounted automatically when you boot
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,049   +11

    Eh, fdisk -l /dev/hd* (replace the * with a letter) produces more readable output than cat /proc/partitions ;)
  6. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    erm, yeah! :eek:

    I should stop passing on more of my bad habbits!
  7. redfoxtx

    redfoxtx TS Rookie Topic Starter

    ok, that worked, looks like the partitions i want are:



    They're all vfat (im ignoring the ntfs one i use for windows as i presumer linux cant access that)

    Now, do i have to mount them all to the /mnt./ directory, or can i mount it to anywhere i like?
  8. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,049   +11

    Linux can read ntfs partitions (if the support is built into kernel, and most distros have it as a module). Yes, you can mount them anywhere you like. It's just not smart to mount to /dev/null :giddy:
  9. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    you can mount them anywhere that you like. Of course, if there is anything in the directory that you mount the device in, you won't get that stuff, just the stuff in the device.

    to get your system to automatically mount a device on boot, you need to add an entry to /etc/fstab

    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

    is one of your existing lines, you want another one, thus:

    /dev/hdg2 /mnt/mydrive vfat noauto 0 0

    try something like that for each device. remember, you will need to create the mount points (in this case, /mnt/mydrive) before you reboot so that on next boot you don't get an error.
  10. epsilon

    epsilon TS Rookie

    But RedHat doesn't support NTFS so how would you go aboot getting Linux to read a NTFS drive?
  11. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,049   +11

    Red Hat's kernel is compiled by default so that it has nearly everything in modules. You can install ntfs module with insmod ntfs from command line. You can also check which filesystems are supported with cat /proc/filesystems.
  12. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    Remember that that NTFS support is read only. You get write access NTFS support in Linux, but its very dangerous and not recommended as it can cause data loss.
  13. epsilon

    epsilon TS Rookie

    phantasm, read only is fine as long as i can copy files off the winxp hd i need. mic, when i ran the cat syntax it didn't list the ntfs file system and redhat's own website said it doesn't support ntfs because of legal issues w/ M$
  14. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    Certainly, NTFS read support is natively support by the linux kernel, so you can either try loading the module in the way that Mictlantecuhtli mentioned, or you can recompile the kernel to either have NTFS support as a module or actually compile it into the kernel itself.

    If NTFS support has been left out by Red Hat, then you will have to recompile the kernel, I guess.

    This will involve a 30MB download from www.kernel.org , the file you are looking for is here:


    On broadband, this should take about 10-15 minutes or less.

    Download this file, and post back here when you have. I will then tell you how to recompile your kernel. But you should get the latest kernel source if possible please first.
  15. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    NTFS support is in RH kernels, but not enabled by default. You will have to recompile.

    I suppose it could be MS putting pressure on RH. SuSE (a german company) ships its linux with NTFS support builtin.
  16. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    In fact, if you did a full install, you will have the kernel sources under /usr/src

    folder will be called something like linux-2.4.20 or something...???

    You should be able to go right in there and compile the kernel.

    I noticed I didn't have 2.4.22 on my home machine, so later in the week I might recompile and write down what I am doing at the time, and then make a short guide post on how to do this.

    I will be too busy with SQL exam this week to do it right away.
  17. epsilon

    epsilon TS Rookie

    ok phantasm, i d/led the new kernel. how do i recompile the kernel? i tried doing it once and had to reinstall rh9 cuz it wouldn't boot
  18. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    Heh. Since you got it not to boot, then it means you managed to compile and install something. I'm sure Phantasm is coming up with a 3 page instruction on Linux kernel compiling, so I'm not going to attempt any fine literature here.

    When you install a new kernel, always make sure you have the option to boot the old kernel in case the new one didn't come out right.
  19. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,049   +11

    I'm not Phantasm66, but anyhow:

    Extract the kernel to, say, /usr/src.

    Go to kernel directory in command line:

    cd /usr/src/linux-2.4.22

    To make sure everything is how it should be by default, do

    make mrproper

    That isn't necessary, and it'll slow things down a lot if you're compiling the same kernel for nth time as it deletes all compiled files.

    To configure the kernel in command-line mode, do

    make menuconfig

    To configure the kernel in graphical mode, do

    make xconfig

    After you've saved the configuration, it informs about the next step:

    make dep

    After that, compile the kernel:

    make modules;make install;make modules_install

    That'll compile the kernel and install it to /boot/vmlinuz-2.4.22 with a symlink to /boot/vmlinuz (along with other stuff).

    If you're using LILO to boot, you need to edit /etc/lilo.conf a bit to tell the bootloader about the new kernel. After editing LILO conf file, run /sbin/lilo for the changes to take effect.

    If you're using GRUB, edit /boot/grub/menu.lst instead. With GRUB, there's no need to anything else.

    Reboot and enjoy your new kernel (if everything went well).
  20. epsilon

    epsilon TS Rookie

    WOOHOO!!! I'm so glad i got ntfs support on RH9 w/out recompiling the kernel. I used the Linux-NTFS project rpm and their instructions. got it installed in 10 mins. Now i have to get my wireless g520 card to work so i can have net access.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...