Logitech Headset "USB Device Not Recognized

By JandSilantBob
Jan 12, 2008
  1. I recently purchased A USB logitech Headset to use with ventrilo while playing WoW. The first time i plugged it in it worked perfectly, since there were no drivers to install i plugged it in, and in the system tray it said "usb device installed". So the next day i unplug the headset to plug in my iPod. Well later that day when i try to plug my headset back in i get a message down at the bottom of my screen saying "USB Device not recognized one of the usb devices attached to this computer has malfunctioned and windows does not recognize it, for assistance solving this problem, click this message." Well i tried clicking the message and you know god ol' windows, didnt get me anywhere at all. So i went into device manager and unistalled the device, then plugged it back in, then it would say "New Device Installed" but then immediately afterwards the same old usb device not recognized error message would pop up. I even tried it on a different computer and got the same message. Is it actually possible that by simply unplugging my headset that it could malfunction to the extent of not working at all? And when i try to go through install new hardware, i see the "Unknown device" in the list of installed hardware, and when i click on it it says "This Device is Working Properly"
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...