Lost Admin Privileges

cookiedude

TS Booster
Hi all

So the situation is this, I had to setup an existing PC in the office for a new starter and decided to be lazy and simply change the user account name (I know, that was a schoolboy error!). Since doing this, the computer allows me to login fine with the new username/password but keeps asking for the Admin login details whenever I try to make system changes, update software, etc. The user account I changed was the admin account so not sure why this is happening. I've tried using every username/password that has ever been assigned to that PC, but nothing works! Is there any workaround to get Admin privileges back so I can fix this?

FYI - The PC is a member of our work domain, so figure this has further complicated things!?

Really hoping this isn't going to need a full re-installation of windows, fingers crossed someone out there can give me some good news :)

Thanks in advance
 

jobeard

TS Ambassador
The prompt for Admin during installs is actually a good thing (that is the UAC and you REALLY want it to prompt) BUT you can almost always use any log in the Administrators Group

use CP->User Accounts
add user
set type = Admin
*must* add password to it

save and close

runas /user:$whatever$you$just$created cmd
give that password

it will then create the %profile% for that new user

From then on, you can reply with $whatever$you$just$created and its password
 

cookiedude

TS Booster
Thanks Jobeard, but the problem is, since the name change, I can't get the PC to accept any of my admin credentials to get past UAC.

eg. when I go to Control Panel > User Accounts > Add User it asks me for admin login and doesn't accept my username/password, so I can't create/edit any of my user account details.

It's like the change in user settings has confused the system somehow and I need to "un-confuse" it :)
 

cookiedude

TS Booster
No joy. However, I randomly tried my own login details, which somehow worked... can't quite figure out why as these were never used on that machine!

So, I removed the machine from the work domain and created a new Admin account, deleted the old primary user account and created a new one for it set as an Administrator. I then put the machine back onto the work domain only to get the same UAC issue.

The only way to make changes is to use my personal login details... just can't figure out why!? What is weird is that the UAC settings are higher on the domain user account than they are on the local user account, but it won't let me change them :(

We don't have this issue on any other machine/user account across the domain, so I'm completely baffled!!??