Low harddrive throughput - any suggestions?

By Zolar1 ยท 15 replies
Aug 26, 2005
  1. I was running a RAID 0 array with 2 WD 36gb Raptor Harddrives, 10,000 rpm, SATA.
    My harddrive throughput was 50Mb/sec. So I added another WD Raptor 36 Gb to the array.
    I tried changing the volume striping from 64K to 32K, which helped marginally.

    I don't have any movies or music or games on my system, nor do I run any databases. The wife, however, uses Paint Shop Pro programs, and her average filesize is around 256K. I do have to defragment every 2-3 days to keep fragmentation below 5%.

    All 3 harddrives are rated at 150Mb/sec each, but I can only get 100Mb/sec through the array as measured by PCPITSTOP.COM .

    Why can't I get the full throughput of 450Mb/sec??

    I can't seem to find any bottleneck or mis-setting anywhere.
    What did I miss?

    How can I fix this problem?

    I have a small fortune invested in this machine. It should knock my socks off, but it doesn't.

    I'm running XP Pro SP2 (with all the updates) on an MSI motherboard, 865 PE Neo2-P, Platinum Edition (with most recent BIOS Flashing), with a P4 3.0Gb Northbridge sporting 2 Gb of fully matched 400Mhz DDR memory (POST screen says I'm running my memory in Dual Channel, Liner (Linear?) mode. My Video Card is a GE Force 6200 (256Mb DDR) AGP (1 week old).

    The RAID Adapter is a High Point RocketRaid 1810A, 4 channel PCI-X (compatable) with a HPT601 XOR Optimized, RAID 0,1,5, 1 0, JBOD available settings, on IRQ 7. The adapter is rated at 1Gb+ throughput.

    I tried XTEQ, and Tune-XP, but little or no improvement in throughput.

    I have about 43 processes running, which I can't reduce as they are needed. (i.e. Antivirus, firewall, spysweeper, Weatherbug (2.7), printer & scanner drivers, AutoUpdates, RAID Drivers, etc...)

    The system runs fine, but for what I have recently invested in the RAID Array, it really should be extremely fast.

    If I thought putting a Hamster in there would speed it up, I would go buy TWO tomorrow! LOL

    Just really annoyed here, can anyone help?

    Feel free to email me if desired.

    Thank you!
  2. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    PC Wizard 2005 has some benchmarks of interest to you.
    ... L1 Cache, L2 Cache, HD thruput

    see re dual channel linear mode

    Just to be sure we're talking apples/apples: you're implementing RAID-0, not -5, 10, or JBOD, right?

    An excerpt
    hum; memory and paging may be interacting here! What kind of CPU usage are you seeing?

    Are you allowing the SWAP file to be placed on the RAID?
    Is the entire system running from the sole HD/RAID config or is the RAID for your
    special interest data files?

    If you're swapping on the RAID, I would add a 10gb IDE drive, reduce the swap on C: to as
    little as possible and build a swap file on the new ide at least 4gb.
    {note: w/o multiple HDs on my platform, I can't demonstrate it works, but on prior
    systems, this was effective}
  3. Zolar1

    Zolar1 TS Rookie Topic Starter

    I put my entire swapfile on the IDE harddrive. My OS is on the RAID 0 array.
    My CPU Usage runs between 0% and 8% (typically), and 65% when doing an antivirus check.

    I'm posting a copy of Task Manager for your review (if it will upload).
  4. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    hum; did you try the PC Wizard 2005? It will tell you the cycles required
    for L1 & L2 Cache, as well as disk thruput.

    You're likely aware, but I'll mention it just in case; Systems with many small
    files being updated will perform better with smaller RAID block sizes.
    It's a big waste to ask for 512 bytes and wait for the full 32k. The wife's
    Photoshop work @256k is on the smallish side for graphic files.

    You mentioned frequent defrags to keep it at or below 5%. Can you determine
    which files are causing the fragmentation? Norton Speed Disk will list'em for you.

    One other query: is poor performance PRIMARILY at boot time or just poor
    all the time? Remember you can change the Prefetch to system boot only
    and save a ton of I/O that can be deferred until really needed.

    Another observation: I/O really can be too fast! Here's why.
    We want serveral blocks and start to transfer BK-1. When done, we need
    BK-2 but the disk has rotated past it and we have to suffer the latency delay
    on one rotation until BK-2 is available again. In this case, we want to use
    READ-AHEAD features and multiple buffers to keep the data flowing w/o
    latency impacts. Check your BIOS and the RAID controls for these settings.
  5. Zolar1

    Zolar1 TS Rookie Topic Starter

    The poor performance is listed inPC Pitstop's testing information.

    I have 3 WD Raptors, each with a rated throughput of 150Mb/sec.

    When all 3 are in a RAID 0 array, my throughput is only 100Mb/sec, or about 20% of the rated speeds (additive).

    You mention multiple buffers....OK, It makes sense,but how would I make and configure them?

    RAID & MOBO documentation is nonexistant at best. There are No BK anything settings anywhere.

    I can see no read-ahead optimization settings like Win98 has.

    Basically, my computer is OK, but for what I spent on it to obtain the rocket propelled speed, I'm being shortchanged by either the hardware or software.

    I will check out the program I just d/l to test my system.
    I'll post the info as soon as I can complete the testing.
  6. Zolar1

    Zolar1 TS Rookie Topic Starter

    OK, the utility states things VERY differently that what BIOS/CMOS reports.

    In BIOS, the FSB for the CPU is reported as 200Mhz.

    The config utility says my memory is configured at 266Mhz, whereas the BIOS reports it as 400Mhz.

    Both report the cpu speed as 3.0Ghz

    Which one is correct???
  7. Zolar1

    Zolar1 TS Rookie Topic Starter

    The Benchmarks are in.

    My regular SATA WD Raptor is faster than my RAID 0 array with 3 Raptors.

    And my memory efficiency is 63% - hmmm...not sure why.

    And the Intel program apparently erroneously reports the wrong FSB and Memory Mhz.
  8. Zolar1

    Zolar1 TS Rookie Topic Starter

    Getting really frustrated here.

    The Intel Program says I have no L2 cache. I know for a fact that I do! I made sure the P4 had the 1024Kb L2 cache instead of the 512Kb L2 that the other one's came with.

    Even the factory sealed box the CPU came in stated the cpu was a P4 3.0 Ghz with a 1024 L2 cache.

    Something's not right.

    Could I have a bad BIOS or Motherboard?
  9. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    can you get the L1+L2 Cache numbers?
    FSB vs Processor has some info
    on the multipliers. you should always try to get whole integer or the nearest 0.5 else the processor will wait for data.

    hum; my ram and global mem latency is much lower and consistent
    than yours; you should investigate.

    here's my trival Toshiba Laptop 1.3gb system
    Mainboard : TOSHIBA (EAL20)
    Chipset : Intel i855GME
    Processor : Intel Celeron M 350 @ 1299 MHz
    Physical Memory :512 MB (1 x 512 DDR-SDRAM PC2700 @ 166 MHz)
    Hard Disk : IC25N060ATMR04-0 (60 GB)
    Operating System :Microsoft Windows XP Home Edition 5.01.2600 Service Pack 2

    and the reports
    Report Date: Saturday 27 August 2005 at 15:22

    L1 Latency : 3 cycles

    L2 Latency : 10 cycles

    HD Thruput
    Sequential Write : 16.47 MB/s
    Sequential Read : 21.89 MB/s
    Buffered Write : 68.74 MB/s
    Buffered Read : 85.92 MB/s

    Bandwidth (Write Float) - Prefetch) : 563.27 MB/s
    Bandwidth (Write Int.) - Prefetch) : 551.99 MB/s
    Latency : 105 ns (137 cycles) <<<<<
    Bandwidth Efficiency : 75%

    global memory
    Bandwidth 1 KB : 9268.77 MB/s
    Bandwidth 2 KB : 9476.69 MB/s
    Bandwidth 4 KB : 9598.24 MB/s
    Bandwidth 8 KB : 9522.41 MB/s
    Bandwidth 16 KB : 9606.37 MB/s
    Bandwidth 32 KB : 9352.08 MB/s
    Bandwidth 64 KB : 5436.87 MB/s
    Bandwidth 128 KB : 4918.64 MB/s
    Bandwidth 256 KB : 5082.97 MB/s
    Bandwidth 512 KB : 5472.57 MB/s
    Bandwidth 1 MB : 5319.68 MB/s
    Bandwidth 2 MB : 1960.8 MB/s
    Bandwidth 4 MB : 1879.67 MB/s
    Bandwidth 8 MB : 1879.79 MB/s
    Bandwidth 16 MB : 1880.33 MB/s
    Bandwidth 32 MB : 1880.59 MB/s
    Bandwidth 64 MB : 1880.56 MB/s
    Bandwidth 128 MB : 1880.66 MB/s
    Bandwidth 256 MB : 1880.59 MB/s
    Latency : 105.47 ns (137 cycles) <<<<<
  10. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    saw this after my post today. my suggestion is to resolve the L1,L2 without
    your RAID environment, even if it means getting back to 'normal'.

    Typically, the BIOS can enable/disable L1/L2 caches so try to solve this first.
    I recall you've updated the BIOS before going to RAID. Can you get any doc
    for it?
  11. Zolar1

    Zolar1 TS Rookie Topic Starter

    My L1 cache is 16K I think, and my L2 cache is 1024K for sure.
    I flashed my BIOS because my system was slow, not the other way around.

    Are you assuming my Mobo is bad or the RAID card?
  12. Zolar1

    Zolar1 TS Rookie Topic Starter


    If I unplug my RAID 0 array, how am I supposed to determine if anything has changed?

    Perhaps someone could steer me to a freeware version of a program that will let me custom edit my own BIOS then flash the new file?

    Unfortunately, I don't speak BIONESE (binary) lol
    And I don't know how to do anything in Hex, even with an editor.
  13. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    let's go thru the matrix.

    hardware cache is controlled by the BIOS.
    there was a firmware update before the RAID install
    and another after the install

    sure would be nice to know the status without the RAID, as then
    we could determine the mobo or BIOS status. if this isn't correct,
    then it's unlikely that adding the RAID change will improve it.

    1) if the native system w/o raid still fails, investigate BIOS and mobo
    2) else if it fails only with the presence of raid, investigate the
    raid bios update. The raid card itself is unlikely to be the issue.
  14. Zolar1

    Zolar1 TS Rookie Topic Starter

    I just tried to physically move the RAID card from Slot 2 to Slot 3 on my motherboard. The screen goes through the steps, but when I expect the XP boot screen to show, the screen remains blank.

    I put the card back and everything works again, but still slow.

    My RAID card is sharing IRQ 17 with my Realtek 97 Audio card (built into the mobo).

    There was no firmware update other than the drivers for XP to work with, and a management program to make changes to the RAID array IF the array isn't used for booting.

    I tried all 4 floppy disks that came with the card, and nothing changes.

    Still, no one has replied to my previous questions - which is correct - BIOS or the other programs in reference to the DDR Memory frequency.
  15. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    I would think it important to isolate the RAID from the sound card :suspiciou
    Using the Pc Wizard tool, you can get a list via the Resource button on the left
    and the magnifier ICON. Then move the RAID as low as possible OR
    the sound card higher; eg:

    01 : Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
    08 : System CMOS/real time clock
    09 : Microsoft ACPI-Compliant System
    0C : Alps Pointing-device
    0E : Primary IDE Channel
    0F : Secondary IDE Channel
    10 : Intel(R) 82852/82855 GM/GME Graphics Controller
    10 : Intel(R) 82801DB/DBM USB Universal Host Controller - 24C2
    10 : ENE CB1410 Cardbus Controller
    11 : Realtek AC97 Audio
    11 : TOSHIBA Software Modem
    12 : Intel(R) 82801DB/DBM USB Universal Host Controller - 24C7
    13 : Intel(R) 82801DB/DBM USB Universal Host Controller - 24C4
    14 : VIA OHCI Compliant IEEE 1394 Host Controller
    15 : Realtek RTL8139/810x Family Fast Ethernet NIC
    17 : Intel(R) 82801DB/DBM USB2 Enhanced Host Controller - 24CD
  16. Zolar1

    Zolar1 TS Rookie Topic Starter

    I moved the RAID card to a different Slot, and not the conflict is between the RAID card and one of the USB ports. I went into Device Manager and disabled the offending USB port.

    Things seem a little different. :eek:

    Also, I went to a RAID 5 with a 256k Stripe. Most things seem normal, and other things seems fast.

    I think I had 2 problems - hardware conflicts and too small of a stripe size.

    Still, I can't get consistant info out of the reporting/benchmark programs I used.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...