Make D-Link DI-524 802.11g router work only as WAP

By phoenix9
Nov 26, 2005
  1. Hey,
    Im sorry fot bein a n00b here, Im not normaly, im just tired and frustrated in dealing with my familys new HP's never ending amount of pointless software. I( thought somebody might be able to give me a quick awnser on this one.


    I have a network set up with a Linksys BEFSR41 (rev. 3) acting as the primary gateway and the DHCP server, there are currently 4 clients on the network (mine dual-booted XP Pro, SuSe, and a partialy complete LFS; my sisters PowerBook; the new HP which unfortunatly was fasly advertised with Media Center Edition rather than its actual XP Home; my Xbox). the Router is connected to a BEFCMU10 (rev. 1(?)) serving Cox Cable.

    The problem arrises that my sister wants to use her PowerBook wierlessly and theres a chanche I might get a laptop soon anyway. Because of Black Friday Sales the HP also came with a free (after rebate) D-Link DI-524 (b/g WAP & Router /w 4-port switch). My initial reaction was to replace the old LinkSys with the new router, but a) It refused to get an IP from Cox, b) It switched me from the 192.168.1.* i was used to to 192.168.0.* and c) I found its interface unusably annoying. What I'd like to accomplish is to set the DI to work soley as a WAP for the network and still pass things such as DHCP and Port Forwarding (Routing in general) up to the LinkSys. How does one attain this result?

    I did a bit of googling and the only thing I came across was something about disabeling the DI's DHCP, but, as its configuration interface isn't acsessable when its soley a client, I feared that doing this would mean I had no way to acsess the interface at all, if I wanted to change the encryption key or something.

    Also, what may be an unrelated problem, with its current configuration the DI doesn't seem to assign adresses to wirless clients at all, but does to wired ones. (It is important to note, however, that the only evidence of this is my sisters PowerBook which has had issues getting an IP from the servers on her schools network as well).

    Any ideas would be appreciated.

    Thanks in advance,
    ~Donald Guy
  2. phoenix9

    phoenix9 TS Rookie Topic Starter

    nobody knows?
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The configuration interface is always available, you probably had routing issues since the devices are in different subnets.

    Set the local IP of the wireless router to be in your subnet instead of the default (something in the range). Disable DHCP, packet filters etc you don't need. Set up wireless.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...