Memorex 32023223 20x DVD won't burn DVDs

By wmseith · 4 replies
Jun 4, 2010
  1. Good Day

    I was wondering if someone could help me. I just purchased this dvd burner. The problem I am having is that I was able to burn a video dvd with the bonus light scribe disc that came with the burner. I then went to use the dvd-r's I had left over from before my last burner died. It would not record to the dvd-r's. It would encode the video to my harddrive but when it shouls open up and begin the writing process it fails every time. tried with 5 different dvd's but of same variety. Checked specs and it says it is both dvd+ and dvd-. Anyone have any ideas. Doesn't really pop up with an error message just tells me process failed. Thanks
  2. nismo91

    nismo91 TS Evangelist Posts: 930   +31

  3. wmseith

    wmseith TS Rookie Topic Starter


    thanks. tried that but no firmware for this model. While lister as an +/- it will only copy + dvds.
  4. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    If you mean you've tried 5 different brands of DVD media, then I'd say your drive is defective. I would try to exchange it.

    BTW, it seems like an older model even though you might have just bought it. 20X has been superceded by 22X and 24X.
  5. wmseith

    wmseith TS Rookie Topic Starter

    Thanks. I think I figured the problem but have no idea how it happened. it seems the decoder for the computrer which unlocks the css somehow vanished. Which I find a little confusing as I do not have that computer hooked up to the internet or install software. I use it for one thing to burn movies.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...