Metro 2033 lagging FPS

By DKRON ยท 4 replies
Aug 28, 2011
Post New Reply
  1. Is anyone else having a problem with playing metro 2033 on high settings? i have turned the AA off and tessellation is down and it is smooth most of the general game play but when i throw a bomb or grenade it slows right down.

    I have a:
    CPU - I7 950 (Clock speed)
    Motherboard - Gigabyte X58 UD9
    Memory - Corsair 12GB (6x XMS3 2GB) PC-12800 (1600MHz) XMS DDR3
    Graphics - 2x HIS ATI Radeon HD5850 1GB iCoolerV CrossfireX
    HDD - OCZ Vertex 2 60GB E Series SSD, Seagate Barracuda 1.5TB
    Monitor - Samsung BX2450 24inch Widescreen LED Monitor (1600 x 1050)
    Operating System - Windows 7 Pro 64-bit OEM

    I am running it at 1600 x 1200

    SKYSTAR TS Enthusiast Posts: 207

    Turn Physx off and the game will running fine
  3. DKRON

    DKRON TS Guru Topic Starter Posts: 569   +25

    really easy as that? will try that thanks

    SKYSTAR TS Enthusiast Posts: 207

    Hi DKRON
    your system spec is excellent ,
    but the slow down in the game when you throw a grenade is happening because you dont have a hardware to process the heavy physx of nvidia so you need to choose one of the three options here :
    1 - turn physx off as i told you.
    2 - if you like physx and you don't want to turn it off , then you need to buy a nvidia graphics card for physx like gt 240 , gts 250 ,gtx 260 or better.
    3-if you dont want to buy a graphics card for physx try to overclocking your cpu this
    could help you to have better fps.
    and good luck
  5. DKRON

    DKRON TS Guru Topic Starter Posts: 569   +25

    Thanks it cost me alot of money to build my computer, it is a pain that amd cards don't work with physx but from the reviews on techspot even the gtx590 had trouble running it high, i might be swapping up to Crossfire 6970's soon

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...