Micro ATX system doesn't power up

By EXCellR8 · 5 replies
Sep 4, 2010
Post New Reply
  1. I built myself a little computer reusing some of my LGA-775 stuff but I am having problems getting it to power on. I bought a 600w power supply (specs are below) which should be adequate for this setup, and it has run before, but now I can't get the computer to turn on. When I push the power button, the system powers up for a split second and then dies. If I push the button again... nothing. I can turn the switch on and off in the back all I get is that brief on state. The board has power indicated by a green LED, and the very first time i tried it the system ran fully powered.

    PSU Specs - Thermaltake TR2 600w


    I know Thermaltake units are hit or miss but it doesn't make any sense that it worked fine and now it doesn't. The power supply is brand new and it doesn't make any weird noises. I know there is plenty of power going through it because I can hear the normal faint buzzing sound.

    System Specs

    Intel Q6600 (stock speed)
    ASUS P5G41C-M mATX board
    Super Talent DDR3 4GB
    HD4870 512MB
    LiteOn DVD-Burner

    There are also 2 60mm fans and one 80mm fan plus the CPU cooler...

    Any help with this would be extremely appreciated, thanks! :)
  2. DKRON

    DKRON TS Guru Posts: 569   +25

    Have you tried grounding it, sometimes computer can short out when powering due to the motherboard touching the case, e.g. one of the screws are loose and move. You seem exsperienced so i would advice taking it out and plugging it back in on cardboard which will stop any power shorting out.
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    What you describe sounds like a failed, or improperly connected, power supply...
    or perhaps a CPU Fan
    As you probably know, the fact that a power supply is new, doesn't mean it is working properly...
    Check your cables, plugs,and sockets... Something isn't connected properly... or a memory module is not properly seated.
  4. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    Thanks for the responses... I finally concluded that I blew the power supply, which seemed to be under-powering the system I guess. I used a working 520w unit to power up the mobo and cpu and it worked just fine; posted normally. I already went ahead and ordered a new unit (modular this time around) so I can swap that it sometime this week. Of course I gotta rip the whole thing apart but hey at least I didn't fry anything else :)
  5. Benny26

    Benny26 TechSpot Paladin Posts: 1,535   +51

    Damn shame...Exact thing happened to me a few months back.

    I had a beloved psu that i bought for 30 quid...and i went and blew the sucker. i cant find it in the shops no more.
  6. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 1,835

    I replaced the power supply last night with the 600w Ultra X3 and it's working fine now, plus the modular design really neatened things up in there. I probably should have just used this power supply from the start considering I love my 1000w X3 but w/e it's working great. The unit itself also looks a hell of a lot better with the mirror finish; matches the case nicely :)

    Now if I could only figure out why the board isn't stable @ 1333 FSB I would be perfect... sort of scratching my head over that atm.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...