Spread the love! TechSpot Tech Gift Shortlist 2017


By tommy2k8 ยท 22 replies
Oct 30, 2008
  1. I am solving BSOD's that my client has had intermittenly over the last couple of months - the attached being the first minidump that I got on 8 July. After analyzing it with WinDBG, I decided to do some more analysis by using .reload;!analyze -v;r;kv;lmnt. However, I am still none the wiser. With this deeper analysis, I am meant to be able to tell what process, program or device is causing the BSOD. However, I can't find it! Can anyone help?

    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    As per your minidump analysis: "Probably caused by : memory_corruption"

    Run memtest for a minimum of 7 Passes (8 individual tests per Pass). Any errors run the test again per stick of memory to determine which one(s) need to be replaced.

  3. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70


    This is the problem in detail and what I've tried, hopw this helps:

    The specs of the machine are:

    3.00GHz Pentium D
    2GB RAM
    250GB Hard drive
    ConRoe 1333 D667 mboard (ASRock)

    Since June, I have had intermittent BSOD's. I kept a record of them




    26 August - IRQ_NOT_LESS_OR_EQUAL

    26 August - MEMORY_CORRUPTION (2)



    12 October - MEMORY_MANAGEMENT



    (The last two didn't create a minidump for some reason)

    Things done so far, to no avail:

    Memory modules taken out, one by one - alas, TuffTest, MemTest, Windows Memory Diagnostic say no errors.
    New psu - didn't solve errors
    Updating drivers - didn't solve anything
    Updating Windows - didn't solve anything
    Two OS reinstallations due to crashes and Vista Repairs not working, didnt solve anything

    What is very odd is this:

    I did a TuffTest disk test (Seek Test and Surface Analysis) on his machine and it came up with F004 errors - Sector not found. Then I put the disk in my test machine, same errors. Then I tried it in his machine again with 1 memory module at a time, same errors. However, after testing the disk test again, putting the 2 modules back, the test was error-free!!

    Also, in the Event Log, about once an hour, I get "some processor performance power features have been disabled due to a known bad firmware problem. Please contact the manufacturer." I did this last Friday, and still no answer!!

    My mate and I (he works with computers as well) both think it's now a motherboard problem, but as it's intermittent, we're struggling!!
  4. banic

    banic TS Rookie Posts: 24

    Can you post your exact specifications?

    Have you tried with well-known memory modules?

    Made any bios updates, overclocking, new hardware etc?
  5. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70


    It's a ConRoe 133 D667 motherboard running at 200MHz, with 2GB of DDRII 667MHz memory, DVD-RW drive, Maxtor 250GB Hard Drive, Intel 82845 Chipset, RealTek RTL8101 NIC.

    My mate brought some other memory modules round, but they didn''t make a difference
    Because it's a client machine, I don't like overclocking.
    Also I have flashed the BIOS (the most recent sated December last year) and updated graphics and chipset drivers
  6. banic

    banic TS Rookie Posts: 24

    Hmm...First, did these problems accour suddenly without any hardware or BIOS change at all?

    If you're sure that it's the motherboard, take all the hardware from the failing motherboard to another known-good and test. You could also run "system safe mode" by disabling all extra features and hardware and run this for a couple of days/week.

    It has to be your memory, harddrive or the motherboard which is failing.
    I would try to(if you haven't already done this):

    Remove motherboard completely and check for short circuits and remove dust and other material from the slots (especially DIMM slots). Cable check.

    Default motherboard settings, switches and jumpers.
    Downgrade to default bios setting and version.

    Install RAM model and size which is supported in motherboard documentation.
    Replace harddrive with clean install, Windows XP.

    One more question, have you checked temperature while system is operating, before crash?
  7. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    Firstly, I flashed the BIOS back in the summer, and no, I haven't made any hardware changes recently.

    Secondly, as I've got cerebral palsy and not very dexterous, my mate (who's worked with these things for 30 years) came and helped me take the computer apart and did what you suggested. First of all we swapped and tried other memory modules, still errors, checked temperature settings, voltage, still errors. However, we haven't taken the motherboard out and checked it in another systen.

    So, a rundown of how we both used elimination (directly copied from an email sent by my mate):

    If this is from Ron's machine then you can't treat it as a normal
    system crash because we think Ron's machine has a hardware
    The analysis is plastered with statements saying 'Memory Corruption'
    I think that is what has happened.
    The only pattern in all the crashes is 'Memory Corruption'
    The only problem left is we don't know exactly what is causing it.

    I think we can rule out software because we have had so many different
    pieces of software fail.
    I think we can rule out the memory because the disk still failed TT when
    we used your memory.
    I think we can rule out the disk as my disk failed on the machine.
    I think we can rule out Bios settings as you loaded a new Bios.
    That just leaves a motherboard problem.

    On Friday night, I came across some forums that suggested that Comodo Firewall was the reason for the IRQL_LESS_OR_EQUAL BSOD's.
    However, now I'm not so sure, as, since then, I've had three minidumps that I've never seen before. Can someone shed any light on these please?
  8. cantankerous

    cantankerous TS Rookie

    Error Help Please

    I've been having a lot of trouble with my system crashing lately. I'm not too familiar with minidumps or error messages. Could someone please have a look and give me a hand.
  9. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Tommy2k8, your minidumps:


    One of three types of problems occurred in kernel-mode: (1) Hardware failures. (2) Software problems. (3) A bound trap (i.e., a condition that the kernel is not allowed to have or intercept). Hardware failures are the most common cause and, of these, memory hardware failures are the most common. The problem with your dump was the analysis was inconclusive.

    One was error 0x8E and these are almost always caused by hardware. It cited memory corruption as the issue.

    The other dump was another 0x8E error and it cited NETIO.SYS. I can't remember what OS you are running. Is it Vista. Here is a link that might help...



    cantankeros, please in the future start your own thread rather than attaching to someone elses's posting/issues. It confuses the process. That being said, all four of your minidumps are 0xD1 errors and thay are due to either a faulty driver or buggy software.

    In your case the driver cited in ALL four was PRISMA02.SYS which is a PRISM Wireless NDIS 5.1 Driver - PRISM 802.11 Wireless LAN - by Conexant Systems. It can be found in D-Link or Linksys. Update your wireless drivers.
  10. cantankerous

    cantankerous TS Rookie

    Good day everyone.

    First of all, my apologies for being in Tommy2k8's thread, this is my first time on this site and it was late when I wrote this message, plus I was exhausted from trying to work on this problem all day. Next time I'll be more careful

    Thank you for your help. Turns out that the router is more of a pain than it's worth, so it looks like I may be in for a new one.

    Sorry again Tommy for the mix up. Take care
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Its okay, and thanks for getting back to us. Have you been having issues with this router before? Before purchasing a new one see if a driver update corrects your issue. Let us know.
  12. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    A mate of mine who has worked with computers for 30 years looked at it as well - this is strange.

    I initially thought it was memory problems - so, my mate put his wife's memory into my client's machine, and that worked fine, after several hours of disk testing, motherboard testing, CPU testing, memory testing. Still with her memory in it, he used a piece of software called Glaze, a graphics card tester, thus testing the motherboard and putting it under stress, plus he ran other apps as well, but the computer didn't cough up once.
    He ordered some more memory from Crucial, put it in, and it has worked fine since lunchtime today (Friday), (with Glaze running as well).
    So, he thinks that the person who built it must have used cheap and nasty, unbranded, memory

    The computer hasn't coughed up a single BSOD since Friday, however, I did a TuffTest this morning, and it came up with F001 - Invalid Function Request - Bad Command, for both the Seek Test and the Surface Analysis (like it did before) (I did that test about 2 hours ago). Just now I did it again, but this time it was fine; what's going on?
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    If you have stability and everything is going fine I wouldn't worry about it. Sometimes the issue can lie with the test itself.
  14. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    Toughest job

    As a computer engineer, this is one of the toughest jobs I've had to - purely because of the problems and the test results being intermittent. As you know from my last reply, a disk test with TuffTest produced an error, a couple of hours later no error, and I turned it on this morning 'from cold', and no errors this time either.
    I am now going to run Glaze continually to put stress on the motherboard and see if it fails, otherwise I shall have to give it back to my client and say bring it back to me if it coughs up again!
    Does that sound the best thing to do?
  15. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70


    On Sunday he brought it back to me saying that it crashed again while updating AVG.
    So, I booted up, it got stuck on the screen "Please insert CD or DVD".
    So I fixed the boot sector with the Vista installation CD.
    I then rebooted; got an error message (not a BSOD) but I couldn't read it as the computer restarted, then froze.
    So the Vista CD went back in, but no disks were found!
    I did a TuffTest, and a Surface Analysis yielded the error code F000.
    The same with the Media Analysis and Repair Test.
    So I am going to replace the disk.

    He bought the computer from a 'Palicomp' on EBay in March 2008. He first called me in June, how could everything go wrong (almost everything) within a year?
  16. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    First of all our recommendation here at TechSpot is to uninstall everything AVG plus using their removal tool to make sure there are no remnants. It is causing all kinds of issues for many, many people. We've lost count of how many people have regained stability by iuninstalling AVG and using another antivirus such as Avast, NOD32, Avira, and Kaspersky.

    Also, what about infections?
  17. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70


    I'm pretty sure the problem wasn't with AVG; even when Avast was put on it, it still failed.
    Anyway, the disk has got to be replaced, but surely the company he got it from should have made it so the disk doesn't fail within a year!
  18. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    You would think not, but I have seen hardware fail within 6 months. RAM, CD/DVD Drives, and harddrives, from my experience, can fail at any time without reason.
  19. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    Driver conflict?

    Everything is working again now, except...

    On the evening he took it home, he was installing the driver for his webcam, and he got the attached BSOD.
    He then went into Safe Mode, completely uninstalled; reinstalled in normal mode, and now everything works fine.
  20. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Thanks for getting back to us and glad to see everything is working fine.
  21. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70


    Are there any compatibility issues between webcams and Vista?
  22. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Yes. I have seen quite a few issues between webcams and Vista and a lot of times it comes down to the drivers for the webcams themselves.
  23. tommy2k8

    tommy2k8 TS Rookie Topic Starter Posts: 70

    New problem

    My client phoned me yesterday with another problem:

    The strange thing is that yesterday it refused to boot up for him, Vista said it couldn't detect a disk, but for me today, it booted fine!
    He also got a strange message yesterday, which he didn't tell me about til today, "Security oprions failure"
    No clues or errors in the Event Log
    Ran a chkdsk - no errors found.
    AVG, SpyBot - fine
    For some unknown reason, Firefox couldn't connect to the Net, but IE would; I discovered ZA had been uninstalled, but Ron said it was on there before he brought it to me! I installed the latest version, and then put a green tick in the Allow boxes for FF, which solved that - don't know why it disappeared in the first place!
    I found out that the error message 'The instruction at 0x768e03fd referenced memory at 0x768e03fd. The required data was not placed in the memory because of an I/O error status of 0x000000e' isn't related to memory!, as 000000 is an unknown address, and that it pionted to network connection problems.
    I checked that the network driver was up-to-date, which it was, and that's how far I've got!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...