Missing localesentCMP.dll

By infin ยท 10 replies
Mar 14, 2010
  1. Hi,

    My first post. I my anti-virus software AVG removed the below file after identifying a trojan. I need to locate and re install it somehow, it's absence is detrimentally affecting how text appears. The attached error message appears when i boot Windows ( i blurred out my username). I'm using XP and Firefox.


    Attached Files:

  2. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    hmm; an A/V product should not be running from that location.

    1. login as Admin
    2. uninstall the existing product
    3. reboot
    4. login as Admin
    5. reinstall correctly
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    i think localesentCMP.dll is part of malware. AVG disabled the malware by removing the .dll file but there's still more pieces. My guess: you have a startup that's still trying to call the now missing dll.

    Let's see if we can find it. Download Autoruns. Click autoruns.exe to run it.
    > Notice its status displayed in the in lower left corner of window.
    > Wait for status in lower left says Ready
    > Click File->Save As, save as a .txt (text) file and attach text file to next post
  4. Twisby

    Twisby TS Rookie

    I have the same exact problem. Until I've found out what localesentCMP.dll actually does and how I get rid of it completely I have at least disabled it in startup.
  5. infin

    infin TS Rookie Topic Starter

    I think it might have happened when my version of firefox failed in updating to the latest version for a couple of weeks so possibly became vulnerable during that period.

    I've attached the file.

    Attached Files:

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    There's a registry entry still trying to start file localesentCMP.dll. Run autoruns again then click Ctl-F and enter
    Click Find Next. When it finds the localesentCMP entry, rt click Delete it then exit Autoruns

    You can also delete the directory as well (note i replaced the userid with dashes below)
    D:\Documents and Settings\---\Local Settings\Application Data\localesentCMP
    @Twisby: Note you can do the above as well. The file localesentCMP.dll is malware you don't want on your machine
  7. infin

    infin TS Rookie Topic Starter

    Thank you, I followed your instructions and no longer receive the error message upon booting. I couldn't see a localesent directory at that location even with viewing the hidden files so was unable to take any action on that.

    However, some text in now appears in slightly the wrong places when browsing forums since I've had this malware. Could it be related to how text appears? I am unfamiliar with what these events may have influenced.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You're most welcome. Glad to hear it's fixed

    I'm not really sure about the answer to this problem. You might try reinstalling Java
    > Control Panel->Add/Remove Programs, then uninstall the Java entries
    > Then click here to re-install the latest Java

    But if the problem persists (and no other answers to your Problem with text placement in browser in this thread) you might try posting a new thread with a new title to draw responses from others about it

    Hope you get it fixed!
  9. therebehounds

    therebehounds TS Rookie

    Very nicely answered. I'm getting the same error message at startup and tried the above fix, but there's nothing listed by that name in the readout from AutoRuns. Any ideas? The .txt from AutoRuns is attached.

    Attached Files:

  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Look again. I can see it in your autoruns txt output file as well. Click your cursor at position at start of autoruns then click Ctrl-F to find localesentCMP.
    + "localesentCMP"	""	""	"File not found: C:\Users\Admin\AppData\Local\localesentCMP\localesentCMP.dll"
  11. therebehounds

    therebehounds TS Rookie

    *facepalm* Searched in AutoRuns the first time and didn't get anything. My mistake. Got it deleted anyway, thanks a lot.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...