Missisg audio due to missing SM Bus Controller?

By Phoenix_306 · 4 replies
Aug 31, 2006
  1. Hi guys - first time posting here, hope i'm not breaking any rules by being in the wrong forum or something!!!!

    Anyway - i'm well and truly stumped. Recently i formatted my PC and reinstalled XP. This was all great until i tried to play an mp3 to discovered i had no audio!!

    I've tried everything since - audio drivers etc etc, but nothing seems to work.

    According to the device manager, I have a couple of big yellow exclamation marks next to SM Bus Controller and SIS 7018 Audio driver. I've tried to reinstall
    the audio driver but it won't let me, and i can't find the Bus controller driver!!!

    gahhhh! help me please!!!!

    Please find below a summary of my system - hope this is of use!

    Thanks in advance!!!!!!!!!!!!!

    EVEREST Home Edition © 2003-2005 Lavalys, Inc.


    Version EVEREST v2.20.405
    Homepage http://www.lavalys.com/
    Report Type Report Wizard
    Computer MARK
    Generator Mark's Comp
    Operating System Microsoft Windows XP Media Center Edition 5.1.2600 (WinXP Retail)
    Date 2006-08-31
    Time 14:04



    Operating System Microsoft Windows XP Media Center Edition
    OS Service Pack Service Pack 2
    DirectX (DirectX 9.0c)
    Computer Name MARK
    User Name Mark's Comp

    CPU Type Intel Pentium 4, 2800 MHz (21 x 133)
    Motherboard Name MSI MS-6703 (TriGem OEM)
    Motherboard Chipset SiS 648
    System Memory 512 MB (PC2100 DDR SDRAM)
    BIOS Type Award (11/01/02)
    Communication Port Communications Port (COM1)
    Communication Port Communications Port (COM2)
    Communication Port ECP Printer Port (LPT1)

    Video Adapter NVIDIA GeForce4 MX 440 with AGP8X (Microsoft Corporation) (128 MB)
    3D Accelerator nVIDIA GeForce4 MX 440 with AGP8X
    Monitor Plug and Play Monitor [NoDB] (12426028)

    Audio Adapter SiS 7012 Audio Device

    IDE Controller SiS PCI IDE Controller
    Floppy Drive Floppy disk drive
    Disk Drive SAMSUNG SV1204H (120 GB, 5400 RPM, Ultra-ATA/100)
    Disk Drive Multi Flash Reader USB Device (117 MB, USB)
    Disk Drive SEAGATE ST3250823A USB Device (250 GB, 7200 RPM, Ultra-ATA/100)
    Optical Drive HL-DT-ST DVDRAM GSA-4167B (DVD+R9:8x, DVD-R9:4x, DVD+RW:16x/8x, DVD-RW:16x/6x, DVD-RAM:5x, DVD-ROM:16x, CD:48x/32x/48x DVD+RW/DVD-RW/DVD-RAM)
    Optical Drive JLMS DVD-ROM LTD-166S (16x/48x DVD-ROM)
    SMART Hard Disks Status OK
  2. Phoenix_306

    Phoenix_306 TS Rookie Topic Starter

    update on my problem!!

    Been messing about now doing various things, and now the problem has changed! I still can't get audio, but the two errors mentioned before have gone, and now in other devices under device management, it now has Multimedia Audio
    Controller with a yellow exclamation mark!!!!!

    what's going on?

  3. N3051M

    N3051M TS Evangelist Posts: 2,115

    It means that the drivers arn't installed properly. Download the latest ones from the website of your PC manufacturer or your motherboard/soundcard and install those over it..
  4. Phoenix_306

    Phoenix_306 TS Rookie Topic Starter

    I've tried all that. It's an Advent 3214 - the advent web site is useless, and there's barely anything online regarding my model pc. I've been on the MSI drivers website, but i can't find the drivers for my model.

    I've downloaded the drivers for SIS 7018 audio controller and run them to no effect. i have also downloaded and run the IDE setup files that are apparently for my chipset to no avail.

    i have an Advent system recovery disk, but i can't run it because everytime i do it says it can't continue because ntkrnlmp.exe is missing. however, i have made sure that this file is present in on the c drive - is it missing on the disk? (the disk is a little scratched).
  5. N3051M

    N3051M TS Evangelist Posts: 2,115

    Download SIW (system info for windows).

    Its kinda like everest (so you need to navigate to the info about your audio "card"), and it should link you to a site that has the drivers for your audio card
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...