Mobo + memory = POST failure

mobo:

asus.com/Motherboards/AMD_AM3/M4A88TM/

asus m4a88t-m


memory:

hynix.com/datasheet/eng/module/details/module_20_HMT125R7TFR8C.jsp?menu1=01&menu2=01&menu3=01&menuNo=1&m=1&s=1

hynix hmt125r7tfr8c




the board does no beeps, but it features MemOK! and has a dram_led... the dram_led is blinking red continuously... this is the ecc memory and the said board is supposed to support ecc... i tried reinstalling / reseating the memory - same result... i'm going to buy some other memory, but what could be the problem here? any help is appreciated
 
the power is fine, the onboard power led shows green... as soon as i hit the power button, the dram_led starts blinking and it just stays that way, the screen doesn't come up... tried clearing the bios, didn't help... any other suggestions?
 

dividebyzero

Posts: 4,840   +1,270
I would try booting the system with only one stick of memory. If that shows no improvement, then swap sticks and retry. Just for the sake of form I would repeat the exercise with the sticks in the second of the primary DIMM slots.
Next course of action would be- as you have already noted- to obtain another set (or stick) of RAM and try booting with that- preferably a module on Asus's memory QVL. If this option does not work either, then the problem is board related. Is the board known to be working, or is the board new/second hand but untested ?
 
i tried one stick, 4 sticks, 2 sticks all kinds of combinations and places... yeap the board should be working - it's a refurbished by asus board, still under warranty... i have another ddr3 board, this ram doesn't work in it either, but that one i think doesn't support ecc... i guess memory replacement is the only thing i can really do here
 

dividebyzero

Posts: 4,840   +1,270
You can try RMA'ing the RAM -at least if it gets returned then you'll know that it is either the board, or board incompatibility. You might also try testing the RAM in another system- if you have one handy.
The M4A88T-M isn't some workstation/server board - the board will take non-ECC as well as ECC memory.