Mohaa:Troubleshooting

Status
Not open for further replies.
I --- Common Initialization ---
Medal of Honor Allied Assault 1.11 win-x86 Mar 5 2002
----- FS_Startup -----
Current search path:
C:\WINDOWS\Desktop\mohaa\mohaa/main
C:\WINDOWS\Desktop\mohaa\mohaa\main\ZNV Light Scope.pk3 (7 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\znv light scope NS.pk3 (5 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\XtG 50 NSDAP.pk3 (20 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\xmp 70 mk II.pk3 (15 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\weapon hud.pk3 (20 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\UserModzAwesunds2_2.pk3 (49 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\User-ZDestroyed.pk3 (3 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\User-ubersoldat kar98.pk3 (22 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\user-N3O-E-Scope-NEON-Axis.pk3 (6 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\user-N3O-E-Scope-NEON-Allies(1).pk3 (5 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\User-Karabiner 98 Biathlon.pk3 (15 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\User-DagroovUltimate Gore.pk3 (12 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\user - Liquidfont.pk3 (5 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\user - jello CrosshairZ v1.pk3 (3 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\usa riot.pk3 (21 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Tokarev.pk3 (14 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Tokarev for axis.pk3 (3 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Springfield BB Gun.pk3 (14 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\pak6.pk3 (104 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Pak5.pk3 (259 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Pak4.pk3 (593 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Pak3.pk3 (669 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Pak2.pk3 (4722 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Pak1.pk3 (772 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\Pak0.pk3 (11175 files)
C:\WINDOWS\Desktop\mohaa\mohaa\main\combat gloves.pk3 (4 files)

----------------------
18537 files in pk3 files
execing default.cfg
execing menu.cfg
execing newconfig.cfg
Config: unnamedsoldier.cfg
execing configs/unnamedsoldier.cfg
execing safemode.cfg
^~^~^ Can't find localized.cfg
couldn't exec localized.cfg
execing autoexec.cfg
Unknown command "fov"
^~^~^ Can't find custom.cfg
couldn't exec custom.cfg
...detecting CPU, found Intel Pentium III

------- Input Initialization -------
Initializing DirectInput...
Couldn't set DI coop level
Falling back to Win32 mouse support...
------- Input Initialization Complete ------- 64
You are now setup for medium mode.
----- Client Initialization -----
Called FadeSound with: 0.000000

------------------
Event system initialized: 69 classes 244 events 67344 total memory in response list

----- Initializing Renderer ----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\SYSTEM\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
GLW_StartOpenGL() - could not load OpenGL subsystem
and then it wont let me play so whats my problem and how can i fix it?
 
I have the same problem!!!?

I have the same problem,and I don't know what to do to fix the problem. I'm very nervous and if you know how can i fix it please send me mail to my email adress: zdenman2000@yahoo.co.uk
Maybe I'll have a suprise for you.
 

olefarte

Posts: 1,314   +13
I had pretty much the same problem the other day. All I did was reinstall my video card drivers, and that fixed the problem.
 

LNCPapa

Posts: 4,315   +574
TS Special Forces
Could you enter your info in your profile please? If you have an ATI card and are using Catalyst 3.9 some people are experiencing this problem with all Quake III engines - which includes MoH. 3.8 and 3.10 do not have this problem afaik.
 
Trouble Installing

While Installing On Disk 2. The File Pak2.pk3 when i'm about 80% done overall it causes a component transfer error... says date files completed but file Pak2.pk3 either couldn't be done because of I/O hardware error. or says something about cyclic redundancy check. any help will be appreciated. thanks.
 
I had to uninstall MOHAA due to corrupt data. Now when I trie to install MOHAA it brings up Install Shield Wizard. the program gives me three choices:
Modify-Select componants to install (these are componants that have nothing to do with the accual game).
Repair-Reinstall componants installed in the previous setup (these are the same useless componants as the firt option).
Uninstall-completely remove the game and all its componants.
Please help me! :(
 
It seems that a bunch of ppl are havin that problem too. Not too long ago I tried to install it again and in the add/remove programs chart it says it's there. So, I click on change/remove and the same three options come up~Modify, Repair, and Remove. I've tried all three opts. several times and still git nothin. I've reinstalled it and it doesn't install the game. I'm VERY frustrated any help appreciated, thanks. ~P.S.-I'm very dumb with computers lol-~
 
try this

if your driver is the correct one and if the file opengl32.dll in in the windows\system32 dir.
go to gme dir and move the file opengl32.dll from thi directory
run the game.
 

Sharkfood

Posts: 1,018   +4
Hey guys,
MOHAA (.. and Spearhead) both have bugs with the OpenGL string that can cause them to crash on ATI videocards with certain driver revisions. It's not really an ATI bug, but a bug in the game as it can't handle a string of a certain size being returned by the drivers... and ATI fills it to it's fullest string (all other OpenGL games are fine with this).

I'm not 100% sure if it's been fixed yet by ATI, but there is a work-around that also is a good thing to try regardless.

The older, 4.12 OpenGL file from ATI yields some of the best performance in this game.. and OpenGL allows you to selectively place a file in the game directory so as this particular game will override the system OpenGL and use this one.

I've zipped up the 4.12 OpenGL file here:
http://zupload.com/download.php?file=getfile&filepath=24154

You can unzip this and place it in the same folder as the the MOHAA executable and the game *should* work if you are indeed experiencing the OpenGL initialization issue. This should also work for both MOHAA and MOHAA:Spearhead (full game and demos).

This is for ATI VIDEOCARDS ONLY.

Good luck and hope this helps! PLEASE REMEMBER you put this file in the game folder for future reference. If you upgrade drivers down the road, it may be incompatible with future drivers (but still works now even up to the 5.13 Catalyst drivers). You'll need to delete it if newer drivers render it obsolete.

PS- this mini OpenGL also works best for older OpenGL games like Quake, Quake2 and the like. It's the pre-OpenGL 2.0 DLL, so it does NOT support newer OpenGL games very well. If you still play games like Quake2 or Q2 engine games (or possibly even CounterStrike V1.6, NOT CS:SOURCE), placing this DLL in the game folder should yield much better performance as well.
 
Status
Not open for further replies.