1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

More memory = more crashes, but no errors with memory? (minidump)

By kungfujoe · 10 replies
May 11, 2006
  1. I just upgraded from a pair of Corsair CMX512-4000PRO (TWINX1024-4000PRO) memory modules to a pair of Corsair CMX1024-3500LLPRO (TWINX2048-3500LLPRO) memory modules, and I'm seeing some odd problems. Basically, if I run both modules, the system crashes. I can use it for some unpredictable amount of time, and it crashes. The only way to predictably crash it is to play Elder Scrolls IV: Oblivion for 10 minutes (as it's about the most demanding game in existence right now). Rarely do the first 5 minutes pass without a system crash. However, if I remove EITHER module, things run much more smoothly. I've run the two 512MB modules in this same system since I put it together in January (that memory was a holdover from my previous system), so I know the motherboard's DIMM bank 2 is not bad. In fairness, I haven't run either module individually for long enough to verify for certain that it's as stable as my previous memory modules, but I've run Oblivion for much longer than 10 minutes with each of them.

    Detailed system specs are in my profile, but in a nutshell:

    DFI LanPartyUT nF4 SLI-DR Expert motherboard
    Athlon 64 X2 4800+ CPU
    2GB Corsair TwinX Low-Latency memory
    eVGA GeForce 7800 GT video card
    SoundBlaster X-Fi Platinum sound card

    Nothing is overclocked in this system (the plan was to get everything running perfectly stably before I started bumping the speed up a bit), and everything is running the latest drivers (I just updated the MoBo BIOS yesterday just in case that improved memory compatibility).

    I've attached three Minidump files from crashes that generated BSODs (all of which were a bit different. I had STOP values of 0x00000050, 0x0000007E, and 0x0000008E). Unfortunately, most of the crashes are hard freezes. The whole system completely freezes, and there's nothing I can do to recover it. When this happens in Oblivion, the sound keeps looping, and upon reboot, the MS problem report tool tells me that the nVidia display driver is what crashed. When it happens elsewhere in Windows, the problem report tool generally doesn't come up upon reboot to give me an indication.

    I've run MemTest86+ (conveniently included in the MoBo BIOS) without any problems. I ran one module for 7 passes, the other module overnight for 22 passes, and then both modules together overnight for 13 passes. No errors in any of the tests, and no crashes or lockups during any of the tests.

    I'm hesitant to try to get Corsair or ZipZoomFly (still have a few days before their return policy expires) to replace the memory because I can't seem to find any evidence that it's faulty, but I don't know what else could be wrong. This motherboard is certainly common enough, and Corsair XMS memory is certainly common enough that I'd have expected to find any compatibility issues between the two when researching this purchase.

    Any help would most certainly be appreciated!
  2. WinDoWsMoNoPoLy

    WinDoWsMoNoPoLy TS Rookie Posts: 237

    You've hadn't, before the new memory, edited your registry at all have you? I'm mostly refering to the memory setting in there. Or changed the paging area for the memory? These could cause the problem or you could try them to fix it. Good luck.

    BTW, i can't read minidumps :p
  3. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Hello and welcome to Techspot.

    I can confirm, that ram is the culprit.

    This is either caused by faulty ram, or by ram incompatibility.

    1 minidump crashes with memory corruption and a bugcheck of 50.

    1 minidump crashes at win32k.sys and has a bugcheck of 8E.

    1 minidump crashes at you Nvidia video card drivers and has a bugcheck of 7E.


    Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).


    A kernel mode program generated an exception which the error handler didn’t catch. These are nearly always hardware compatibility issues (which sometimes means a driver issue or a need for a BIOS upgrade).


    A system thread generated an exception which the error handler did not catch. There are numerous individual causes for this problem, including hardware incompatibility, a faulty device driver or system service, or some software issues. Check Event Viewer (EventVwr.msc) for additional information.

    Go HERE and follow the instructions.

    Regards Howard :wave: :wave:
  4. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

  5. Spike

    Spike TS Evangelist Posts: 2,122

    maybe, but
    is not strictly true.

    It's something to be taken into account for sure, but to imply that mixing brands or speeds, or especially sizes, is likely to damage your system is simply untrue.

    Besides, as there is no indication of mixing memory in any respect, your comment is completely irrelevant here anyway.
  6. kungfujoe

    kungfujoe TS Rookie Topic Starter

    How is using a pair of matched memory modules mixing memory? Not only are the same model, their serial numbers are off by only one digit (as I'm sure all TwinX packages are, though my old TwinX modules didn't have any S/N listed). The only way to do less mixing would be to never use more than one module. :)
  7. Spike

    Spike TS Evangelist Posts: 2,122

    LOL! :D

    Very true.
  8. kungfujoe

    kungfujoe TS Rookie Topic Starter

    I think I've actually figured it out. I did test both modules individually, but I believe I actively used the system with one of them much more than the other. This morning, after running the MemTest on both modules together, I pulled one out, leaving in the one I wasn't using much yesterday. I noted the serial numbers so that I could easily differentiate between them, and after actively using the system for about an hour this evening, the system locked up. I fired up Oblivion, and after about 15 minutes, it crashed. It seems odd that with both modules, I can consistently crash the game in well under 10 minutes, but with only "the bad one," it takes longer. I haven't recorded any hard system crashes with only the other module installed.

    I definitely appreciate your analysis of my minidump files, and your confirmation that the problems are memory-related. It's ironic that 5 minutes in a new computer game tests RAM more rigorously than almost 9 hours of MemTest86+ (plus the amount of time testing that module individually - I didn't note which was which at first, so I don't know which module got 7 passes and which got 22). :)

    I was reading that two days ago, and used that to guide me a bit between then and when I posted. It's definitely an excellent breakdown of hardware troubleshooting methods.

    I literally pulled the old memory out, put the new memory in, turned the machine on, and that was it. I made no other config changes before the problem began (no BIOS changes necessary, since the BIOS was set to go by SPD for memory timings). And since removing one of the modules seemed to solve the problem, it seemed unlikely to be a swapfile or registry issue.
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Unfortunately, Memtest is not perfect and some faulty ram can and does pass Memtest. This is the same for every ram testing programme I`ve seen.

    I wish there was a utility that was better, but I have never come across one yet.

    The only thing I can say about Memtest is, if it does give you errors, then your ram is most deffinitely bad.

    Regards Howard :)
  10. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    My mistake, I thought you were using two different brands at the same time.
    In any case, perhaps the board doesn't like the timings. Some motherboards like Asus and Dell are very picky about memory. (The sticky also mentioned that.) Just go with with the brands the manufactuer recommends in the manual.
  11. kungfujoe

    kungfujoe TS Rookie Topic Starter

    With all due respect, are your regular contributions to TechSpot limited to simplistic responses aimed at newbies, but not based on reading the original post? I truly do appreciate you trying to help, but so far, both of your pieces of advice suggest you didn't really read the problem description, and both assume a lack of knowledge on my part, at a level basic enough that someone for whom your suggestions would be appropriate would have been extremely unlikely to have assembled the system that I did (which is by no means an ultra-power-modder-and-tweaker system, but it's also a very far cry from a "Dude, I got a Dell" system). The (apparent) assumption that the person you're helping is an extreme newbie also suggests that you didn't read the original post.

    Edit: Just to close out this thread properly, since I didn't explicitly state it before - I've narrowed down the problem to one of the memory modules. I've just initiated the RMA process with ZipZoomFly, and hope to have a fresh pair of replacement memory modules within a week or so ("pair" because I have to return them together even though only one is bad, since they were sold as a matched pair in a single package).
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...