1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Mouse and Keyboard acting strange

By jajohn · 33 replies
Jan 23, 2015
Post New Reply
  1. Hello, lately I've been having the strangest of problems:
    My mouse doesn't work as it should - sometimes clicking on something doesn't do anything, sometimes it does something different, as if some altering keys were pressed - eg sometimes clicking on a tab in a browser will close it (with left mouse button).
    I have tried to locate and update new drivers for my keyboard and mouse, since these are my guesses for what could be causing this, but couldn't find any driver for the keyboard and the driver for the mouse didn't change anything.

    My mouse : Trust MI-6970C Laser Mouse
    My keyboard: Genius KB-G265
    I'm running Win 7 Professional

    I can't think of any changes that I did at the time this started happening, so I'm really at loss.
    Thank you for any advice on this.
  2. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    Try them with another computer. If they both work OK suspect either a hardware problem with your computer or a possible malware infection. It could also conceivably be a Windows problem but the other two possibilities are more likely.
  3. jajohn

    jajohn TS Rookie Topic Starter

    Hi, I've tried them with my laptop and it seems to work okay.
    I've tried downloading a software to show me what I'm pressing/clicking/typing (OSD hotkey) and I'm not sure if it does that normally, but it shows me that I 'hold' whatever key/button I press/click.
    I did a full scan with my antivirus but didn't find anything.
    I will try to check for the malware, as that could require specialised software and not just a general antivirus I'm guessing.
  4. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

  5. jajohn

    jajohn TS Rookie Topic Starter

    Thanks for the link

    Is there any way to be 100% sure that this is the cause?
    Like some software that would check if it passes on what it's supposed to or something like that...

    I would rather not change the thing (or the whole motherboard) until I am sure it's the cause.

    I appreciate your help though.
  6. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    If there are no error beeps on start up you could locate the chip and see if it looks damaged or if it plugs in, whether it's loose. I'd expect it to be soldered on and hard to replace though. Somebody with technical qualifications is your best bet. Repair shops will of course charge for a diagnosis because identifying a problem is often not easy. I'm not aware of any software that will do what you want.
  7. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    If you hold down the Windows key and press "u" it gives you some ease of use options including Windows on-board keyboard that you could try, say with Word. Assuming this also uses the same motherboard controller chip then if it plays up this might well confirm it for you. I'm not too sure about that but it's worth finding out. In Control Panel there are sections about the keyboard that might tell you more about your keyboard and mouse.
  8. jajohn

    jajohn TS Rookie Topic Starter

    I'm back with some not very great news (mostly for me of course :D).

    So I decided, after what you told me and what I've also read on other sites about this problem, that my motherboard is the source.
    However, after buying a new motherboard (and a CPU and RAMs), formatting my harddrive and installing new windows 7, I ran into the problem again and really have no idea how it's even possible.

    So to summarize from the start:

    I changed my motherboard,RAMs and CPU, formatted one of my harddrives (the other one I kept because I greedily want my data (though in reality all of the big things are easily re-downloadable and the small important things would take max 1GB).

    I tried to unplug the keyboard to make sure it isn't messing with the inputs from the mouse, I tried a different laser mouse, I found my old PS2 ball mouse, I tried to use the numeric keyboard as a mouse (windows in-built thingy). Still the issue persisted, though for a while it behaved differently (clicking on a window would de-select it and render doing anything with a mouse virtually impossible, though I could use the scrolling wheel).

    My machine:
    Motherboard: MSI A88XM-P33 - AMD A88X
    CPU: AMD Athlon X4 860
    RAMs: Kingston HyperX Savage 8GB (2x4GB) DDR3 2133MHz CL11
    Graphic card: Sapphire HD 7750 1GB GDDR5
    OS: Windows 7 Professional (Currently without licence, as I didn't find the key, but I was and will be using a student license from my university)
    Keyboard::Genius Gaming KB-G265
    Mouse: Trust MI-6970C
    Instead of using speakers, I have a Genius HS-G550 headset plugged right into my computer.
    I have a LG Flatron IPS234V-PN Monitor connected by an HDMI cable.

    I realize most of this information is absolutely useless, but I'm providing it anyway in case you see something strange in it or whatever.

    Is there any utility or anything I could run and provide logs from?

    Note: I also wanted to format the harddrive with a 3rd party program since I don't pretty much ever trust Microsoft to do their job well, so I created a live GParted USB (using this tuxboot thing I found online).

    It didn't work though, giving me a message with something like "end Kernel panic - not syncing VFS unable to mount root" .
    That was only the last line,from which I was only able to get away with hard restart (long push on the turning button).

    Since my harddrives are the only part of the computer that I kept besides the graphic card (which I honestly can't see having anything to do with anything, but hey, who knows at this point) I was wondering whether they could somehow be so specifically faulty that they could cause stuff like this.

    I am thankful for any (constructive) input.
    And very thankful for your effort.
  9. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    I hesitate to suggest anything else. You replaced the motherboard which was the most likely problem with no improvement which to me brings us back to the keyboard itself and the mouse.
  10. jajohn

    jajohn TS Rookie Topic Starter

    I will try to get more different keyboards and mouses and check again if the problem prevails with them.
  11. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    I did spot this
    "OS: Windows 7 Professional (Currently without licence, as I didn't find the key, but I was and will be using a student license from my university)"
    After 30 days an unvalidated copy of Windows starts to have problems but I'd not have thought it would relate to keyboard and mouse. It's more likely to pester you with reminders.

    You haven't plugged the mouse into the keyboard by any chance rather than using separate usb ports on the tower?

    Is there any problem showing in Computer, System properties, Device Manager relating to the keyboard and mouse? You could try uninstalling them both and restarting the computer to check what happens with the Windows default drivers but you've probably already done this.

    Last edited: Feb 5, 2015
  12. jajohn

    jajohn TS Rookie Topic Starter

    Normally I indeed do have the mouse plugged into the keyboard, but I'm pretty sure I tested it plugged directly into the computer as well. Then I checked it right now and it didn't change anything.
    I have tried uninstalling the drivers, but didn't restart the computer after that. After plugging the mouse/keyboard back in, the drivers auto-installed (I guess some plug-n-play action or whatnot).
    I'm going to try to uninstall the drivers, turn the computer off, plug them in and turn it on, maybe it will make a difference.

    I'll come to share the outcome after.
  13. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    I suspect that until you restart the computer it will continue to use the same drivers even if you uninstall them. Also, I'd revert to separate usb ports on the tower for both the mouse and keyboard.
  14. jajohn

    jajohn TS Rookie Topic Starter

    Uninstalled, restarted (with both devices plugged into the motherboard).
    Unfortunately no difference.
  15. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

  16. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    I did read once that usb devices can be hacked and it caused a big security scare. It seems very unlikely but if you have an old style keyboard and mouse with the PS/2 socket and your tower has these connections it would be worth trying them to see if they work.
  17. jajohn

    jajohn TS Rookie Topic Starter

    I did try a ps/2 mouse and think I have a keyboard here as well, didn't try the keyboard yet.
    I'll try that tomorrow I guess
  18. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi, This could just be a USB port (socket problem), as you have changed the motherboard and installed Windows again, that rules out a faulty keyboard driver.
    Some PC's ( mine too) have a small USB board right at the front of the tower just under the DVD drive, it could have become faulty.
    If so, try plugging the keyboard and mouse into the USB sockets on the back of the PC where they plug right onto the motherboard.
    You don't say if you are using wired or wireless mouse/keyboaord though.
    I would suspect the keyboard or mouse though, the left and right buttons are usually pretty cheap switches ( a few pence/cents to make ) and don't last forever.
    Try or borrow a spare and see what happens.
  19. jajohn

    jajohn TS Rookie Topic Starter

    I will try to plug the mouse into a different socket, but (as I wrote before) I had the problem with this mouse (USB cable), anothere USB mouse, a PS/2 mouse, and without a mouse, using a windows ease of access tool that allows you to use your numerical keyboard to operate the cursor.

    Edit: Tried to plug it in a different USB port, didn't change anything.
  20. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    It's got to be OK with a simple PS/2 keyboard and mouse. Uninstall the Trust software for your laser mouse. There is no extra software for that gaming keyboard to mess things up. Are you sure no joker swapped the two motherboards when you weren't looking so that you put back the original one? ;)
    The only other thing I can think of is some exotic malware that your scans haven't uncovered.
  21. jajohn

    jajohn TS Rookie Topic Starter

    I have found that other people had similiar problems with the Battle.net application, but none of the ones I found also reported his browser not registering the keys properly.
    The PS/2 keyboard and mouse do the same thing as the USB ones.
    I haven't found any specific Trust software in my installed programs and am not sure how I would find it anywhere else.
  22. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    That's the first time you've mentioned "Battle.net." I've never heard of it. If it's a known problem then you should either uninstall the software that's screwing up your computer or follow this up on a specialist gaming forum. "Battle.net" may have it's own support but It sounds like something to leave well alone.

    I just read a PDF on Warcraft II from Battle.net and we are talking very old games from the era of Windows 98 so it's no surprise that modern systems are not liking it. 64 bit Windows 7 seems to have loads of problems with Warcraft. Your computer spec and OS are probably unsuitable. Gaming keyboards and mice were not around at that time.
    Last edited: Feb 8, 2015
  23. jajohn

    jajohn TS Rookie Topic Starter

    Oh wow, I'm stupid not to mention it earlier. I thought I did, but apparently not.
    After some further testing, these are the problems I've encountered so far(that I consider to be of the same nature):
    In Opera - my web browser - clicking on the tabs (which should switch them) does nothing.
    Just tried Internet Explorer and it works there.

    Then. Battle.net - a program used to access blizzard games (Hearthstone in my case, but also Diablo III, WoW, and Starcraft. But all of them except of Hearthstone can be run by shortcuts from outside of Battle.net).

    In this program I can use my mouse to scroll, when I hover my mouse over buttons they seem to register it (they glow), but clicking on anything in the program does nothing.
    I looked into the problem on their site and found a few threads where people had similar problems, but after going through the threads I found that what solved it for them does not work for me, or can't even be done in my case (e.g. faulty logitech drivers, problems on Mac).

    Once again I'm sorry for not mentioning it earlier, as it's kind of a crucial information.
    I thought I said it in the first post and apparently,for some reason, I didn't.
    I realize how hard it is to solve anything if you encounter a new information after trying to solve a problem for some time.
  24. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +252

    You haven’t said whether all these problems with keyboard and mouse are present only when you try to run the games or whether they are there all the time. If they are there all the time you need to uninstall the problem software and make sure everything is OK with Windows.

    Again, do you have Windows 7 32 bit or 64 bit installed? If it’s 64 bit I think you are wasting your time. You could try again after installing the 32 bit version of Windows 7 but there’s no guarantee of success there either.
  25. nickc

    nickc TechSpot Paladin Posts: 921   +11

    Bazz, I do not think u would find any deference in 32 bit and 64 bit of Win 7 other than the amount of mem. they can see. and even that has to do with MB used.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...