mouse stops responding

By Soap ยท 7 replies
Jun 8, 2004
  1. i have a microsoft optical usb mouse and up until about 2 days ago it had been working perfectly. Now it stops responding for some unknown reason.

    ive tried unplugging it and then plugging it back in but this doesnt always work and more often than not after plugging the mouse back into the usb plug the base of the mouse doesnt light up.

    Has anyone else struck this problem? or know how to fix it?


    edit: btw im using windows xp pro if that helps.
  2. Masque

    Masque TechSpot Chancellor Posts: 1,058

    First of all, are you plugging directly to the machine or to a hub? I've seen some issues with hubs and some devices not always recognizing properly.....intermittent life yours. Also, have you tried a different USB port on the machine? As well, have you tried another USB mouse to see if it reacts in similiar fashion?
  3. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Have you added anything new to USB, as it might not have enough power to push them all? Although the mouse should be minimal.
  4. Soap

    Soap TS Rookie Topic Starter Posts: 72

    I'm plugging directly into the usb on the board itself. At the moment ive just swapped the printer and the mouse around to see if the different usb makes any difference. I havent tried a another usb mouse yet but i will try and find a friend who has onee which i could borrow as teh only other mouses around my house arent even ps2.

    The only new addition has been as usb infra red thing for my mobile phone but that was over a month ago, would it be possible that im only starting to see problems now?

    edit: mosue just cut out again and it reminded me of another and probably very important detail when i plugged the mouse back in the monitor screen went blank and didnt comeback on until the computer was reset. is that a power issue with the board? time to buy a new one or repair something on it?
  5. young&wild

    young&wild TechSpot Chancellor Posts: 993

    Just curious. is this your first USB mouse?
  6. Soap

    Soap TS Rookie Topic Starter Posts: 72

    well yes it is my first usb mouse ive had it ages and ive never had a reason to get a second one. just curious...what is the point of that question?
  7. stelex

    stelex TS Rookie

    I have similar problem.

    I had MS optical mouse blue, plugged into the PS/2 port via adapter (USB/PS2). It worked for long and one day when I wanted to wake up the PC from the sleep mode( mind you, this is just the monitor pwr savings func., PC ran all the time) I moved the mouse - nothing. Hit the keyboard and the screen came up. Looked underneath the mouse - no red light. OK, I thought - reboot. But it did not fix.

    Then I tried it in USB port, nothing. Another USB mouse - no work. The third one, this one wireless optical blue - nothing. Tried all in PS2 and USB - nothing.
    Tried all those mice on another PC - all work fine.

    Then I took my old Logitec (ball) mouse, plugged into PS/2 and it worked fine.

    But after a while that one starts behaving funny, chokes a little and then freezes as well.

    Checked all hardware (physically) looks OK. Played a little with memory (2x256 MB Kingmax DDR on 333 MHz), swapped modules places and it worked ... for a few days. now, it does the same.

    About o/s - I'm on Win XP home SP2rc2.
    I have performed clean install of Win XP home - did not help. Added all updates - nope ! Added SP1, then SP2rc1, then SP2rc2 - all the same, makes no difference.

    At the moment running memtest on that computer to see if the memory might be the cause ...
  8. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    There was a recall about two years on specific Intellmouse brand mice. The problem was very simliar to what you are experiencing.

    So it is possible that you have a bad mouse.

    What I might suggest is searching for more details about Microsoft's Intellimouse recall and see if the symptoms apply to your specific mouse. If so, they may still replace it for you free of charge.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...