MSCONFIG: An Access Denied error was returned

Status
Not open for further replies.

zillah

Posts: 80   +0
http://www.google.com.au/search?hl=...nt+to+make+the+specified+changes&start=0&sa=N

https://www.techspot.com/vb/all/windows/t-42578-MSCONFIG-access-denied-error.html

http://www.pchell.com/support/msconfig_access_denied_error.shtml

An Access Denied error was returned while attempting to change a service. You may need to log on using an Administrator account to make the specified changes

I have read a lot of threads on different forums but I could not overcome this issue yet that I have been experiencing for a while.

1- I logged as a user that has admin privilege on Win XP SP3.

2- I am expereincing this problem in both normal and safe modes.

3- Yes I do have hp OfficeJet Pro L7590 driver and utilities installed, on my laptop and desktop ,,,as far as i remember (to be checked) I have got no problem with the laptop , only with desktop.

4- When I had Avast AV free version I had this problem.

5- Then I uninstalled Avast AV and installed ESET smart security same problem still going on.

6- I tried many online scanning to make sure that there is no spyware or malware installed on the system.

Any other suggestions ?

Thanks
 
it seems u got urself some trojan or worms...try Process Explorer & Autoruns from SysInternals.. They ll help u have a look at the various processes that are executed at start up and also the currently running..Remove any suspicious ones n see if it helps..also do check the LOGON tab in Autoruns...delete any suspicious registry keys...


Note: A lot of trojans,worms and viruses can & are outsmarting the Anti viruses...So try n see if u can heal ur system manually...
 

Bobbye

Posts: 16,314   +36
I have 2 suggestions:

1. Start> Run> type in services.msc> double-click on the Service> make the change> check the Dependency tab to see if it is dependent on another Service to run.

2. IF that doesn't work, if it IS permissions issue, running one of the following should fix it:

RatsCheddar
It is a Policy Controller program written by Rathat to remove certain restrictions on XP systems often disabled by malware.
  • 1 Download RatsCheddar.zip and save it to your desktop.
  • 2 Extract (unzip) the file to the desktop.
  • 3 Double-click on RatsCheddar.exe to launch the tool.
  • 4 Select Enable for everything listed, then click Exit.
  • 5 Restart your computer.
Warning: This program was developed for Windows XP ONLY. Do not run this program in any
other Operating System.

OR

FixPolicies.exe from Bill Castner:
  • 1 Download FixPolicies by Bill Castner and save to your desktop
  • 2 Double click on FixPolicies.exe to run it.
  • 3 Click on Install. It will create a folder named FixPolicies on your desktop.
  • 4 Open the FixPolicies folder.
  • 5 Double click on Fix_policies.cmd to run it. Command Prompt will open and close quickly; this is normal.
Thanks to kimsland.
 
I have also seen this when viruses have been removed or when the security of the system has been compromised (removing a user account improperly, etc.).

1. A lot of the times when you see this error message, you can still apply the changes you want; you just have the annoying pop-up screen.
2. Do check your security! Update and run scans!
3. Check for hidden process and files aka Rootkits; nasty little dudes...
4. Hi-jack this; run a scan and analyze it with one of the many online analysis tools! See whats bad, good and un-needed.
5. Sysinternals; Autoruns, Filemon, Regmon, etc. Great tools for finding/catching malware.

Jon-Eric Pienkowski
_________________________
Pacific NorthWest Computers
pnwcomputers.com
 

Bobbye

Posts: 16,314   +36
I could find that this under services (Local), is this typo or my misunderstanding ?

It's neither. #2. is a suggestion to resolve a permission problem, not a specific Service.

There is a blue line through Service Layer which is Disabled. ?Is this just because the cursor happened to be on this line?

I have an HP all in one and it sees to me that I just unchecked this driver on msconfig. So give that a try- after you run one of the policy programs. I did not do any registry edit to stop mine.
 

zillah

Posts: 80   +0
There is a blue line through Service Layer which is Disabled. ?Is this just because the cursor happened to be on this line?
It is disabled not because of the the cursor happened to be on this line.

Thanks
 

Bobbye

Posts: 16,314   +36
Well. I guess I'm going to have to pull it out of you! Gosh, I hate to assume, but I'll give it a try> this is the Services you are trying to change> Right? Wrong?

It's not a Microsoft Service. the Service Layer 'Service' is for a Nokia Connectivity Library support task. If you know that already, just skip the sentence! HERE is more information on what uses this Service.

All this 'pulling' is simply because the message An Access Denied error was returned while attempting to change a service. gives no indication whatsoever of which Service you are trying to change.

Had this been a standard Service for the Microsoft operating system, I might not have had to play so dumb! In troubleshooting problems like this, where there could be a malware explanation, knowing specifics goes a long way!

You also threw this in:
Yes I do have hp OfficeJet Pro L7590 driver and utilities installed, on my laptop and desktop
which is related to the permission problem, not the Service itself.

If you choose to be more specific, maybe I can help> we need to determine if it's a problem with the 'Service Layer' itself or whether it's a permission problem!
 

zillah

Posts: 80   +0
Thanks Bobbye

If you choose to be more specific, maybe I can help>
I would love to be more specific, but I do not how to be more specific

but I'll give it a try> this is the Services you are trying to change> Right? Wrong?
Which services do you mean ? initially when I tried to disable some programs that start up with windows OS automatically, I received this error message.

I tried to

RatsCheddar
It is a Policy Controller program written by Rathat to remove certain restrictions on XP systems often disabled by malware.

* 1 Download RatsCheddar.zip and save it to your desktop.
* 2 Extract (unzip) the file to the desktop.
* 3 Double-click on RatsCheddar.exe to launch the tool.
* 4 Select Enable for everything listed, then click Exit.
* 5 Restart your computer.

Warning: This program was developed for Windows XP
ONLY. Do not run this program in any
other Operating System.

OR

FixPolicies.exe from Bill Castner:

* 1 Download FixPolicies by Bill Castner and save to your desktop
* 2 Double click on FixPolicies.exe to run it.
* 3 Click on Install. It will create a folder named FixPolicies on your desktop.
* 4 Open the FixPolicies folder.
* 5 Double click on Fix_policies.cmd to run it. Command Prompt will open and close quickly; this is normal.

Thanks to kimsland.
I tried the quote above but did not solve my issue.
 

Bobbye

Posts: 16,314   +36
Okay, that was one thing known to cause the problem. Best suggestion at this point is to go through this:
Virus and Malware Removal.

Between us we've pretty well eliminated everything else. The programs you'll run may find something previous programs didn't.
 

zillah

Posts: 80   +0
Hi Bobbye

Okay, that was one thing known to cause the problem. Best suggestion at this point is to go through this:
Although I have used all the tools that are listed in the "Virus and Malware Removal" section and I am still using it and beside that

6- I tried many online scanning to make sure that there is no spyware or malware installed on the system.
.

but I will try them again and post logs,,,,,,do you want to post log here or start new thread in the "Virus and Malware Removal" section ?

Thanks
 

Bobbye

Posts: 16,314   +36
Best to move to the other forum. Hopefully there will be someone who can check the logs for you.

Since malware can cause the problem you are experiencing, it in absence of anything else at this time, it needs to be ruled out-or ruled in!
 
Status
Not open for further replies.