1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

My 2TB WD Green has fast write speed but slow read speed

By pioneerx01 · 12 replies
Aug 31, 2010
Post New Reply
  1. Last week I have purchased a WD 2TB Green Drive as well as a non-raid capable raid card Rosewill RC-212; since my older PC (WinXP32, Celeron D, 1GB RAM) does not have SATA ports. I have installed fresh drivers form Rosewills’ website even though they are not needed for non-raid configurations. The PC recognized the card right away as well as the HDD. The write speeds are as expected, however the read speeds are between 300KB and 2500KB. I cannot figure out why the read speeds do not exceed 2.5MB? I have plugged the HDD as an external drive via USB and the read/write speeds are as expected. Anyone knows why and how to fix it?

    I have tried 1TB WD green drive (1.5-year old) and it works as expected.

    Update 2:
    I have just spoken with Rosewill tech and he said that using PCI card and such a large drive it is expected to be slow. Personally I believe it is B.S. You?

    P.S. for moderators: I have similar thread under storage and networking, but it no longer applies as such issue. Please delete it.
  2. mailpup

    mailpup TS Special Forces Posts: 7,309   +580

    The Rosewill card's transfer rate is "up to 1.5GB/s." The WD hard drive's is 3.0Gb/s. Perhaps if you set the jumper on the 5-6 pins to activate the 1.5GB/s rate per this instruction: Western Digital.
  3. pioneerx01

    pioneerx01 TS Guru Topic Starter Posts: 277

    Yes, I have done that too. Than I have also tries jumper 7-8 since it is an XP machine as instructed bu the HDD sticker itself. Than I was trying all sorts of jumper combination and nothing.

    I have a feeling that this controller is not fully compatible with my 2TB HDD (since it is compatible with 1TB, SATA2, and no jumpers). I have orders a difference controller from other manufacturer, so we will see. It does have the same VIA chip as a RAID controller, so hopefully that is not the cause of the issue. We will see...
  4. mailpup

    mailpup TS Special Forces Posts: 7,309   +580

    Yes, perhaps the card doesn't fully support drives as large as 2TB.
  5. pioneerx01

    pioneerx01 TS Guru Topic Starter Posts: 277

    That is what I am thinking. I have jet to find another "looser" like myself that needs a HDD controller to have a 2TB drive since his MOBO has only IDE. I guess I am going to "pioneer" the way :) get it
  6. DrRochdale

    DrRochdale TS Rookie

    That loser has been found! :)

    I just googled, "write speed fast read slow?", this was the first hit, I have just purchased the same drive and needed to connect to my existing NAS (old ugly tower computer that sits in my garage, with a gig LAN, and wake-on-lan configured).

    Anyway, the issue is the same for me, I need to connect the drive to an old Raid VIA6421 Card. The write speeds are normal, but the read speeds are awful, so bad I cannot stream media over the LAN.

    What was the outcome of your issue, I'm glad the issue is related to the RAID card and not the drive itself, did a replacement RAID card solve the issue, if so which one did you use? I appreciate this is an old thread, worth a shot. Thanks
  7. pioneerx01

    pioneerx01 TS Guru Topic Starter Posts: 277

    The computer motherboard (at least the south bridge) was too old to support 2TB drives. I have put the drive on different (newer) motherboard and it was all OK. So my solution was to get new hardware...

    There is not much you can do with raid cards or drivers if you hardware is old for this. Sorry

    You could put in in external enclosure. It will work "full speed" via USB port
  8. DrRochdale

    DrRochdale TS Rookie

    thanks for the quick reply, hmmm, I don't really want to configure the drive via USB (I do have a Sata USB Kit which will let me do this) as I actually purchased two 2x2TB drives to upgrade my old NAS drives (7 drives in total, reaching only 1.9TB), however I do not have many options as the motherboard of this tower only supports IDE, looks like an upgrade of the mobo is due, rather than shopping around for a raid controller that will work, thanks for help!
  9. pioneerx01

    pioneerx01 TS Guru Topic Starter Posts: 277

    No raid controller will work (probably) as it is still connected to the old motherboard that can not support 2TB drives.
  10. DrRochdale

    DrRochdale TS Rookie

    Okay, I'm sure I have an old PC lying around with Sata capability, my overall goal is to increase storage of my three year old "beast of a custom NAS", and reduce power consumption. Over the years I've just been adding more drives without thinking of the power consumption, time to replace the mobo with something more eco as well as sata capabilities.

  11. ninguno

    ninguno TS Rookie

    Hi pioneerx01! I have the same problem, slow reads in WD20EARS with a Rosewill RC212 card. I understand your solution was to change motherboard, what was you're old and new mother when the disk became to work as expected?
    Thanks in advance!
  12. pioneerx01

    pioneerx01 TS Guru Topic Starter Posts: 277

    Well, yes after bit of tinkering. Keep in mind that the "new" motherboard had on-board SATA ports, so I was able to bypass the RC212 all together. I do not believe that I have even tried it, I just went straight for on-board SATA. I still had to update motherboards SATA controllers with newest drives to utilize full 2TB. I don't think this is what you wanted to hear. Try few things:
    • Maker sure you have a quality, undamaged cable, believe me I had that happen just few days ago that performance suffered because of bad cable. You may not see if the cable is damaged, just swap it to be safe.
    • Get the latest, and OS appropriate drivers for RC212
    • See if you can update your chip-set drivers on your motherboard, see manufacturers website.
    • If you are using Windows XP you will probably need to use the advanced format utility Western Digital has on their website. I believe that you will need to re-format your drive to do that, so transfer any data to another location.
    That is all I can tell you for now that might help. Try it and see what happens. If you have new information start a new thread with all the info that you have and maybe someone has a solution. Email me if you start a new thread so I can follow as well. Good luck.
  13. ninguno

    ninguno TS Rookie

    Thanks for your advices pionnerx01!

    I already tried the cable and rc212/mother drivers thing so I think I should look to a newer motherboard, cause it's a really old one (MSI K7N2Delta with Socket A, almost 10 years of operation!!!).The only thing I don't tried yet was the advanced format utility.

    Or maybe left at is, cause is a pc used most for backups or storage things. ;)


Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...