My PC lags for 3 seconds and then comes back to normal for every 5-10 mins

Hi I have a computer with GeForce GTX 1070, i7-6700, 2400 16gb RAM, 250 SSD, and a 500gb HDD. I’ve been playing games on my computer for a while but I never had an experience of lag on my pc. Every time I play games or even just searching up something, my pc lags for 2-3 seconds and then comes back to normal. It happens very often for like every 5-10mins. Is there any way I could fix this? I would really appreciate it if someone could help me with this. Thank you :)
 

JimFew

Posts: 8   +1
I have seen this issue. For me it end up being a problem with the SSD. Replacing it resolves the issue there.
 

Cycloid Torus

Posts: 4,640   +1,444
I have seen this issue. For me it end up being a problem with the SSD. Replacing it resolves the issue there.
Might be true here, but the other steps are much cheaper than buying a new SSD - unless it first shows up with an error state in a manufacturer's test utility. The test utility would be the step right after DISM and SFC....
 
  • Thread Starter Thread Starter
  • #5
Might be true here, but the other steps are much cheaper than buying a new SSD - unless it first shows up with an error state in a manufacturer's test utility. The test utility would be the step right after DISM and SFC....
I did everything except for DISM because I don’t know how to do it. Can you guys explain to me on how to do it please. It still lagging when I play games. A friend told me that it might be the thermal paste because my cpu’s temperature was high. Now that I applied a new thermal paste it still does not help. I hope buying a new SSD will solve the problem if DISM won’t work. I appreciate you guys helping me :)
 

Cycloid Torus

Posts: 4,640   +1,444
DISM & SFC are a 'one-two' punch so run according to this: https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker

If that does not help, it is time to locate the testing utility for the HDD and the SSD and to test them (download from manufacturer's website). Please report results and provide manufacturer, model and detail on how much is stored on the drives. Look for firmware and driver updates as well.

If not fixed, run Malwarebytes (free edition).

Check Device Manager for errors.

Check Reliability Monitor for failures and warnings

If that doesn't help AND both games and search have lagging issue still, try Search Troubleshooter: Start > Settings > Update & security > Troubleshoot, then Click Search and Indexing and Click Run the Troubleshooter - describe problem as "lags"

If that has not corrected the issue, try Task Manager - sort by CPU use - and run in a window while running game or search in another window. When you note a lag, check what is running heavily in Task Manager.

Still stumped? Well, I am too. So then confirm you have backups of your data files and license keys to all your programs, because the next step often leads to a clean install of a fresh copy of Windows. Alternate might be to install fresh windows on new SSD...
 

Jerry in WA

Posts: 6   +0
I had a similar issue that was resolved when I changed my color settings back to default. I had wallpapers set to change every minute and I also set the colors to change with each wallpaper. Every time my PC would cycle this wallpaper/color change, there was a lag. (4790k/16gb/gtx1070/2tb nvme). Once I set the colors back to a single color, the cycling wallpapers had no lag effect.

Settings > Personalization > Colors > Choose your accent color : (uncheck box)
 
  • Thread Starter Thread Starter
  • #8
I had a similar issue that was resolved when I changed my color settings back to default. I had wallpapers set to change every minute and I also set the colors to change with each wallpaper. Every time my PC would cycle this wallpaper/color change, there was a lag. (4790k/16gb/gtx1070/2tb nvme). Once I set the colors back to a single color, the cycling wallpapers had no lag effect.

Settings > Personalization > Colors > Choose your accent color : (uncheck box)
I have the same thing my wallpaper changes every 5 mins. I hope this resolves my issue.
 

Latest posts