Neither CDRWs drives will write.

By scumbag ยท 7 replies
Jan 6, 2006
  1. Bit of an odd one this...

    I have 1 DVDRW & 1 CDRW each. Both work great when it comes to reading but neither will copy anything at all, either using Windows drag & drop or Nero. I've tried lots of different kinds of files.
    I've also used 2 different kinds of CD's.

    I get the error message
    "There was an error in the writing process. The disc you have attempted to write may no longer be usable"

    I've used loads of discs, all clean, so I doubt this very much.

    I've recently Installed a new version of Windows (Home, a kosher copy, no downloaded crap) and the problem seems to have happened since then.

    I've also run an error check on my C drive and uninstalled Norton Systemworks. It still doesn't work.

    I've right clicked on both discs & made sure the relevant boxes are ticked, I've also tried writing at slower speeds.

    A bit of a puzzler this. It's got me stumped?

    Any ideas?
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    try set to udma/dma mode they may have defaulted to pio
    I can't drag and drop to copy, I don't think anyone can
    there has to be an api interface
    I would also try another copy utility to there are free ones on line.
    nero can and will always be buggydo you know where event viewer can be found ,under computer management
    system tools
    there can be clues here why write is failing
    I have the IMAPI CD-Burning COM Service disabled on my xp pro
    but I don't use cd burner just dvd it burns cd's just fine
    look into firmware upgrades for your devices
  3. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    It might be a driver issue. The drivers for your optical drives come with Windows and when you updated Windows, it may have affected the driver. Try going to the Device Manager (IDE ATA/ATAPI controllers) and uninstall each optical drive. When you restart, Windows will detect the "new" hardware and reinstall the drivers. Note, you are not physically removing the drives. Hopefully, that will clear up your problem.

    BTW, while you're in the Device Manager, you may as well check all your devices for any yellow exclamation marks. You don't have to look too hard. It will be obvious. If there are any, you likely have driver problems with them as well.

    Edit: Samstoned posted while I was still writing. Uninstalling the devices is one way to clear the DMA to PIO issue too.
  4. scumbag

    scumbag TS Rookie Topic Starter Posts: 18

    I've been to device manager & uninstalled both the drives & restarted my PC.

    They were both recognised correctly by Windows and apparently installed properly!

    I've also updated drivers etc but that doesn't seem to do any good either.

    Could you tell me more about this udma/dma mode please? That's a new one on me, it sounds like it's worth looking into.

    Oh, and when I said about drag & dropping I meant using the inbuild Windows burner, the one supplied by Roxio. I've tried several ways of getting stuff onto the disc, right clicking & using send to, D&Ding etc but nothing seems to work.

    Anyway, here are my stats if they help

    Operating System System Model
    Windows XP Home Edition Service Pack 2 (build 2600)
    ASUSTeK Computer INC. A7N8X2.0 REV 1.xx
    Enclosure Type: Desktop
    Processor a Main Circuit Board b
    2.20 gigahertz AMD Athlon XP
    128 kilobyte primary memory cache
    512 kilobyte secondary memory cache Board: ASUSTeK Computer INC. A7N8X2.0 REV 1.xx
    Bus Clock: 200 megahertz
    BIOS: Phoenix Technologies, LTD ASUS A7N8X2.0 Deluxe ACPI BIOS Rev 1003 03/19/2003

    ARTEC WRR-52X [CD-ROM drive]
    PIONEER DVD-RW DVR-107D [CD-ROM drive]
  5. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    Here's a link to information about DMA and PIO: Click here.
    However, if that was the problem, uninstalling and reinstalling should have fixed it.
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    check in bios settings for udma and pio
    or right click on the drive when you go to in the computer management/ removable storage/liberarys
    see if they are enabled
    I did not have to do it but you may need to add a jumper to drives.
    when you install disc does the light on the drive flash a certain way,check website for error codes
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Give this a try.

    1. Start Registry Editor by clicking start/run, and typing regedit into the run box. Press the enter key.
    2. Locate the UpperFilters value under the following key in the registry:
    3. On the Edit menu, click Delete, and then click OK.
    4. Locate the LowerFilters value under the same key in the registry:
    5. On the Edit menu, click Delete, and then click OK.
    6. Quit Registry Editor.NOTE: After you remove the Upperfilters value and the Lowerfilters value, if you notice lost functionality in a particular program, such as CD recording software, you may need to reinstall that software. If the problem recurs, consult with the software vendor for assistance.

    7. Restart your computer.

    Regards Howard :)
  8. scumbag

    scumbag TS Rookie Topic Starter Posts: 18

    Weeeeell... I tried the registry fix suggested but could only find a maximum entry, no minimum.

    I deleted it but it still doesn't work.

    I've also looked in the BIOS for the udma & pio but can find no reference to them.

    Bummer huh? This is really beyond me :-(
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...