Netbook won't connect to wireless Internet

By HarlequinPuppet ยท 4 replies
Aug 26, 2011
Post New Reply
  1. My parents have a Samsung N150 netbook which worked fine with their old modem however they recently got a new one- a D-Link DSL-2730B and it won't connect wirelessly to it, only with the ethernet cable. Every other computer and laptop in the house works with the new modem so I don't understand what's wrong. Is it the drivers? I tried to find an update but couldn't.. Would really appreciate some help as my parents are going to nag me until I fix it. Thanks in advance.
  2. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    So you got N150 using it with N150 netbook.

    Make sure you have this router adsl modem in the mix mode: 802.11b/g/n Try that. Does this router see this Netbook in it's DHCP Tablet? What OS is on that netbook?
  3. HarlequinPuppet

    HarlequinPuppet TS Rookie Topic Starter Posts: 16

    Hi, thanks for the response. Yes, the router is already in mixed mode and the netbook is listed in the DHCP clients. It's running XP.
  4. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    when you attempt the connection, do you see the SSID at all?

    it is possible that the WiFi is defaulting to OFF . ..
  5. HarlequinPuppet

    HarlequinPuppet TS Rookie Topic Starter Posts: 16

    Yes it is there and I can click it to connect and the box will come up to say it is establishing the connection. It stays like this for several minutes and then disappears without having connected.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...