Network access lost in regular mode, not in safe mode

By gscal · 20 replies
Dec 10, 2008
  1. I have XP system.
    I got infected with some malware.
    This ended making my PC lock up repeatedly, forcing me to shut the power off to restart. I also lost all network access from the regular windows mode.

    I used Malwarebytes Anit-Malware to remove the virus, as well as adaware to clean things up. The machine now successfully boots up and shuts down without having to turn the power off, but the network connection is still lost. I only have access to anything through safe mode. I can't even ping in regular mode.

    I have tried to set the services started at startup and processes running at startup down to the same as safe mode, but still no luck. Anything that tries to access the network simply hangs. There are no error messages returned, just nothing.

    I have tried a number of things, including running HJT. I have attached the log file from that run.

    Any help would be appreciated.
  2. rf6647

    rf6647 TS Maniac Posts: 829

    Since Safe Mode with networking is working for you, I suggest using SDFix and see what relief you get.

    1. Download SD Fix to Desktop From Here

    2. On Desktop run SDdFix. It will run (install) then close.

    3. Then reboot into Safe Mode
      • As the computer starts up, tap the F8 key several times.
      • On the Boot menu Choose Safe Mode.
      • Click thu all the prompts to get to desktop.

    4. At Desktop - SD Fix does its job
      • My Computer C: drive. Double-click to open.
      • Look for a folder called SD Fix. Double-click to enter SD Fix.
      • Double-click to RunThis.bat. Type Y to begin.
      • When prompted hit the enter key to restart the computer
      • Your computer will reboot.

    5. On normal restart the Fixtool will run again and complete the removal process. Then say Finished

    6. Hit the Enter key to end the script and load your desktop icons.

    7. Once the desktop is up, the SDFix report will open on screen and also be saved to the SDFix folder as Report.txt.

    8. Attach the Report.txt file to your next post
  3. gscal

    gscal TS Rookie Topic Starter

    SD Fix attempted

    I've run the SDFix now. It appeared to end abnormally on the second step that runs after reboot. I ran the RunThis.bat with the F option to finish. Network access is still not working outside safe mode. I've attached the Report.txt. I also noticed a catchme.log on the desktop created, so I am attaching that as well.

    Thansk for the help so far.
  4. rf6647

    rf6647 TS Maniac Posts: 829


    The real curse is not viewing your problem with an open mind. Your description speaks more about a networking problem. Removal of infections did not clear this symptom from the preceding problem.

    The safe mode portion of SDfix is comprehensive, and deleted 1 file from recycle bin. The 'catchme log' is unexpected and showing a disk read error for the 'recycle' folder looking for the deleted infected file - is more a symptom of a program error that was not handled.

    Before throwing another scan at the computer, let's try repairing 'winsock'.

    Fix XP internet connectivity with WinSock XP Fix

    Also check this page for more info - Winsock

    Please attach a fresh HJT log. I was expecting SDfix to handle this:
    O20 - AppInit_DLLs: eyttof.dll
    Other findings - dimsntfy is a missing system file?
    Check events logs for errors at startup.
    O20 - Winlogon Notify: dimsntfy - %SystemRoot%\System32\dimsntfy.dll (file missing)  >> legit  > system file >
    O20 - Winlogon Notify: WgaLogon - C:\WINDOWS\SYSTEM32\WgaLogon.dll  >> legit MS wga
    O20 - Winlogon Notify: WRNotifier - WRLogonNTF.dll (file missing) >> webroot spywaresweeper  >> legit
    O21 - SSODL: WPDShServiceObj - {AAA288BA-9A4C-45B0-95D7-94D524869DB5} - C:\WINDOWS\system32\WPDShServiceObj.dll  >> legit
  5. gscal

    gscal TS Rookie Topic Starter

    I tried to install the Winsock FP Fix, but the install fail stating:
    "not valid Win32 application"

    I have attached the new HJT
    I see there are 3 missing file messages: xpnetdiag.exe, dimsntfy.dll, WRLogonNTF.dll
    Are these needed and is there somewhere I should go to download them?[

    The eventlog shows one error:
    ===================== EventSystem =====================
    Time: 12/13/2008 10:58:46.640
    Type: Error
    Category: 50
    Event ID: 4609
    The description for this event could not be found. It contains the following insertion string(s):

    I also cheked the netbtlog and see that this one odd looking line appears when starting up in regular mode, and does not appear in safe mode
    Loaded driver \??\C:\Documents and Settings\Gary Scalfano\Desktop\B8A6C8708D9F6C5C\B8A6C8708D9F6C5C
  6. rf6647

    rf6647 TS Maniac Posts: 829

    I’ll start with the objective – run a scan with ComboFix and finish with HJT.

    Here are the steps I suggest

    Obtain & run ‘fixit’ to repair file associations
    • symptom = ‘not valid Win32 application’
    • Not interested in running MBAM & SAS at this time.
    • Message #3 - link to 'fixit download' has demonstrated its effectiveness in many cases. Go to message # 3 'fixit download'

    Rename folder on the desktop by adding ‘x’ to foldername
    • B8A6C8708D9F6C5Cx\B8A6C8708D9F6C5C
    • Method to disable, but maintain new file tracking (combofix diagnostic)

    • effectiveness compares to SDfix
    • uses 'catchme' - just like SDfix
    • gives diagnostic information

    Open issues - not clear at this time
    O20 - Winlogon Notify: dimsntfy - %SystemRoot%\System32\dimsntfy.dll (file missing) >> legit > system file > Valid for xp sp3
  7. mflynn

    mflynn TS Rookie Posts: 2,655

    Hi GScal

    Rich asked me to look in.

    Here is what I see.

    1. Old out of date HJT. Get the new one here: TechSpot 8 steps:

    2. Possible signs of a RootKit.

    3. It does look like SDFix did not run correctly

    4.Fixit and Combofix not run as advised.

    Forget winsockfix until you are clean of Malware.

    Do the below in order given in Safe mode Networking:

    Copy all inside the box and paste to an open Command prompt. It will close the Command prompt when finished.
    @echo off
    sc stop TDSSserv.sys
    sc delete TDSSserv.sys
    D/L install and run ATF-Cleaner clear all except passwords in all browsers you have. Run repeatedly until no more found.

    D/L Xclean_Micro
    No install, just run it delete all it finds decline to reboot on each item found, until the program finishes then reboot.

    Xclean will run minimized and will pop up a window if it finds anything. If it finds nothing it will exit.

    Please make a note of what it found if any as it has no log.
    If it finds several things reboot to Safe Mode and run again before continuing below.

    Get and run Malware Removal Tool by Joe Pestro

    When above is completed reboot back to Safe Mode Networking and do the following..

    When Fixit.cmd finishes it will reboot to normal.



    NOTE: If you have had ComboFix more than a few days old delete and re-download.

    Get it here:
    Or here:

    Double click combofix.exe follow the prompts.

    When finished, it will open a log.
    Attach the log and a new HJT log in your next reply.

    Note: Do not click combofix's window while its running. That may cause it to stall.

  8. gscal

    gscal TS Rookie Topic Starter

    Thanks very much.

    I swear I looked for the garbage folder earlier and didn't find it, even with turning off the folder options of "hide protected operating system files." I did that again and found that directory. I renamed as suggested and then moved to download fixit and run. For some reason, the fixit didn't load. It created no folder. As I was trying to figure out what I did wrong with it, I decided to try net access again. This time, it worked. I now appear to have full access. I will delete the odd directory and file and proceed forward. Is there something else I should do with that file or something that may have created it?

    Do you have any recommendations for things I should be looking for to make sure things are still clean?

    Again, thank you very much for your help. I'm still learning. I know where to look for most things, but am not 100% sure whether I'm looking at a problem or not when I see them.
  9. mflynn

    mflynn TS Rookie Posts: 2,655

    Well we need info,

    So did you do all the steps in my last post down to Fixit.

    We need.

    1. ComboFix log.

    2. HJT log with new version of HJT.

    3. Don't think because that one thing is working now that all is well. Until we tell you so.

    So do the 8 Steps as directed in my last post and get us these logs.

  10. gscal

    gscal TS Rookie Topic Starter

    The ATF Cleaner ran normal, cleaned it all in one run.
    The xclean didn't find anything.
    The malware removal kit didn't find anything.
    When I tried to set up fixit, the dowloaded file did not work as a ZIP. So, I switched it to EXE and ran it. It opened a cmd window, then closed it right away. I didn't find that it installed any fixit folder or fixit.cmd.

    I stopped there. Is there anything to do with the fixit?

    I can try the rest tonight after I get home from work.
  11. mflynn

    mflynn TS Rookie Posts: 2,655

  12. gscal

    gscal TS Rookie Topic Starter

    daft.exe said all associations were ok

    fixit still does not do anything. I downloaded the zip file and double click. It says it is corrupted. I rename to exe and double click and it opens a cmd window for a few seconds, nothing on screen and it closes. No fixit folder or fixit.cmd loaded.

    combofix found evidence of a rootkit. It cleaned some things and rebooted the machine once. Log attached

    new HJT attached as well.
  13. mflynn

    mflynn TS Rookie Posts: 2,655

    Hi gscal

    Run HJT Scan only select and remove the below item
    O24 - Desktop Component 1: Warning homepage - C:\WINDOWS\warnhp.html

    Run MBAM Click More Tools-Run Tool copy and paste the line below into the File name: and click OK

    Rerun ComboFix and post log to confirm removals.

    New HJT log.


    EDIT: On the Fixit. You can not just rename the icon. You must rt click and chose properties then in the Box rename to Fixes.exe. Did you do it this way? If not do so and run.
  14. gscal

    gscal TS Rookie Topic Starter

    combofix didn't reboot any this time.
    its log and hjt attached
  15. mflynn

    mflynn TS Rookie Posts: 2,655

    OK Gary

    It looks as tho we are finally clean.

    Before we do the tools cleanup and thread closing do this one more Scan.

    D/L Norman Malware cleaner

    Boot to Safe Mode only and run it.

    Finally report back thr Status of your computer. After removing some Malware some issues can remain from damages the Malware did.

  16. gscal

    gscal TS Rookie Topic Starter

    This malware tool found no infections.
  17. mflynn

    mflynn TS Rookie Posts: 2,655

    We should have enough fixed that the below will run now.

    Try do the WinsockXPFix that failed, again.

    Then back to post #2 and try SDFix again.

  18. gscal

    gscal TS Rookie Topic Starter

    None of these are showing anything to fix anymore.
  19. mflynn

    mflynn TS Rookie Posts: 2,655

    OK so finally boil it down!

    Are we finished. What works what don't?

  20. gscal

    gscal TS Rookie Topic Starter

    From what I can see, everything is working now. I haven't found aything not working yet. Thanks for the help.
  21. mflynn

    mflynn TS Rookie Posts: 2,655


    Thread closing-------------------------------------------------------------------------------------------------------------

    Please download OTCleanIt

    Save to desktop.

    This will remove all the tools we used to clean your computer.
    These tools update so often they require downloading again later if needed.

    Double-click OTCleanIt.exe. Click CleanUp. Yes to the "Begin cleanup Process?"

    Approve all if prompted by Firewall, Widows Defender or other guards or security programs about OTCleanIt attempting access to the Internet, allow all.

    If prompted to Reboot click Yes.
    OTCleanit will delete itself when finished, if not delete it by yourself.

    Run CCleaner again twice or more on Cleanup temps, then on left click Registry then Scan for issues also repeat till clean.

    D/L install and run ATF-Cleaner clear all except passwords in all browsers you have. Run repeatedly until no more found.
    The issues could possibly be found is in System Restore so do the below.

    Start-Programs-Accessories-System Tools-Disk- System Restore and create a new Restore point. Name it "After cleanup at TechSpot".

    Then Start-Programs-Accessories-System Tools-Disk Cleanup
    Click OK to accept C:
    Select all Boxes
    Then click More Options
    Here click System Restore and OK to "Are you sure" and the OK to Run.

    As this runs it clears all but the most recent Restore Point but it does one other thing that can contain infested files and a huge amount of disk space.

    It clears what is known as Shadow copies which are used by specialized back up programs.

    This is if you have the Volume Shadow Copy running which is the default.

    Every 2 weeks or so run mbam and sas until clean They take a while so leave scanning while you are sleeping working or watching TV. If not done under the gun they can be schedules not to interfere with computer time.

    If they find something they can not clean then get back to us.

    Additionally run CCleaner.

    I have been using ThreatFire for more than a year, it just went from ver 3 to ver 4.

    It was designed to co-exist with other Virus scanners.

    Additionally it uses totally different process to protect. While conventional Virus scanners work from definitions ThreatFire works on recognizing Virus/Malware activity. It's like looking at it with 2 sets of eyes and from a different angle.
    Look at

    Run SpyBot ocassionally and use the Immunize function.

    Install Hostman and allow it to disable DNS Client and select all 4 Host files and then Update

    A Disk scan and Defrag are in order.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...