Networking adapters

  1. Hello,
    Ive a little bit of an issue with my internet lately. i have a little cousin thats staying over for christmas and he 'accidently' turned my pc off. when i turned it back on it went into startup repair did its bussines but then wouldnt connect to the internet. I opened device manager and under the Networking Adapters tab all the subtabs had a yello "!" sign beside them and in properties it said This device is not working properly because Windows cannot load the drivers required for this device. (Code 31).
    i fixed my sweex wireless adpater by clicking on "update drivers" "search my computer" and " let me pick form list of device drivers on my computer" it worked for half of the "!" marks but for all the WAN miniports such as :
    - Wan miniport (ip)
    - Wan miniport (ipv6)
    - Wan miniport (l2tp)
    - Wan miniport (networking monitor)
    - Wan miniport (PPPOE)
    - Wan miniport (PPTP)

    and microsoft torredo tunneling port it says "windows encountered a problem installin the driver software for your device". i can now go on internet but stuff like Windows live messanger wont connect :/

    Please help

    Thanks in advance
  2. mailpup

    mailpup TS Special Forces Posts: 7,187   +470

    I suggest you go to your motherboard manufacturer's website, download the NIC/LAN drivers and reinstall them unless you already have the motherboard driver CD.

    I suspect your cousin did a bit more than merely turning the PC off accidentally but that's neither here nor there. :)
  3. SpikeyBoiCahir

    SpikeyBoiCahir TS Rookie Topic Starter Posts: 40

    Thanks it worked like a charm.. Thank you very much..
    i guess he had to press a few buttons :)
  4. mailpup

    mailpup TS Special Forces Posts: 7,187   +470

    You're very welcome. Thanks for the update.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...