New drive won't recognize blank CD!!??

By macx ยท 6 replies
Sep 19, 2006
  1. I always seem to have fits trying to write to a simple CD.

    I just installed a new NEC drive, and I'm running into the
    same problem I often do when I infrequently try to burn
    files to a CD.

    I got the folder selected and chose "write to CD" but
    then it says "put a disc in the drive" when there's already
    a new blank one in there!

    Why do I always have to have such a time doing such
    a simple thing!!

    What to do??

  2. swker98

    swker98 TechSpot Paladin Posts: 1,077

    maybe a fermware update can fix this
    maybe try a different ide cable

    is your drive free of any dust you can see?
  3. friend2u

    friend2u TS Enthusiast Posts: 71

    Had a similar problem had a tech out I did a complete system recovery, the drive would not recognize media then all of a sudden it worked fine out of a clear blue sky and then back to the same problem again. I do not trust drives that run on IDE cable and I dont like the connection they make on the board, if your mother board is corrupt at that connection all the tricks in the world wont help. So what I did was to buy an external drive which connects through the USB port. I only paid around 100 bucks and I got an LG brand DVDRW which is better then my internal since it does dual layer dvd, DVD+, DVD- and would you believe it does RAM discs also, and it is much faster then my OEM internal drive which is only a few years old. If you can return the drive I would do so, you could always buy an external and if it works fine then return your internal !

  4. macx

    macx TS Evangelist Topic Starter Posts: 718

    Thanks for the ideas, but this is a brand new NEC dual layer etc etc etc.

    When I insert a disc, the little disc icon appears by the cursor for a while,
    then goes away.

    I don't want an extermal cuz I travel a lot and drag my setup with me.

    The whole thing is less than a year old, all new cables, etc.

    I've checked the connections, everything's tight and clean.

    I just tried a CD with some files on it, though, and it wouldn't open
    that one and read from it.

    The only CD I got with the new drive was a Nero application, as far
    as I know there's no drivers or anything on that disc.

    The computer recognizes the drive, lists it by name, and says it's
    working properly. Well, not quite!

    Why me Lord!?
  5. swker98

    swker98 TechSpot Paladin Posts: 1,077

    try a fermware upgrade for the drive and a new ide cable

    check bios options to make sure everything i on

    if that dont work you may have gotten a bad drive

    if its less then 30 days old you should be able to get a full replacment
  6. macx

    macx TS Evangelist Topic Starter Posts: 718

    OK, I give up, what do I do exactly to do a firmware update?

  7. Patriot.Aus

    Patriot.Aus TS Rookie


    i dont know your level of expertise, but definetly make sure that the cd you have in the drive is compatible with your burner.

    there are + and - discs, and also some drives only burn R and not RW. you can find all of this on the front of your drive.

    It sounds like your trying to get windows to burn it for you, this may be well and good, but download nero and see if this helps.

    if you go to the device manager you might be able to update the driver?

    good luck mate
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...