New video card problem -> computer does not boot after connecting GTS 450

By alwaysab
Dec 3, 2010
Post New Reply
  1. Hi,

    I have a pentium D 3.4GHZ running on a mercury PI945GCM motherboard.

    I recently upgraded my graphics card from ATI radeon HD 2600 to Zotac - 450GTS PCIE 2.0 1GB card

    I also bought a cooler master 460W SMPS to support the 6pin input to the card.
    When i connect the card without the additional power i am able to boot from the on board graphics chipset.

    however soon as i connect the 6 pin power to the graphics card i am not able to boot at all . the display doesn't come . even bios is not loaded and the computer turns off in 5 - 10 sec

    I have checked on my friend's PC that the card and the SMPS are in working condition

    Please help
  2. rohnib

    rohnib TS Rookie

    HElp same problem.

    Help i have he same problem and same configuration as yours.
    Did you get your problem solved ??
    i have 450 watts supply.
    still it's not booting please help.
    Vet. ortedid
  3. alwaysab

    alwaysab TS Rookie Topic Starter

    Yes i did get the problem solved. Not a very good solution though.

    Apparently my motherboard did not support the graphics card. The chipset was alright but apparently the manufacturer ( Mercury was the problem ) i upgraded to a gigabyte 40m combo ( a decent and cost effective option).

    These graphics cards also require a 22V supply . Normal 400-500W Power units do not give that they have only 1 12V supply..

    I had to upgrade to a coolermaster 450/500 W supply .. it gives 2 12 V supplies ..

    and now it works.. the card is great though :)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...