Newbie overclocking question about why setting XMP causes random crashes


The recommended memory (and cpu?) settings for my ASUS Z97-A USB 3.1 mobo is to have something called XMP enabled to boost performance. But when I do enable it, I get all kinds of random Windows 10 BSODs, but it runs fine with XMP disabled. Forgive my naivete, but XMP mode is some kind of basic overclocking, correct?

My question is this: What is the most likely component(s) I'd have to upgrade in order to use XMP mode without crashing? Here are my current components and settings...

Processor: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (4C
8T 4.4GHz, 4GHz IMC, 4x 256kB L2, 8MB L3)

Chipset: ASUS Core (Haswell) DRAM Controller 100MHz,
2x 8GB DIMM DDR3 2.67GHz 128-bit
Memory Modules: 2 x G.Skill F3-2666C12-8GTXD 8GB DIMM DDR3 PC3-
21300U DDR3-2666 (9-9-9-25 4-34-10-5)
Graphics: NVIDIA GeForce GTX 750 (512SP 4C 1GHz/1.29GHz,
2MB L2, 1GB 5GHz 128-bit)

I've attached a more detailed report (compressed as a zip file) covering RAM and the CPU specs.

Thanks for your time and assistance!


  • Sandra Report for Z97-A RAM and CPU
    65 KB · Views: 2


Posts: 2,426   +2,988
Staff member
When enabled XMP, the RAM modules and the memory controllers in the CPU are both overclocked to the level set in the RAM's XMP profile. Your Core i7-4790K's default speed for the memory is 1600 MHz but the G.Skill's profile is 2666 MHz - you're essentially forcing the controllers to have a 67% overclock.

For that particular CPU, it's a big increase, and many other factors have to be just right for it to cope with that clock level. Asus themselves have tested only one G.Skill 2666 MHz model (F3-2666CL10Q-16GBZHD) and rate it okay for that speed, but with memory timings of 10-12-12-31. Your RAM has XMP profile timings of 12-13-13-35 and this suggests that the profile is too 'loose' for your CPU and motherboard combination. That said, another brand of RAM they've tested at 2666 MHz seem to have been okay at 12-13-13-35 (I.e. Apacer 78.BAGFF.AFC0C).

One way to try and resolve this problem is to overclock the CPU, as contradictory as that may sound: increasing the core voltage and or clock multiplier to, say, 1.35 volts and x46 might help. But do note that there is significant variation in the overclocking performance of CPUs -- buy one 4790K and it could be absolutely fine (which mine was, as it ran at 4.8 GHz, 1.4 volts, with 2666MHz RAM for years on end), whereas others may struggle to hit 4.5 GHz or no more than 2000 MHz on the RAM.

Another way would be to alter the RAM clocks and timings manually, rather than using the XMP profile. But if you're completely new to overclocking, this can be rather daunting, given the number of RAM settings in the motherboard BIOS.