NIC card enables but cannot renew IP

By Jeanbe
May 23, 2008
  1. This is a Dell Dimension 2400 computer that had excessive spyware which was cleaned but the nic will not renew the IP. The following error was received "an operation was attempted on something that is not a socket"

    I ran Dell diagnostic and the NIC passed and also reinstalled the NIC driver.

    Any suggestions?
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    First try the Microsoft solution from their knowledgebase. Use this link:

    The solution in Method 1 works most of the time. If you need a registry editor, use Tweaknow, or download the simple and good RegCleaner by juoni Viourno at
    Good luck.
  3. Jeanbe

    Jeanbe TS Rookie Topic Starter

    Thank you. That worked perfectly.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...