No Boot Device available - insert boot disk and press any key

By WesternOphel
Aug 10, 2009
  1. I bought a Caviar SE16 Serial ATA drive from Western Digital(SATA II).And all i got was this lousy message when i started up my PC.My mobo is an Intel D946GZISSLIt only supports SATA but i didn´t think i would have a problem since the drive is backwards compatible with SATA.

    I got the utility called Data Lifeguard Tools from the makers website and burned it to a CD and tried rebooting with that to see if my disk was kaput but i couldn´t boot from the cd either.Now i´m not sure if i burned the DLT right or something but i´m pretty sure i couldn´t boot from the cd either when i tried with the Windows XP Cd.And that cd works fine.

    The bios i just don´t understand what´s going on.I checked to see if it detected my drive and it appears to be detected as SATA 1 or something.Master and Slave say nothing is installed.I tried changing the boot order but i doesn´t seems to change anything.

    Gonna try tomorrow booting with the Data Lifeguard Tools form a floppy disk.But first i would love to have some kind of advice first because my Pc case is a bit small( microatx) and i have to remove my dvd drive and videocard to reach the Hardrive.

    Thanks for the help and sorry for my bad english and poor grammar.
  2. strategic

    strategic TechSpot Paladin Posts: 1,020

    Have you tried putting your old HDD back in?
    Cables connected correctly?
  3. WesternOphel

    WesternOphel TS Rookie Topic Starter

    I did and it works.My old drive is working without problems.One thing i forgot to add.I changed the jumpers like the Western Digital website suggests to limit the drive 150 speeds but that didn´t help.It´s strange because it seems that when i connect the new drive.The DVD drive doesn´t seem to work either.

    Another thing i forgot.When my pc starts in the menu there is two options:
    F2-Bios Settings
    F10 Bootmenu

    I tried my luck with the F10 give me a few choices to boot.The one i remember were the new drive and the DVD drive neither worked.It took me to the same screen were it tries to detect something and then the no boot device appears.
  4. WesternOphel

    WesternOphel TS Rookie Topic Starter

    Well i resolved my problem myself.Just chalk it to the ignorance of a dude that has problems handling technology. heheh

    The drive just needed an OS.I thought that when i started the PC the drive would gave me a message to install the OS.Well i changed the boot secuence so it starts from the cd and put the XP cd before rebooting and there you go.Problem solved.Thanks to all that helped.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...