No display driver displayed!

By keith9697 ยท 4 replies
Sep 6, 2004
  1. Hello,

    I recently bought a reconditioned IBM Thinkpad T22 laptop. I was quite happy with it till I tried to play a DVD using WinDVD. After running up and loading a DVD i get an error saying 'Cannot create Overlay; reduce screen resolution and retry'. I have tried combinations of all resolutions and colour depths and get the same result.

    I thought I would check the display settings and the diver version.
    When I checked Device Manager there was NO display adapter displayed, nor is there one in MSInfo. I downloaded the driver from the IBM website and tried to install it, but got a 'Failed to complete installation' error.

    I tried using the "Add Hardware Wizard" to try to detect the grahpics card, with no result.

    This machine should have an S3 8MB Savage graphics card built in.

    Bizarrely its working at its default resolution of 1024x768, not VGA.

    Has anybody seen a problem like this before, and know a solution? Is the graphics card in this machine dead?


  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    What windows?

    It may be your graphics card does not overlay capability at all. You can tell WinDVD not to use overlays.

    What does it say to be your display adapther in Display Properties. Should be something like: "xxxx monitor on xxxx adapter".

    The laptop LCDs are set to run on their native resolutions. Anything else will look bad anyway.

    And you can always format and reinstall.. :p
  3. keith9697

    keith9697 TS Rookie Topic Starter

    Thanks for that response - I'll try that in WinDVD.

    My Display Properties are...

    (Default Monitor) on <blank>

    ie it doesn't say <blank>, but there is a space after the word 'on'.

    As I said in my original post, there is NO display adapter listed in Device Manager or System Information, and that's the conundrum. How is this display working at all at 1024x786, when there appears to be no display driver in use???

    Its running XP Professional, by the way.


  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Have you installed the drivers for your motherboard too? Try uninstalling-reinstalling those.
  5. keith9697

    keith9697 TS Rookie Topic Starter


    Problem solved, by reinstalling XP. I suspect that the registry was corrupted. I.m left with other problems, but they're for another forum...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...