No display/post on custom pc

By Duhafen
Jul 9, 2009
  1. well im new here and in a bit of a jam, just built my first pc and already having problems with it. any help would be great

    ASUS M4A78-E 790Gx
    AMD Athlon x2 64 Dual Core processor
    Rosewill 650W PSU
    G.Skill DDR2 1066 4Gb ram (2 sticks)

    and the older items are my harddrive and cd/dvd drive

    ok i just spent the past 7 hours trying to figure out whats going on. i put everything in my case, started it up for the first time and everything worked fine, 1 beep bios came up so i followed the manual and went into BIOS setup. worked untill about 25-30 secs later my monitor showed no signal. so i rebooted and everything worked fine but this time after 10 secs it popped up with no display again.

    now im not getting any POST or display, just fans and the green LED on the mobo

    im going to do the ram swap 2morrow, aswell as testing out a different PSU but before then i'd like to know what else could be wrong with it. any suggestions would help alot.

    on a side note- could it be a grounding issue? the mobo making contact with the case?

    EDIT-also i have checked, rechecked and re-rechecked all the connectors
  2. EXCellR8

    EXCellR8 The Conservative Posts: 1,835

    Welcome to TS; sorry to hear you are facing problems...

    First off, make sure everything is assembled and connected correctly (power dongles, case buttons etc.) Second, which video card are you using in this system? I noticed you did not list one. You can try one stick of RAM at a time to eliminate the possibility of faulty modules. You might want to try a CMOS reset by removing the battery for ~20-30 secs so the BIOS settings are set to default. Good luck and post up your progress or additional queries so we can help you further.
  3. treetops

    treetops TS Evangelist Posts: 2,069   +218

  4. Duhafen

    Duhafen TS Rookie Topic Starter

    thanks for the replies guys.

    the vga im usin is the onboard ati radeon 3300hd, i figured that it would be easier to work with that than my other card.

    btw i did try my other card, ati radeon 2600xt but still got the same thing

    i also removed the battery but still nothing.

    i also checked and took out/plugged back in the various power plugs

    i shall try the ram switch thing when i get home from work tomorrow
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...