1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

No internet, problem with obtaining DNS addresses automatically

By Bill_A_1973 ยท 6 replies
Aug 10, 2008
  1. I have an old Dell Latitude running Windows XP (SP2). Recently, my internet quit working: the computer tells me that I am connected, but when I open a browser I cannot access the web. I've tried all the basic fixes (resetting the modems, some resets, new drivers, etc.). The problem happens no matter where I am -- at home, public network, etc.

    Recently, I had a fix that seemed to work, but with two problems: (1) it was done by the cable guy who magically went into my settings and fixed things, but I don't know what he did (see end of this post for my vague sense of what the magical cable guy did), and (2) it only worked overnight (when I shut down my computer at night and restarted it in the AM, the problem resurfaced).

    So the obvious problem is that my computer says I'm connected, but I can't actually get online. The thing that clued the cable guy in was this:

    When I open network connections, then right-click and select "properties" from the network connection (this happens both with Local Area Network or wireless connection), then click TCP/IP and choose properties, I see "Use the following DNS server addresses" clicked, with the following DNS addresses:
    Preferred DNS server:
    Alternate DNS server:

    If I click "Obtain DNS server addresses automatically" it deletes those two addresses. BUT (and this is the kicker) if I then click out (by choosing "OK" twice to get back to Network Connections) and then go *back* into Properties and back into TCP/IP Properties, the "Use the following DNS server addresses" is re-clicked and the same two addresses are back in place! I've tried doing some basic resets (like the "netsh winsock reset" command) without any luck.

    For more possibly useful information, under "Advanced TCP/IP Settings," I have the following:

    IP settings: DHCP enabled is listed, and "Automatic metric" is checked
    DNS: I now only have "Append primary and connection specific DNS suffixes" clicked. If I click "Register this connection's addresses in DNS" and then click out and click back in, I get the two DNS addresses listed above in the "DNS server addresses, in order of use" box.
    WINS: "Enable LMHOSTS lookup" is clicked
    Under NetBIOS settings, the "Default: Use NetBIOS setting from the DHCP server..." is clicked.
    Option: TCP/IP flitering is listed as an Optional setting

    Anyone out there have any idea how to fix this problem with the DNS addresses? I am not very tech-skilled, so I need to be walked through fixes. The ones I've tried I've found through message boards like this. I have looked all over online (on microsoft help, on these therads, etc.) and haven't found a fix. I've tried

    From what I gather, the fix needs to make it STAY on "Obtain DNS server addresses automatically." The previous fix (from a very handy cable guy) involved finding the Winsock2 folder and deleting (I think) the information in it, then running some sort of reboot or other. Again, this solution seemed to work, but only until I shut down and restarted my computer. So ideally I need a longer-term fix.

    Thanks in advance (endless thanks!) for helping.

    - Bill
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Are you an Administrator? That is probably a System-owned resource.

    If you are and it won't change, delete the connection, reboot, and make a new one.
  3. THNDR143

    THNDR143 TS Member Posts: 43


    From the sounds of it, I'm guessing spyware/adware?

    My 0.02 cents
  4. Bill_A_1973

    Bill_A_1973 TS Rookie Topic Starter

    CCT, Yes, it's my computer, so I'm the administrator, if that is what you mean. What is it that you think is a System-owned resource? Can you walk me through how I'd delete the connection and make a new one? (I can handle the rebooting, but I'm pretty tech-unsavvy otherwise!)

    THNDR143, I was thinking the same thing, especially since I can't get fixes to, well, to work. I still don't know what the magic cable guy did, but from what he told me at the time, I suspect it was something similar to this: http://support.microsoft.com/kb/811259 . However, I tried those fixes for myself (specifically, deleting the registry keys and then installing TCP/IP), and they didn't work. Notably, when I restarted it was right back to the same thing where it provides me with DNS addresses rather than letting me select "Obtain DNS addresses automatically."

    However, I have Spybot Search & Destroy installed, and I haven't turned up anything when I run a scan. Of course, I don't think I can update it now, since I can't get internet access. Is there any spy-finder software that works well that I might be able to download to a key drive from a different machine and import to my laptop that way?

    One thing I failed to mention in the previous message is that if I go into the CMD prompt, I can ping IP numbers, but I cannot ping a specific address, such as yahoo.com or google.com.

    Any ideas? Thanks again!

    - Bill
  5. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    >>One thing I failed to mention in the previous message is that if I go into the CMD prompt, I can ping IP numbers, but I cannot ping a specific address, such as yahoo.com or google.com.
    (you mean system name :) eg www.google.com)

    this is confirmation that TCP is ok but the DNS is not :(
    [ see basic networking: https://www.techspot.com/vb/topic55006.html]
  6. tipstir

    tipstir TS Ambassador Posts: 2,425   +112

    OS is corrupted, if you have Windows XP Pro CD re-install it and then update the patch to SP2. There is another way to fix this but you'll need to do the the following steps, but no magic ball that it will fix it as if it's really bad then the OS re-install is the only way to cut down time to get it working again.
  7. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Yes you want to keep Dynamic DNS address.

    disconnect from the network
    obliterate ALL settings under the device properties, even register dns.
    clear the Alternative settings
    set Dynamic IP and DNS
    click ok,ok,ok to save the settings.

    Reboot the system and THEN reconnect to the network.

    If all else fails
    try this http://www.bleepingcomputer.com/files/lspfix.php
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...