No keyboard response in XP login screen

By Boneripper34 ยท 13 replies
Jun 23, 2007
  1. Hi

    This is my first time using this forum, and i can only but prey for a quick response!

    I rebooted my computer after installing bootvis (as i had problems with slow imapi and other important applications during boot). Suddenly my keyboard stopped working, and as i couldnt get past login screen (password) i had a big problem.
    Tried a USB keyboard, but same problem.
    I can enter bios and all just fine, but when login screen comes no buttons, not even num lock, caps lock or scroll lock responds (no lights).
    Mouse works fine though... :suspiciou

    PC specs :
    MSI P965 Platinum socket 775.
    PowerColor Radeon X1950XT 512MB
    2 GB kingston ram DDR2 PC5300
    1x 300 GB sata2 seagate hdd
    1x 200 GB IDE seagate hdd
    420W PSU
    Labtec media keyboard
    Microsoft habu

    I thought it might be an Bootvis error (as it was the last thing i installed), but have find no indicators of this. The comp. should be malware and virus free, as i have gone through it often and kept safe.

    Any suggestions?:confused:
  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

  3. Boneripper34

    Boneripper34 TS Rookie Topic Starter

    Thnxs for the welcome:)

    Yes i have tried going into safemode, but with no luck. As it loaded, same problem appeared at login screen.
  4. Boneripper34

    Boneripper34 TS Rookie Topic Starter

    I might add that i was stupid enough to think it might be a problem with drivers & such, so i decided to reinstall windows. upon entering the serial code for windows, the keyboard stops working again! and every time i reboot it auto-restarts im kinda stuck now!
  5. CCT

    CCT TS Evangelist Posts: 2,653   +6

    If you boot with the XP cd in the tray are you able to cancel settup and retry to effect a repair install?
  6. Boneripper34

    Boneripper34 TS Rookie Topic Starter

    Thnxs, but it doesnt work. I only get an error message, and then it auto-reboots. It looks as though it might have removed vital files from the original install during repair install :(
  7. CCT

    CCT TS Evangelist Posts: 2,653   +6

    If still able to navigate Bios, can you find an ESCD reset setting or a Reset Configuration Data feature (same thing diff name)?
  8. Boneripper34

    Boneripper34 TS Rookie Topic Starter

    Ill try, and post back. thnx!
  9. Boneripper34

    Boneripper34 TS Rookie Topic Starter

    couldn't find such an option...
  10. CCT

    CCT TS Evangelist Posts: 2,653   +6

    How about a 'Clear NVRam' entry?

    edit: Look under PNP/PCI Configurations maybe.
  11. Boneripper34

    Boneripper34 TS Rookie Topic Starter

    Nope, not as far as i can see =(
  12. CCT

    CCT TS Evangelist Posts: 2,653   +6

    OK -here's the thing.

    The way I understand things, the bios controls the basic comp and the keyboard/mouse until the OS boots and it hands it off to the OS.

    Now, booting from cd the only OS you have is the 'fake' one created to guide you through the install/repair. The existing hard drive OS isn't in play.

    So, if the keyboard isn't seen by the install/repair OS, then the disk may be dirty or the driver missing.

    Maybe I'm wrong but that's how it looks to me.

    edit: or the mobo interface is gerfunkled but that seems unlikely here - was why I thought ESCD might help to shock the Bios
  13. Boneripper34

    Boneripper34 TS Rookie Topic Starter

    hmmm. still dont get things to work. As a helping hand towards the solution, i can say that the last thing i did before reboot was installing bootvis. I had some trouble with slow Imapi launch at startup, and thought i needed an analyse.

    Could this be the cause. some sort of error in the prog. ended in removing keyboard functions? Or is that a farfetched theory?
  14. TomFilin

    TomFilin TS Rookie

    I have just had the same problem on a machine that was new in January. Looking at the machine across the network I read the driver loading log and found that three .sys files were not loading. These files were, in the order they have to load, termdd.sys mouclass.sys and kbdclass.sys. When I looked at these files across the network I found that they reported a CRC data error on any function I used to rename, copy or open etc. The cure that I had to do was to remove the HD, a SATA 80gig, and fit it into a working XP machine as a second drive. I then did a chkdsk /f and found that these file reported a problem and chkdsk seemed to fix them. However after re-fitting the disk to the original machine they were re-corupted. The final cure was to refit the HD to a working XP machine as a second drive and run chkdsk /f again and then deleat and copy the three files from a good working machine. The copy function to get the files off the working machine was via a DOS boot disk with NTFS file reading functionality. This has cured the problem on the original machine, but I suspect that the problem was not a HD error but a virus/worm problem on the machine. This seems a long drawn out cure but the machine is on a company network and cannot be easly rebuilt.
    Hope this help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...