Spread the love! TechSpot Tech Gift Shortlist 2017

No power to laptop -- tried new charger and even new motherboard

By spencer1980
Mar 26, 2012
Post New Reply
  1. HI,

    My Acer Aspire 7730 has no power (no lights at all).

    Originally I had a problem with my power socket. I then re-soldered it and it worked fine for 6 months. Then one day it stopped working. First I tried a new plug. I didn't want to re-solder again so I ordered a new mother-board from ebay. I installed it but still no lights came on, the seller said the m/board was fully tested but accepted a return. I have now installed a second fully tested m/board and have the same problem. I have tried removing the ram and hard drive. But still no lights when plugged in. I could understand if it wouldn't power up because that might be a hardware fail but its the fact theres no charge that confuses me. Oh and I'ver tried the 'hold the power button 30secs' trick too.

    Please help
  2. Cerf

    Cerf TS Rookie Posts: 23

    Well, if you've tried two motherboards, then you could try with a different power socket/power adapter?
  3. spencer1980

    spencer1980 TS Rookie Topic Starter

    Obviously that was the first thing I tried. Its definitely not to do with the power adapter or socket.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...