Oblivion on Vista Ult. x64 giving "stopped responding" errors

By HaLo2FrEeEk
Mar 9, 2009
  1. I don't know what's going on. I've installed the latest drivers, I know this should work. I just reinstalled Vista about 2 weeks ago, I have Oblivion installed to a separate harddrive, my 1TB harddrive. Here are my current Hardware specs:

    8800GT Superclocked 512MB
    8GB DDR2 6400 RAM
    ASUS M2N-E SLI mobo

    I've got plenty of power to run this game, and I've played it before on this same setup except with 4GB RAM and it worked. I've tried dumbing down the video quality, I've tried windowed mode, and run as administrator; it's the same everytime. It'll load up the launcher and let me start the game, but without fail about 1 minute in, give or take 30 seconds, the game will crash giving me an "Oblivion has encountered an error and needs to close" error.

    Anyone know anything about this?
  2. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    Since Oblivion came out before Vista, maybe it will run better in XP compatibility mode. Also, you didn't say if you installed any game patches. If not, give that a try too.
  3. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    I hadn't installed any updates, but I did now. Haven't tried it yet.

    Bethesda said that all their internal tests on Vista worked fine, but the plugins don't work on 64 bit systems or any version of Vista. Bummer, but I'll deal. I'll edit once I restart and test with the update, then I'll try compatibility mode, though that never really helped anything for me.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...