Odd USB problem, Windows 7 Starter on Acer Aspire One

By Tazzr ยท 8 replies
Oct 16, 2010
Post New Reply
  1. Hey All.
    Im having some major problems with a usb stick and my acer aspire.

    I have a Acer Aspire one netbook, and a unbranded 2gb robot usb memory stick. i cant seem to find a problem but thier must be one, as anytime i try to access my memory stick, nothing appears, the LEDS just flash.

    Now as far as i know, things start to get odd
    Ipod connects to netbook fine, can view content and access space reserved for disk use.
    Ps3 controller connects fine, and charges. (not sue if that helps at all)
    Dads memory stick connects and its files can be read fine.
    My memory stick can connect to dads Toshiba laptop, and to school pc's fine.

    i cant see where there can be a problem so im desperate for help right now, so please. any suggestions welcome, and thanks in advance.

  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    See [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post] as is one thing to try
  3. Tazzr

    Tazzr TS Rookie Topic Starter

    Tried that. removal was successful,however my usb stick is still not working, still have blinking LED's.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. Am i correct the memory stick is just a problem when plugged into your laptop? As I understand it, you've tried it and it works on other computers?

    2. Make sure your laptop is plugged in when testing the USB stick. (sometimes can be problem due to power available via USB port. Not sure if applies in your case, but keeping a laptop AC plugged in can help in such situations)

    3. When you plug/unplug it into the port are you at least hearing the device connect/disconnect ding-dong sounds from Windows??

    4. Open up and watch device manager as you plug/unplug it. Does any device item appear/disappear when you plug/unplug it? Anything appearing under USB category listed as Unknown Device?
  5. Tazzr

    Tazzr TS Rookie Topic Starter

    1. Yes it's just my laptop the problem is with, its been tested and has worked on fine on other laptops.
    2.My laptop is currently plugged in and no change.
    3. no i don't hear any noise when connecting and disconnecting
    4.nothing appeared on device manager and there's no unknown device showing up.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmm... I think that implies there's a pretty fundamental issue as those device sounds should be occuring on hardware detection (even if a driver problem existed)

    Only other thing i might guess to try see [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]

    Otherwise, get a new flash stick. And remember, flash sticks can be flaky. They're good for moving data around and temporary storage but NEVER use them as backup devices for important data as can easily fail and you then lose the data
  7. Tazzr

    Tazzr TS Rookie Topic Starter

    no improvement, and i have a spare usb stick anyway. just one last thing.. is there any explanation why my usb stick wont work with my netbook but will work with other pc's when all other usb devices seem to connect fine to my netbook?
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'm stumped as to why!

    Chalk another one up to the mysteries of computers :D
  9. Tazzr

    Tazzr TS Rookie Topic Starter

    ah, bit annoying, but thanks for all your help :)
    if you can think of anything else that could work or just find out anything that could explain what's wrong, id love to hear it. though to be honest it seems like nothing can be wrong, which like I said is a bit annoying, ah well. thanks again :)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...