Official Windows 8 Wi-Fi driver not working, alternate driver kinda working

By dotVezz · 11 replies
Nov 10, 2012
Post New Reply
  1. So I have a very interesting problem! On my ASUS G55, after upgrading to Windows 8 I tried using the built-in Qualcomm drivers, that didn't work so I experimented around for a bit. I'll try to get all the pertinent information into an easy-to-read post, in the steps that I took and the results that I got.

    1) Install Windows 8 Fresh, use built-in drivers.
    - Can connect to unsecured Wireless APs
    - Cannot connect to most WPA2 encrypted APs
    - Cannot connect to ANY APs using WPA2/PEAP with MCHAPv2 (Authentication against Microsoft Active Directory)
    This is where things get a bit messy! At the university I attend and work for, every WiFi Access Point uses this scheme to authenticate users against the school's Active Directory. If you're unfamiliar with this, it basically means I use my school username and password instead of only a WPA2 password/key. It does ask for my username and password, but times out when trying to connect.

    2) Install official Qualcomm drivers provided by ASUS at this page (link).
    - Can connect to unsecured Wireless APs.
    - Can connect to most (but finicky) WPA2 encrypted APs
    - Identical problem with PEAP/MCHAPv2.

    3) Fresh install of Windows 8 Pro again, then install this driver here (link). Results are very mixed, please read carefully:
    - Can connect to all APs! No problem connecting at all! Very stable connection!
    - Upon reboot, or restore from sleep/hibernate, the "Networks" charm/sidebar-thing shows that WiFi is in an "off" state.
    - Upon reboot, or restore from sleep/hibernate, the "Network and Sharing Center" does not include the WLAN card in the list.
    - Upon reboot, or restore from sleep/hibernate, the WLAN card is listed in the "Device Manager", is powered on and has no warnings.
    3.1) After rebooting or restoring from sleep/hibernate, I need to delete the WLAN card from "Device Manager", then reinstall it with the proper drivers. Please read results, because it's still a mess here.
    - Can connect to all APs!
    - Disconnects after 10 seconds and forgets which driver to use?! This is very weird. The "Device Manager" shows that it has reverted to the driver included with Windows, forgetting that I had just installed it with an alternate driver.
    3.2) After it forgets which driver to use, I go back to the "Device Manager", update it to use the alternate driver.
    - Finally, it works. No problems until the next time I reboot or sleep/hibernate.


    As you can see, this is a strange problem. That's a long and arduous process to go through every time I power my computer on. Anyone have similar issues, or perhaps a solution?

    Please ask any questions if I was not clear in explaining anything.
  2. nsmal24

    nsmal24 TS Rookie

    I have been having the same issues with my G55VW. I have been banging my head against the wall trying to get it working at work on my Cisco APs with WPA2-PSK/AES. I have the same setup at home on my Linksys E3000 router and it works fine. Must be something with my enterprise wireless controller and the driver. I am getting ready to try out the second driver that you linked to.
  3. nsmal24

    nsmal24 TS Rookie

    Update: I haven't been able to connect with the new (buggy) driver that you posted. I updated the driver versus doing a full, clean install of Windows 8. I have too many work tools installed on this machine right now to do a clean install without a perfectly working driver. This is so silly.

    Also, I forgot to mention in my initial post that I did give up and call Asus at one point (after they released their Windows 8 drivers to their website). The "tech" was less than helpful. He asked me if I tried the Intel driver that is also listed for the G55VW. I told him that it was a Atheros card, thus, trying would be more than useless. I was on the phone for about 30 minutes before he told me that I should call Microsoft for a driver. I told him that Microsoft was not responsible for providing drivers and that it was Qualcomm and Asus's responsibility to get the proper driver out for this device. He didn't know what to say...sigh. He also told me to go to the Atheros site and download the driver there. There are no download links and not even a mention of this wireless card in particular. Which he realized when I made him go to the site that he sent me to. Where do they get these people?

    Round and round I go...
  4. nsmal24

    nsmal24 TS Rookie

  5. asifmohtesham

    asifmohtesham TS Rookie

    I have the exact same problem. Windows 8 Professional, Broadcom WiFi.
  6. dotVezz

    dotVezz TS Booster Topic Starter Posts: 112

    I've managed to find a temporary solution. I use the alternate driver (Link in step three of my original post) and go to the Device Manager.

    I go to the Device Properties for the Atheros WLAN card, make sure that the alternate driver is installed, then "Power Management" tab and uncheck "Allow the computer to turn off this device"

    It's a temporary solution because it's forcing me to lose power-saving settings. But it works well.
  7. Carlos Almoril

    Carlos Almoril TS Rookie

    I have the same issue and it´s desperating. I have a Broadcom Wlan card... any solution? I tried to update drivers of both, Ethernet and Wlan, apparently the drivers got updated but when I check the net diagnostics of Windows they show me the old versions of the drivers. Anyone can say how to uninstall completely the drivers and a clen installation of new ones?

    Thanks in advance.
  8. dotVezz

    dotVezz TS Booster Topic Starter Posts: 112

    I was at a university at the time, and many students started buying Windows 8 laptops - and a LOT of them had this issue. The school eventually changed something on their end (changed wifi security settings?) but they didn't tell us what exactly they changed. There's no difference in settings a user would use to connect to the network.

    Unfortunately, if you do not have control over the network you want to connect to, then you might not be able to get a permanent fix yourself. You might have to talk to your organization's IT staff about it.

    If you DO control the network you want to connect to, then I recommend experimenting with security settings - although I have no idea where to start.
  9. Xophedebx

    Xophedebx TS Rookie


    I faced the same issue with WiFi Atheros card on both Asus K55VJ and Sony Vaio SVE1512H6EW. I tried all the stuff possible (driver updates, priority settings of WLAN/LAN, etc etc I spent HOURS and HOURS). Nothing worked until I found out the reason: incompatibility between Windows Defender and other FireWalls/Network security/anti-virus solutions.

    Most of the time, you will install the free 90 days Mc Afee or another solution( in my case it was Kaspersky IS 2013 for Win8). It will work on your brand new PC, until installation of the security updates coming from Win Update. From that moment, your Wi-Fi won't work anymore after sleep mode, and sometimes will even stop working for no reason at any time, forcing you to re-boot. And maybe if you uninstall the AV solution, you could also face Defender not willing to reactivate itself anymore.

    On my both PC's, I reinstalled everything from scratch, uninstalled free Mc Afee solution, did all updates and activated only Microsoft protection (Defender, fire-wall) ==> everything works now perfect, even with the old wifi driver.

    ... this is valid for PC with new secure BIOS of course.
  10. dotVezz

    dotVezz TS Booster Topic Starter Posts: 112

    Xophedebx. That's great that you got your solution solved. It looks like it's a different issue from what I had.

    I didn't have any antivirus or network security programs installed - it was a fresh install of Win8.

    EDIT: I'll reiterate what I said before: The solution I (and dozens-to-hundreds of others at the campus) had was an incompatibility between Windows 8 and the school's Wifi security. I was able to work around it using old drivers, but Windows 8 was picky about that.

    In the end, the school updated their security and the problem was solved for all of us.
  11. Xophedebx

    Xophedebx TS Rookie

    Means that you had the Cisco issue: Win 8 has built in compatibility with next WiFi standard ("801.11w"). All Cisco Wireless accesses had to be updated.
  12. dotVezz

    dotVezz TS Booster Topic Starter Posts: 112

    Ah, interesting.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...