Only text with black background when start Homeworld 2

By hw2addict ยท 9 replies
Jan 22, 2012
Post New Reply
  1. Hello All,

    New to the forum, and a Homeworld 2 single player (no internet multi-player) for several years. I hope you can help.

    I recently started HW2 and only got a black screen with the text and the music. I reinstalled, got the same problem, but then after a while, it worked.

    But it happened again. This time I upgraded my AV program (Webroot), and I now only get the same black screen, text, and music.

    I have Windows XP SP3, 1.86 GHz. 3.0 GB RAM.

    Has anybody had this problem and a solution?

  2. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    I still play the original Homeworld and I started but never finished HW 2 for some reason. Is your game patched?
  3. hw2addict

    hw2addict TS Rookie Topic Starter

    Hi mailpup,

    I was not sure anybody still played either one. I think both are pretty good games.

    No, I never got the 1.1 patch. I tried , but after installing, I got an error about an incompatibility with file emulator. Since I could play fine as a single player I gave up trying.

    Thanks for the reply.
  4. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

  5. hw2addict

    hw2addict TS Rookie Topic Starter


    I tried the download. I got the same error: Conflict with Disc Emulator Software detected. See the Securom website for more details. I went to their website, but it was not that helpful.

    No, I am not running any mods. Other suggestions?

    Thanks for the reply.
  6. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Is a disc emulator utility installed? Can you try uninstalling it temporarily to see what happens?
  7. hw2addict

    hw2addict TS Rookie Topic Starter

    I have not installed this. I recall such a message after I first got HW2 and I tried to download the patch. About a year ago I had some repair work done and had a new hard drive installed. I don't know if they would have done this.

    Can I check for it? How would I identify it?

    Thanks again for your interest.
  8. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Try looking in Add or Remove Programs in the Control Panel. I don't know much about it myself and I'm asking because of the error message.
  9. hw2addict

    hw2addict TS Rookie Topic Starter

    I found something that helped on the web after searching for Disc Emulation Errors. The poster said to go to Device Drivers in My Computer Properties, open each CD/DVD drive, and uncheck the option that enable digital audio extraction.

    Well, I did this, but I still got the error. I then uninstalled and reinstalled HW2. Then I tried it by clicking the icon. That did not work - after a while a dialog box came up to Retry or Cancel. I canceled. Then I reinserted the disc in the drive, clicked on play HW2, and surprise - IT WORKED.

    So, I am not sure what happened. And I don't have the patch. And, it does not start the way it should. But at least (for now) it runs.

    Any explanations would be appreciated because it may happen again.
  10. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    It's been awhile since I tried HW2 but I believe I always had to insert the disk in the optical drive. Anyway, the patch fixes a lot of bugs in the game so it's too bad you can't install it. As you say, at least it runs now.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...