Philips spd2410l1 won't detect discs / Samsung DVD-ROM SD-616T

By Kediil
Mar 28, 2009
  1. Just yesterday, my Philips started acting up. It's a couple of years old at least, so it may just need replacing, but it's still odd. It started when I put in an old Amazon Trail disc. Read it fine, but gave me some 'incompatible' and 'language' errors for installation, which is odd, because my friend has the same version operating system and it worked fine on his computer. Anyhow, it loaded slowly, took a long time accessing the cd folder and such. When I took it out and put in Brothers In Arms, it didn't detect the disc. I've tried with other discs, including Amazon Trail. No go. The computer still detects the drive and I can eject from the tabs and such. I've uninstalled the drive and reinstalled, but no luck. Any suggestions? Or am I up to buy another drive?

    The same thing actually happened with my Samsung DVD-ROM SD-616T about a month ago when I reformatted my system, but it wasn't vital since it's an old drive and I had my dvd drive.

    Let me know if I can add anything!

  2. gavinseabrook

    gavinseabrook TS Rookie Posts: 320

    Sounds like a bad drive. Time to replace it with a lightscribe one also.
  3. Kediil

    Kediil TS Rookie Topic Starter

    ^..^ I figured it might be as much. Can't say I'm going for a lightscribe though. My friend has been through several over the past year and they've all crapped out a lot sooner than the less fancy ones. Hopefully someone might have an idea, even if drives are pretty cheap these days. Thank you kindly too. ^..^
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...