Please Help - Internet Issue

By ohlin5 ยท 32 replies
Nov 8, 2008
  1. I have a comtrend CT-5621 DSL modem and am trying to get an internet issue worked out. I have a standard phone line going into the modem, and an CAT-5E ethernet cable going out and running to the desktop. The desktop's internet works perfectly. However, when I connect another ethernet cable to the modem and run it to my laptop, I can only get either "limited connectivity" or "local only". I originally thought that this was obviously my laptops problem, but after much frustration and running the factory restore disks, the problem still wasn't fixed. The laptop seems to connect at other place fine (wireless & wired), but for some reason cannot get full local and internet connectivity at home. Any help would be greatly appreciated!

    Many Thanks!

  2. mflynn

    mflynn TS Rookie Posts: 2,655

    Hello ohlin5

    Do the below on the Desktop that works.

    Paste the following line to an open command prompt and hit enter!

    ipconfig /all >"%USERPROFILE%"\Desktop\ipfig.txt

    A file ipfig.txt will appear on the desktop paste the contents of this back to this thread.

    Now for comparison do the same on the other computer that does not work and paste it back!

    You may copy it to a USB, cd or floppy or just type it back to me. On the one that don't work get me the IP Gateway and DNS.


  3. ohlin5

    ohlin5 TS Rookie Topic Starter

    Here it is...

    Cleared For Security Reasons
  4. mflynn

    mflynn TS Rookie Posts: 2,655

    That OK I see most of what I need.

    Go back and edit the post and clear "all" having this data public for long is not good.

    So edit the post and leave in the post only the text "Cleared for security reasons!"

    I have copied all the data.

    So do that now and I am composing you a post offline.

  5. ohlin5

    ohlin5 TS Rookie Topic Starter

    Do you think you see whats wrong?
  6. mflynn

    mflynn TS Rookie Posts: 2,655

    OK first that is not just a DSL Modem it is a Combo Modem/Router.

    There is no reason at this time to access the router.

    The 2 issues I see are interconnected.

    First it shows: Media State . . . . . . . . . . . : Media disconnected

    Then I see.

    Autoconfiguration IPv4 Address. . :

    Which is what happens when Windows can not find a DHCP Server.

    In this case it is likely caused by the media disconnected issue.

    Also no one uses IP6 yet so go into Local area connection on the Ethernet connection and for now uncheck IP6.

    You may have a cable issue. Turn off both computers.

    To test this unplug the cable from the desktop and plug into the Laptop leave it plugged into the router and turn on the Laptop.

    Actually just switch the cables from the back of the computers. Do not disconnect at all from the router.

    If it connects now then the cable you were using for the Laptop is bad or is what is called a Crossover cable and will not work for this.

    Let me know.


    EDIT: For clarification the the 169,,,, usually means no external DHCP Server can be found. And that is a problem!
  7. ohlin5

    ohlin5 TS Rookie Topic Starter

    Ok I uncheck IPv6 and that didn't do anything...and as I suspected it was not a cable issue. I did try it, but it didn't do anything. The cables are exactly the same and were bought from the same place, only difference is length. IDK...Heck, I even took it to Best Buy b/c I thought it was broken, but it worked fine there...just won't go past local only connection at my house...
  8. mflynn

    mflynn TS Rookie Posts: 2,655

    OK but I/we needed to know.

    I have to do this as I am not there.

    So now switch cables on the back of Modem/Router?

    Does the Router have a light on the front Port 1 port2 etc and do the lights go on and off when the cable is unpluged. There will be a light if Router senses a cable connected.

    Likely the Laptop is not causeing a light to go off when cable is unplugged.


  9. ohlin5

    ohlin5 TS Rookie Topic Starter

    yeah...both go on and off when cables are connected and disconnected, respecfully.
  10. mflynn

    mflynn TS Rookie Posts: 2,655

    Ok in Local Area connection for the Ethernet connection rt click and then lleft click Properties.

    Does the top entry say Enable or Disable?

    If it says Enable click it to make it say Disable.

  11. ohlin5

    ohlin5 TS Rookie Topic Starter

    Sorry I misread...what I see is all the boxes with checkmarks, and they are all checked aside from the IPv6 you told me to uncheck...if you mean is the connection enabled/disabled, it is enabled...
  12. mflynn

    mflynn TS Rookie Posts: 2,655

    Have you repaired the connection?

  13. ohlin5

    ohlin5 TS Rookie Topic Starter

    Well I am on vista, but yes, I have "automatically got new IP setting for the local area connection" and also "reset the network adaptor"...and it always give me a message to the fact that it performed the task, but it did not fix the problem...Wierd part is I can always achieve local only connection, but never local and internet
  14. mflynn

    mflynn TS Rookie Posts: 2,655

    OK it is time to go to a Static IP.

    Rt click Local area connection-Properties-This connection uses

    Go to bottom
    Internet Protocol (TCP/IP)

    Double click it

    Here in Use following IP Address put:

    Click Subnet it will auto fill.

    For Default gateway put:

    At the bottom click Use the following DNS Server addresses.


    Save these and reboot!

  15. mflynn

    mflynn TS Rookie Posts: 2,655


    I assumed XP but all still applied.

    But sometimes Vista can be stubborn!

    Let me know about the last post Static ip before we delve farther.

  16. ohlin5

    ohlin5 TS Rookie Topic Starter

    ugh...that didn't work either. This time it won't even move past "limited connectivity"...
    p.s. @ last post...that's ok I've set up static ips before...
  17. mflynn

    mflynn TS Rookie Posts: 2,655

    OK boot to Safe Mode networking and see if this is still the case if so while there reset connection to DHCP!

    My opinion this is all pointing to a bad Ethernet adapter.

    Can you take this to a neighbor or friends house and check it on a different Router/Modem?

    Unplug cable look in the Ethernet connector is there a wad of lint (I have found this before) and are the wires taunt and straight and not corroded?

  18. ohlin5

    ohlin5 TS Rookie Topic Starter

    That's exactly what I thought about the adaptor, but I took it to Best Buy to replace it, and I saw them hook it up both ways, and both worked. Also, neither DCHP nor static work in Safe Mode...Yes, the wires are straight and everything...the laptop is only like 6 months old...
  19. mflynn

    mflynn TS Rookie Posts: 2,655

    OK that rules out that theory!

    Have you tried with the other computer unplugged, if not try now or let me know if you have.

  20. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I am wondering if the ISP has placed a limit to the allowable amount of computers (via mac address) connected to them at the same time

    Running just the laptop plugged in, and then resetting the Internet, refer here: (note not all commands work on all OS)
    Then restarting, again just with the laptop plugged in only, will certainly confirm this.
  21. mflynn

    mflynn TS Rookie Posts: 2,655

    Excellent idea! Thanks Kim!

    ISP's are doing some weird things now!

    Shutdown or Disconnect desktop cable.

    Shutdown Laptop, power off Modem/Router for 30 sec to 1 minute

    Power on Modem give 10-20 sec to init then power up the laptop.

  22. ohlin5

    ohlin5 TS Rookie Topic Starter

    Ok this is really getting old...:( I ran the laptop over to a friends house, who has the exact same setup as me...(both have the same ISP) and started it up, and at first it didn't work, but then I remembered I had it still set on static ip, and so I switched back to DCHP, and it worked like a charm. Like I said, they have the exact same setup as me. One desktop with ethernet running to modem/router (and I then hooked up my laptop) the ISP hasn't placed limits. Besides, I just did what I am trying to do now last weekend, and it worked flawlessly. @ last idea...tried it, only thing it changed was the network name from "unidentified network" to "Network". other than that I'm still at local connectivity only.
  23. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Then it must be a Router issue
    You could run the Hardware reset on it, usually a small button for a pin somewhere on it.
    But you would then need to re-set it up again.
  24. mflynn

    mflynn TS Rookie Posts: 2,655

    OK I think we are on to something here with Kims Idea!

    I was headed to something similar as what Kim posted but had not thought of the MAC address issue.

    Kim below is my template for what I call the TCP/NETBIOS/Winsock enema!:)

    Going a little deeper! And gets a little log info.

    netsh interface ip delete arpcache
    ipconfig /flushdns
    ipconfig /release *
    ipconfig /renew *
    ipconfig /registerdns
    nbtstat -RR
    netsh winsock show catalog >"%USERPROFILE%"\Desktop\lsp.txt
    netsh winsock reset catalog
    netsh winsock show catalog >>"%USERPROFILE%"\Desktop\lsp.txt
    netsh int ip reset >"%USERPROFILE%"\Desktop\tcpreset.txt
    Reboot see new icons on desktop, paste contents of lsp and tcp.txt back to thread.

  25. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Well if we're crossing notes, do this with Ipconfig, instead of going to a command prompt:

    Start --> Run--> cmd /c ipconfig /all >Desktop\ipconfig.txt < ok>
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...