Problem with world of warcraft patch!

By jdubbzz24
Jan 7, 2007
  1. Please help i cant figure this out!

    I recently installed wow and had a problem so i did a system restore and lost the download. So i reinstalled the game and went to play and download the patches.
    The patch downloads then i restart to load it on the computer! When it finishes it says:

    Update already installed.

    So i then log back in to play and it downloads the same patch and goes through that circle again. I ve tried erasing the patches from the wow folder but it doesnt help. I m not sure if im erasing the right ones and have know idea what to try next! Please Help Thanks! Joe
  2. Jesse_hz

    Jesse_hz TS Maniac Posts: 545

    Did you uninstall the game before you reinstalled it? If not, then try to uninstall and install it again. Also before installing, make sure that the folder where WoW was previously installed is now empty.
  3. jdubbzz24

    jdubbzz24 TS Rookie Topic Starter


    Just tried it but it looks like one of my disks are scratched im gonna have to borrow my buddies cds and get back with ya.
    Thanks joe
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...