Problems connecting an USB printer to an nsa220plus network storage unit

By erikdal ยท 20 replies
Nov 9, 2009
  1. Hi,

    I have a Zyxel nsa220plus network storage unit since a couple months.
    It is equipped with a print server application that should support an USB printer connected to a local USB port on the unit.

    Now I have bought a Samsung ML-1910 laser printer which connects via USB.

    Connecting it to the nsa, the printer is detected by the print server application and assigned a name. Then, I managed to install it on my old stationary XP box and it will print, even if the acess to the printer is pretty slow. The XP box and the nsa are on the same local LAN. However, looking at the printer ports, this printer does not show up. Strange?

    Then, I have tried in vain to install the printer on my laptop over the wireless network. The laptop is running Vista Home Premium.

    The documentation is of no help. Does anybody have a solution or any tips how to proceed?
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Not sure if i can help but willing to try take a look.... If you could first clarify some things first

    1)The Zyxel nsa220plus only connects to your LAN via cable, correct?
    2) The printer only connects to another device via USB?
    3) You say you were successfully able to print to the printer (when it's connected to the Zyxel?)
    > When you did the Print, didn't you need select a printer device by name?
    > Are you saying you see a printer name when you use the print function yet no printers device names are listed under Printers when the printer is connected?
    4) As far as "wireless" not working.. you mean the Zyxel connects via cable to a wireless routers and your computer connects to the same router via wireless?
    5) And with that wireless config in 4) above you can't see a Printer connected whether via Print function?? and/or in device manager under printers?
  3. erikdal

    erikdal TS Rookie Topic Starter

    More info

    1) Correct. On the local LAN, there are:
    ADSL modem
    Wireless router
    Zyxel NSA box
    XP desktop computer

    2) The only connection to the printer is the USB connector

    3) I can print from the XP box.
    The printer is assigned a name by the NSA print server. When installing the printer and searching for network printers, this name was displayed as available on the NSA.
    - After install, the printer is displayed in the list of printers and can be accessed as any other printer.
    - No. What I am saying is that the 'NSA' printer is displayed in the printer list on the XP box. But when I open the properties for it and look at the Port tab, this printer is not shown as assigned to any port.

    4) So far, I have only tried to install the 'NSA' printer on the laptop using the wireless connection, I have not yet tried to install it when conneced directly to the LAN.
    When installing the printer it is not found when searching for network printers. Then I have seached for it using the NSA name on the network. The printer is then found and assigned to a standard TCP/IP port.

    5) The 'NSA' printer is displayed in the printer list and can be addressed, but when trying to print, the print job stayes in the queue forever and the printer status utility has no contact with the printer.

    Obviously, there is something wrong with the setup.
    I will try to reinstall the printer on the laptop when I have a cable connection to the LAN. But I far as I can understand, this should not make any difference?
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    To start:
    > Are you running with XP SP3 installed? (rt click My Computer->Properties to verify)
    > And all h/w optional and critical updates?? Run Windows Update. Click Custom. Keep repeating and install ALL hardware optional updates and any software optional updates for MS .NET FRAMEWORK
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    And sorry if i'm somehow being dense as to the exact issue vs. your configuration. You say
    and then you say
    So you can print OK over wireless??? but you can't over cable LAN?? Or ?? just when are you having the problem vs. not having the problem???

    As i'm still trying to pinpoint the config when you can print vs. can not print vs. the situation where "you haven't tried installing over cabled LAN connection yet???
  6. erikdal

    erikdal TS Rookie Topic Starter

    Sorry if I am not explaining properly.

    Local printing connecting directly to the local USB port works OK on both computers.

    The are two different issues when connecting the printer to the NSA box:
    1) XP desktop
    There I can print, but it is slow plus I can't see the printer port when looking on the printer properties​

    2) Vista laptop
    Here I can NOT print, neither via the wireless nor the cable LAN.
    Trying to print times out with error status.
    Printer monitor program reports no conctact with the printer​

    I have installed the latest service packs (XP SP3 and Vista SP2) plus all the latest updates - both HW and SW - on both computers.

    What additional info do you need?
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thank you. Now i got it. Will get back to you!
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    one minor point.. so with XP you can print
    > Whether wireless or cabled LAN (or you just tested cabled where it's OK but slow?)
  9. erikdal

    erikdal TS Rookie Topic Starter

    Yes, you are correct. The XP box is only connected via the cable LAN, no wireless on this one,

    I tried to send a PM to you with the BelArc log for the laptop, but I was not allowed to do this (too few posts yet). Is there any other way I can sent it to you if it would be of any help?
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I think yoiu should be able to attach it to a post as a text document. If that's still a problem to do, i can wait for a log till after i first look at the problem a bit. Then can give you instructions whether for Belarc (or perhaps a different tool output if needed) Thanks (P.S. You can use the paper clip icon to attach a document)
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Some quick feedback.. I see Zyxel just released both software and firmware just last month! (10/09) I'm going to guess you're probably running on the older version...

    So is worth downloading both...
    The firmware is what runs inside the Zyxel box itself. Running the firmware exectuable should actually upload new code to reprogram the Zyxel.

    (P.S. You don't want to interrupt the firmware upload for any reason)

    Then look in Add/Remove Programs. Look if any Zyxel program is there. If so, uninstall it. Then download and run the new software

    Firmware download link

    Software download link
  12. erikdal

    erikdal TS Rookie Topic Starter

    Zyxel firmware upgrade

    I have already downloaded the latest firmware (3.22) and tried to install it.
    It starts to upload to the Zyxel box, but after a while it failes and says 'Invalid firmware file' :mad: Hmm...

    I have not yet reported this to Zyxel but will do so.
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    So much for new and improved Zyxel software!

    While you wait to hear back, i'd still like to explore a few things

    1) Do you have a 3rd party firewall installed? Or do you use Vista's firewall?
    2) Click Start->Network then Properties to see the Network and Sharing Center window. Then tell me (or you can capture a screen shot and attach an .jpg, whichever is easier)
    > Is your network set to Public or Private?
    > Also tell me each setting listed under Sharing and Discovery
  14. erikdal

    erikdal TS Rookie Topic Starter

    Network and sharing etc.

    1) I use the Vista firewall

    2) Network and sharing
    Wireless network is set to private

    Network identifying - Custom
    File Sharing - Custom
    Sharing shared folders - Off
    Printer sharing - Off
    Password prot. sharing - On
    Media sharing - Off
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Try this...

    Disconnect the cable to your ISP.

    Then on the Vista computer, Control Panel->Windows Firewall and turn the firewall Off. Then reboot the computer. Then try again to connect to the printer over the network with the firewall turned off. Does that make any difference?

    Be sure to turn the firewall back on before reconnecting to your ISP (reboot not required when you reconnect)

    /* EDIT */
    Also, i just read that one must upgrade the Zyxel firmware using consecutive releases otherwise it fails. Let's see if that's your issue. If you use the web interface to connect to they Zyxel it should tell you the firmware release somewhere. Tell me what firmware release it is running
  16. erikdal

    erikdal TS Rookie Topic Starter

    No progress

    Hi again ...

    I tried your suggestion to try to print while the firewall was turned off - no difference, still no contact with the printer.

    The Zyxel firmware in my NSA box is version 3.00. The one and only available on Zyxels web site is version 3.22. I have not yet got any feedback from Zyxel support.

    For the time being, I have given up and reconfigured my system.
    The printer is now connected locally to the XP box and set up as a shared printer on the local network. Then it is set up as a network printer on the Vista laptop. This works, but the disadvantage is of course that the XP box must be up and running to allow access to the printer.

    Any other suggestions?
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    I found someone state the ZyXEL US site is more helpful then their worldwide site. And it appears (click here) it at least provides two firmware downloads (v3.22 and v3.12) but no v3.00 you say you see on your NSA220plus?????

    And what about your Samsung ML-1910? It appears Samsung also has a very recent driver (10/09) (click here) I'd uninstall the old driver before installing the new one. You might even refer to the Zyxel manual about network printer setup to see if they want you to do things in any specific order

    You might also double check the Vista, XP and NSA220 machines all have the identical workgroup name assigned.
    > Rt click My Computer->Properties and look at Workgroup name

    Also on the Vista computer you might try navigating through Explorer to see what it sees
    > Rt click Start->Explorer
    > Look towards the end of the list for Network, rt click Explore
    > I think you should then see Entire Network->Microsoft Windows Networking
    > Under that you see just your ONE workgroup name
    > Under the workgroup you should see the 2 computers and the Zyxel
    > On the Zyxel you should also see the printer. Can you access it from the Explorer window from Vista to see its Properties, for example
  18. erikdal

    erikdal TS Rookie Topic Starter

    Some little progress

    Hi again,

    I have not done the Zyxel upgrades, the procedure seems to be fairly complicated.

    However, now I have managed to find the printer on the NSA box on the local network (I don't know why it didn't show up earlier) and I could install it on the Vista Laptop.

    Now I can print, but:
    - It is VERY SLOW!!! Printing a 13 page 28K PDF document (1,31 MB after rendering) it took 20 seconds just to address the printer, about 9 minutes until the print file started to show in the printer status window and another 3 minutes until printing was done.
    - The print file status is not shown in the printer status window.
    - The print file remains in the printer status window after the printing is finished.
    - The application (PDF Reader) remains locked (not responding).

    This is a small step for man.

    Do you have any ideas why it is so SLOW?

    I think I go back to connect the printer locally to the XP box.
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) My best guess as to why it's so slow would be the Zyxel firmware itself as you indicate remote printing works OK when printer is connected to XP

    2) I DID find all the downloads for the nsa220plus at Zyxel's ftp site. Click here

    3) Firmware versions available:
    > v3.00
    > v3.10
    > v3.12
    > v3.21
    > v3.22

    4) I think each firmware zip download includes a pdf for Release notes. You might look through each to see what specific problems Zyxel says the firmware release fixes

    5) I don't know how easy or difficult it may be to install each of Zyxel's firmware upgrades. Can only suggest you look through each firmware release notes (as your v3.00 is several version behind). For each version, look for
    > List of problems the firmware fixes
    > Decide if it sounds like the firmware releases address problems you have (whether printer or just storage server problems)
    > Decide if it seems worth the time/effort to attempt the upgrade

    Of course, see what info you can get from Zyxel support as well.

    Other thing i can think of that can affect speed.. is look on Vista whether its general printer properties or document properties if there's a Quality setting
    > The higher the quality the more data sent to the printer and longer it takes to print
  20. erikdal

    erikdal TS Rookie Topic Starter

    Thank you for the link to Zyxel's FTP site :wave:. I will check the contents of the different versions.

    So far, no feedback from Zyxel's support :mad:.
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You're most welcome.

    And i hope their support is better organized then the way scatter and distribute info on their websites! (Having to hunt down their different websites to finally get what you want!)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...