Problems with PowerColor Radeon 9700 Pro.

By elevate ยท 5 replies
Jun 25, 2003
  1. Some rellevant info. about my PC:

    MB: Abit IC7-G Max2 Advance ATX (Newest BIOS from
    CPU: Intel P4 Nw-C 2.6 (FSB800)
    RAM: 2x256MB Corsair XMS CAS-2
    GFX: PowerColor Radeon 9700 Pro. with ATI Catalyst 3.5
    O/S: Windows 2000 Pro. with SP-3

    For a day or two ago, I was looking inside my BIOS, just to check it out, because my PC is new, but I never touched anything! The problem is, when I booted my PC now, the SMARTGART was somehow, reset? I could see it, because it was set to: Current AGP Speed: 8X and Fast Write: On (Current Status: On), but now, it was set to: Current APG Speed: 4X and Fast Write: Off (Current Status: Off), well, I tryed to push Retest All, and it changed it automatically to AGP Speed 8X and Fast Write on, though it didn't change Current Status: Off to On. I tried to boot, nothing happened, the only thing that did happen, it was reset to what I mentioned above. I did the same procedure as above, nothing happened, and nothing seem to work. I have tried to update from Catalyst 3.4 - 3.5, and I've tried to remove them, and install them again, I don't know what to do, someone, please help! :)
  2. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,310

    Ive experienced something "odd" like that with SmartGart myself.

    Check your BIOS and make sure it is set for the correct AGP speed settings depending on your motherboards AGP capabilitys.

    Start->Run and type "smartgart". The "retest" settings do not seem work correctly. When I have tried using 'retest' myself I just recieved the SmartGart menu again everytime I restarted Windows if I tried to retest again. The settings that it switched to after doing a retest won't work for me.

    Just restart and let SmartGart come back up. Leave the settings where they are. Dont try to retest. Click ok.

    I also know first hand that a VERY common problem with Radeon series card's are related to AGP issues rather than ATI cards themselves. If you have ANY problems in the future you might want to make sure AGP is on in BIOS and if not turn it on. I have an option for AGP 4X ENABLE/DISABLE in BIOS (my motherboard only supports 4X).

    Also, the way I fixed my problem was this:
    Go into Display Properties, Settings, Advanced, SmartGart.
    Set the AGP speed for OFF and FastWrites to OFF.
    Reboot and see if the problem you (may have in the future, or have now) persists. If not, increase the AGP setting up to 1X.. works? Try 2X. Works? Try 4X. If one doesnt work, switch back to the previous.

    There seems to be an issue with motherboards not doing what they are suppost to do as far as AGP slots. Which may be why I had a problem or not, but it is why a LOT of people do have problems, and what I just described seems to fix MANY peoples problems.

    Hope that helps some.
  3. elevate

    elevate TS Rookie Topic Starter

    I haven't tried it out yet, but I'm going to, right now.

    Just to let you know. In my BIOS, AGP is set to 8X speed, and I know my MB can run that fast, so it's weird it resets it to 4X AGP speed in the SMARTGART settings.

    I'll try it out, see if it helps. =)
  4. elevate

    elevate TS Rookie Topic Starter

    I have noticed, when I type SMARTGART in the run menu, and the SMARTGART-window pops up, it says "Radeon 9700 Pro - Secondary", in my screen display, where I can see my desktop-resolution and so on, it says: 1. AOC Spectrum 7Glr,7GlrA on Radeon 9700 PRO - So the SMARGART function is somehow disabled at the Primary display adapter, and enabled on the secondary?
  5. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,310

    Yea, that could be a problem but I'm not really sure. I would think it would cause problems other than what you are getting.

    I kind of think you might want to remove your Catalyst drivers and then reinstall them and see if that makes a difference in anything. That should fix your problem with being set on Secondary, and may get rid of the other annoyance.

    And yea your BIOS wont give you an option for 8X if your motherboard doesn't support it. At least I've never heard of that happening.
  6. elevate

    elevate TS Rookie Topic Starter

    I think you've got it all wrong, if not, then it's me who explained badly above.

    My motherboard supports 2 options of AGP-settings, and that's: 4X AGP-Speed and 8X AGP-Speed.

    Now, in the BIOS, the AGP-Speed is set to 8X. So, I'm 100% positive that it's set to on.

    The main problem is, that I went in to my BIOS a day or two ago, but I swear I never touched anything, and when I booted up again, the AGP-Settings were all wrong. I'll give you the settings as they was back then, before the "incidident":

    Set AGP Speed: 8X - Current AGP Speed: 8X

    Fast Write: On - Current Status: On

    When I booted up that day, It was changed to:

    Set AGP Speed: 4X - Current AGP Speed: 4X

    Fast Write: Off - Current Status: Off

    I've tried the following: Un-installing Catalyst 3.5 and Control Panels + AOC-monitor drivers. Re-installing them, twice. I've even try to format my c:\ ! :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...