1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problems with Radeon 9200 128mb card

By mhepburn ยท 6 replies
Mar 21, 2007
  1. I have been having several problems with my ATI Radeon 9200 128mb AGP graphics card. My motherboard supports 4x and 8x AGP. I am able to play several old games on it, but nothing newer than diablo II. For example, on my old Radeon 64mb PCI card I was able to play Neverwinter Nights without a problem. Now however, I am hardly able to even choose anything in the opening menu. After several hours of trying different things and reading different forums, I think the problem is my inability to turn on AGP. Setting the AGP speed to either 4x or 8x, as well as turning on AGP read and write in the Catalyst Control Center simply restarts my computer, changing nothing. I can change PCI read and write from the Control Center without a problem. In my bios I have turned on AGP read and right and changed the speed from 64mb to 128mb, but it still does not say it is turned on in the Catalyst Control Center and my game (Titan Quest) still lags horribly in the opening menu. As I said earlier, I am able to play Diablo II perfectly, even with the apparent error. I have the newest BIOS and have unistalled and reinstalled the driver several times. The PC is not overheating either. There is a pin with a case over it(sorry I don't know what it is called, it it very similar to the one used to change a harddrive to master/slave etc.) on the video card, I don't know if changing this would help at all. I have spent several frustrating hours restarting my PC after installing new drivers, changing Catalyst Control settings, and changing BIOS settings, and I would be very grateful for anyone that could help me out.

    Here's my specs:
    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.061219-0316)
    Language: English (Regional Setting: English)
    System Manufacturer: VIA Technologies, Inc.
    System Model: KT400-8235
    BIOS: Phoenix - AwardBIOS v6.00PG
    Processor: AMD Athlon(tm) XP 2200+, MMX, 3DNow, ~1.8GHz
    Memory: 1024MB RAM
    Page File: 413MB used, 2047MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.2180 32bit Unicode

    and my display info as well.
    Card name: RADEON 9200 SERIES
    Manufacturer: ATI Technologies Inc.
    Chip type: RADEON 9250/9200 Series AGP (0x5964)
    DAC type: Internal DAC(400MHz)
    Device Key: Enum\PCI\VEN_1002&DEV_5964&SUBSYS_2073148C&REV_01
    Display Memory: 128.0 MB
    Current Mode: 1152 x 864 (32 bit) (60Hz)
    Monitor: Plug and Play Monitor
    Monitor Max Res: 1600,1200
    Driver Name: ati2dvag.dll
    Driver Version: 6.14.0010.6614 (English)
    DDI Version: 9 (or higher)
    Driver Attributes: Final Retail
    Driver Date/Size: 5/3/2006 10:51:00, 258048 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp: n/a
    VDD: n/a
    Mini VDD: ati2mtag.sys
  2. beef_jerky4104

    beef_jerky4104 Banned Posts: 822

  3. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +36

    The latest drivers available for the 92xx series is Catalyst v6.5. Try using an older version like 5.9 or so and it should be fine. Or alternatively, use the Omega drivers.
  4. mhepburn

    mhepburn TS Rookie Topic Starter


    Ok....I completely wiped anything even slightly related to ATI off my computer. I then installed Omega 3.8.252(The one that the Omega website told me to). Unfortunately I am still unable to enable AGP from SmartGart, and my games still play very slow at just the opening menu(though the opening movie plays perfectly fine?) I have 1gb of Ram, and though I thought it had to share with the video card it shows up under My Computer and dxdiag as 1024mb....Do i need to allow it to share somehow? I really appreciate all the help.
  5. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +36

    Nah, I think you're confused between onboard video and AGP Aperture size. Your card doesn't share memory at all, so forget about that. I still say try using an older Catalyst driver like 5.9 or something.
  6. mhepburn

    mhepburn TS Rookie Topic Starter

    Ok, I wasn't sure if it needed to be shared or not. I did change the aperature size to 128mb from 64. I couldn't find anything to turn off the onboard...not sure if there is one. Ill try and download the old catalyst driver when I get a chance(prolly later today) and let you know how that worked. Thanks.
  7. mhepburn

    mhepburn TS Rookie Topic Starter

    Alright, I installed the 5.9 driver and that didn't work. Then I removed all the drivers, restored windows, and reinstalled the OMEGA driver and still no luck. Any more ideas?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...