Quick question - WiFi pci card

By ericm135
Jan 20, 2009
  1. Hey all,

    I'm totally new to this forum and it seems to be pretty helpful in terms of question/answers.

    I got a new Belkin F5D8001 N1 wireless pci card for my windows machine (xp SP2) because my suite does not support a wired setting. Since I have installed it my computer seems to blue screen to a stop error either upon loading windows or no more than 5 minutes into completing the start up, which leaves very little time for a software/firmware update.

    I was wondering if anyone had encountered a similar problem and could share their solution with me.

    I'm am somewhat computer saavy so if you could point me in the right direction I should be able to get any information you need. As for online capabilities I am able to surf on my mac notebook (cd burning capabilities) but my PC has no connection thus far (except for a random 5 minutes before it locks up).

    Thanks in advance for any input.



    I have tried a full reinstall of the product, both software and hardware, and I have managed to receive a new stop code error, in addition to the previous one:


    Hopefully this will help in diagnosing the problem
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You say "Quick Question"?? ;)

    So, first, i assume the crashes only occur when driver is installed? Not if hardware simply installed?

    Next things to do
    1. With NO driver installed but the card is there (so i assume no crash)
    Let's see what windows reports here
    • Click Start->Run, enter: msinfo32
    • Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, then Edit->Select All, Edit->Copy Paste into next post
    2. Where did you get the driver you're currently using? Tell me the exact version number? Have you checked this is correct? and not wrong or older version number?
  3. ericm135

    ericm135 TS Rookie Topic Starter

    1. Booted up to windows desktop with no crash and installed hardware automatically.
    Within 30 seconds of the card searching for a wireless activity point the computer blue screened to a stop error with MACHINE_CHECK_EXCEPTION.

    Did not get a chance to run the msinfo32 and find any device problems.

    2. Driver date: 19/05/2006
    Driver version:
    (there is a more recent driver on the belkin site but I cannot get internet to run long enough on my PC to download it - it will freeze and blue screen as download begins)
    Driver was installed from the cd that came with the card as I have no internet on the pc currently.

    Belkin wireless utility version:


    I let the pc sit for awhile after this more recent attempt.

    I managed to collect a bit more data - the computer locked and BSOD at the windows logo during loading, I hit the reset button on my tower and it loaded up fine.

    Information from the msinfo32 screen:
    1394 Net adapter V1394\NIC1394\A4EF6111D800 - DISABLED

    Added info on my OS, is XP SP2 version 5.1.2600 build 2600 and my processor is AMD family x86 dual core X2 running at 2200MHz (not overclocked)

    The PC has been up and running for about 10 minutes now, with no crash. However, my WiFi card can't seem to see any of the 4 wireless points in range now and so won't connect to the internet. It seemed that previously, when I had tried to connect to the internet, the computer would crash as the network card began working away at data transfer.

    I hope this helps!


    So since my computer hasn't crashed yet I thought I'd take a peek at my downloads folder, as I had been trying to speed download the new driver from belkin's site before the computer would lock up. Somehow I had managed to download newer drivers and installed them after having already installed hardware.

    Since this new driver installation I haven't had a lock up, but my computer, or rather the card still won't see any nearby networks. I don't know if this helps or not.

    I will try uninstalling the entire thing again, and reinstalling just the driver I downloaded, or install the shipped drivers, update to the new one, and then install the hardware.

    Will let you know what happens.



    I completed the above steps and the computer has yet to lock up. I am currently downloading the most recent (first one actually wasn't) version of the drivers for the card.

    My new problem is that the speed is unbelievably slow. Definitely not at N1 status. I am downloading at roughly 16-20kb/s on my pc, while my 2 year old macbook pro is flying along at around 160kb/s which cancels out the problem being a busy network or a router problem.

    Will keep you posted on results of new driver when it is installed.

    For the time being, thumbs up for no BSOD (yet...) - woot!


    *edit4* (last edit?)

    So I let my computer run over night with the newest driver from belkins site installed. Managed to download over 2gb of data and woke up to no blue screen! The card still seems to not be running at N speeds (only hitting roughly 80kb/s) but hey, at least it's running right? I'll have to poke around the internet some more and see if there is anything I can do on my end to give it a little boost.

    Meanwhile - do you have any thoughts on going SP2 to SP3? Yes/no? I don't want to get Vista just because I don't like MS's new programs until they're a few years old.

    Thank you so much for your help! This site is definitely getting bookmarked and hopefully I'll be able to give back to the community at some point.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...