Radeon 7500 / 3d device problem

By antara ยท 7 replies
Jan 30, 2004
  1. ok need some help... I am playing a game called everquest atm plays just fine on the reg server but when i got to the beta test server for on of their new expations thats comeing up i Get a No 3d Device found error ... It worked fine till they went to directx9 ... ive download that nothing ... updated my drivers ... nothing read a few place my radaeon 7500 is compatable with directx9 but cant figure out why its not working. Ive even tryed old drivers .. ( couldnt think of anything else to do :p ) but useing cata 4.1 again atm .. If you got any idea's lets me know or need to know anything else.
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    That is the beauty of beta-programs. You as the guinea-pig are having the problem, so the makers hear from you what is wrong, then they fix it (hopefully).
    Go back to the main server until the beta has improved.
    And verify that you installed DirectX 9.0b, not any other version.
  3. antara

    antara TS Rookie Topic Starter

    Yes i have directx9.0b and its not a problem on their side.I've all rdy asked about that.The launcher/game its self isnt a beta program its items and new zones that r.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try to uninstall those extra's, or, if you have XP go back to a restore-point before you D/Ld those extras.
    Other than that, I hope some fellow-everquest gamer(s) might know more. Does that server have a forum?
  5. antara

    antara TS Rookie Topic Starter

    ok found something in when i run dxdiag and test direct 3d it dose 7 and 8 fine but when it go's to test direct 9 it says " the test to use hardware accelerated direct3d 9 was skipped because the display drivers does not support it ... im useing cata 4.1 for radeon 7500 ... do i need older drivers or something ?? Btw OS is win 98 2nd edition
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    DirectX 9.0b has all the support you need for cards that support only earlier DX versions, so no need to try and install on older DX.
    If you have any Drive-Image or Ghost from before this problem started, load that back in.
    Fraid I can't help you any further, someone else , Please ?
  7. janaywj

    janaywj TS Rookie

    I am having the same problem with my Radaeon 9200 SE. A strange work around for me is after I get the error to restart, then run dxdiag. If I Test Direct 3D after a restart It says that all tests are successful and then I am able to play EQ. It is like I have to convince the thing it has everything it needs. This is certainly an annoying problem. It is also very annoying to have to run that test after every restart. I hope someone comes up with a fix soon.

  8. drmor80

    drmor80 TS Rookie

    I'm having the same problem. i run a pIII 533 mhz with 512 ram, win98 se. When i first loaded the suggested drivers I got the no 3d devices found message. I loaded the earlier version of that driver ( feb date) and it worked, although i still got the; you need version 3286 or 7189, message before i loaded. I tried to find these drivers and stripped out and reloaded several drivers trying to resolve some terrible lag issues in some important zones like pok and pot but as of yet I havent found the answer. I might have to quit playing. I freeze in those zones and currently have a 58 monk in medaria who's stuck at the zone in and keeps disconnecting every time i try to move him to get him out. Glad to see this post exists if I found a solution iI will let you know, and would be grateful for anything anybody comes up with.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...