Radeon 9800 pro - AGP non functional

By esrevnoc
Apr 5, 2006
  1. Trying out Rise of Legends brought to my attention that my AGP wasnt enabled, so I went about trying to force it on using ATI Catalyst but failed and I cant for the life of me find out whats wrong with it.
    AMD Sempron 3k+
    ASUS A7N8X-E Deluxe BIOS Rev 1013
    Radeon 9800 Pro 256

    I've tried what I could think of :
    Uninstalled using ATI's uninstaller, reinstalled 6.3 catalyst/drivers
    Reflashed BIOS (Primary vga is set to AGP, Fast write/8x both enabled)

    Cpu-z shows my Graphics Interface as just grayed out and blank.

    The only thing I've been able to use that shows I even have agp is PC Wizard and all the agp settings are there but disabled or inactive.

    Every time I turn on 4x/8x agp (cant turn on fast write at all) using Catalyst and restart - it just goes back to default.

    Im completely at a loss ....

  2. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Wow... I'm still on the 5.11 drivers... they are THE MOST STABLE DRIVERS EVER!!!. Anyway, try enabling the AGP in your bios. If you don;t know how to do this, check your motherboard manual. If you do not have a motherboard manual (eg. if you got your computer from a store or the motherboard was OEM) then post back and we will help you.
  3. esrevnoc

    esrevnoc TS Rookie Topic Starter

    Thanks to the random links at the bottom .... updating my chipset worked~ Stupid nForce drivers... *mumbles*
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...