Raid 0 setup chewing thru storage space

Not open for further replies.
Alright i am new to these forums and also this is the 1st computer i have put together myself.
Because im a gamer i thought it would be a good idea to try raid 0 with 2 hard drives for extra performance.

The problem i'm experiencing is that my raid 0 setup is causing files to take up twice as much space on the hard drive as they should be. Like if i select all the files (including any hidden ones) in my c:\ it says 50GB of files. If i go into my hard drive properties it says i have used up 100GB, which has continued as more files are added. it just keeps doubling and it seems to be an exact double. I was not aware this was going to happen, is it normal? no-one else i have spoken to knows what is going on.

I am running windows vista 64bit and the hard drives are both 320GB Hitachi T7K500 sata 2 16mb cache. I have an asus p5k premium and e8400 processor with xfx 8800gt oc gpu. Also i am using the Intel matrix technology to control the raid setup, which does confirm in windows when i run the matrix storage console that its in raid 0 not raid 1 so that isn't the problem.

Any help would be appreciated in terms of fixing or explaning this, and i am seriously thinking of formatting it and starting again with no raid, it is possible to go back isnt it?


Posts: 5,452   +7
Selecting all files in the drive root and checking the size of these does not give you a correct measure of disk space. (You didn't select all the hidden/system/inaccessible files in all the hidden/system/inaccessible subdirectories, did you?) If you do not have access to a file or directory, then you can not find out how big they are either. For example, if you have several users in your computer, then one user cannot see the My Documents folder of another user and therefore cannot count the sizes of the files in there.

As an administrator user, run a disk visualisation program like Seqoia View to get a nice overview of the disk space used.

Also, filesystem cluster size and the amount of files affect the efficiency of disk use. If you formatted your filesystem with 64K clusters, then you waste 32K per file on average. If you have a lot of small files, then you lose even more. A million 10K files means 64GB disk space gone.
  • Thread Starter Thread Starter
  • #3
ah well im using 128kb striping could that be the cause? if so i dont want to be losing so much space just for a little extra hard drive performance.

I only have 86000 files though i shouldnt be losing over 50GB of space for 50GB of data should i? I am the sole administrator user of this computer so there shouldn't be a huge amount of files i cant access.

btw i cant seem to download sequioa view, the server seems to be down :s


Posts: 2,094   +3
nodsu is correct that just hilighting all the folders and files in c:/ drive (eg.) won't show the total data used.. rather right click on the c:/ drive and go properties instead..

try spacemonger, it shows pretty much everything on your hdd in a topdown view as such, however i don't use raid so i don't know how it will work.. but i'm pretty sure it should.


Posts: 1,009   +0
I would say
Nodsu answered the question
do the math let us know
your striping size is way to large what are your average file sizes
you may need to rebuild or RAR a lot of small files
  • Thread Starter Thread Starter
  • #7
I tried space monger and it said i had used 55Gb and that there was 66.8GB of unscannable space used, what has caused this? is it cos of the striping with the raid 0? thats just a massive waste. my other non-raid hard drive has same amount of data on it and only 4GB unscannable space.


Posts: 5,452   +7
You are barking up the wrong tree.. RAID happens two levels below the filesystem and it has got nothing to do with filesystems, free space in them or file access.

It is your OS and other software that does stuff with files. I would blame Vista hiding stuff from you (Recycle Bin, System Restore, or some other "user friendly" feature), some other backup/undelete software, some serious malware or simply filesystem corruption. (You have run chkdsk on C:, right?)
  • Thread Starter Thread Starter
  • #9
im sorry im new to this, perhaps ive missed a step with setting up the raid, all i did was configure it in the intel matrix storage manager which is at a hardware level i believe so perhaps i need to do sumthing about the operating system. i will perform a chkdisk but im pretty sure they will be ok since they are brand new.

I didnt install any drivers off a disk could that be the problem?


Posts: 13,970   +1,778
I invite you to revisit the question, "Why do I need RAID and suffer with all of this?"
  • Thread Starter Thread Starter
  • #11
very true :p Well it seems it wasnt a driver issue afterall it was windows system restore points and clearing all but the most recent freed 22gb! :O what a greedy operating system...
Not open for further replies.