1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Realtek ac'97 audio drive not working, error code 10

By Julio84 ยท 35 replies
Oct 7, 2010
Post New Reply
  1. Hi peeps.

    First time posting, so if im not doing it right i apologise.

    I recently formated my pc, and re-installed windows XP pro.. installed all my drivers ect & everything was working perfect even my sound.. the next day when i switched the pc my audio device has a code 10 error?

    How does that work? i dont have a virus as i did scans, i tried uninstalling and re-installing all different audio drivers even older versions, just doesnt seem to work...
    Im getting sleepless nights with this nonsense :).. damn digital signatures

    My pc specs:
    AMD 3000+
    motherboard 7njl3/4
    geforce 6200a
    1 gig ram
    120 gig hardrive.

    PLEASE HELP ME.. it is so damn annoying..

    thanks in advance.
  2. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    No sound?

    Try the simple things first. Speakers on and working? Plug them into a MP3 player, test that they actually amplify. Speaker plug in the correct socket in the PC? ( I mean not the Mic socket?) Have you looked in 'Device Manager' for a yellow warning by the entry for your sound option? Assume you know all the above, it's most likely still to be the wrong drivers. Go into 'Device Manager' and uninstall any sound drivers. Then go to www.drivereasy.com and download their free program, scan your PC and you will get the right driver I would think. You might also find a few other drivers out of date too. And NO it doesn't cost you to use that program. Hope this helps.
  3. Julio84

    Julio84 TS Rookie Topic Starter

    Will try

    Thnx mike...

    Gonna give it a shot, hope it isnt like that driver whiz & driver detector :p

    Thanks for the response, will keep you posted.
  4. Julio84

    Julio84 TS Rookie Topic Starter

    Hi Mike.. i tried installing driver easy it throws a error "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix the problem." i've tried re-installing it numerous times.. just doesnt work.
  5. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    That's very strange. It works for me on 3 different PC's. My own (Win7) and 2 others I keep going for others (Win XP). Have found it most useful and tell anyone who wants to know the same. Possible you could download it again from, say 'www.cnet.com'. Type 'drivereasy' into the search box.
    They list it, I just checked. Did you get the .exe file or a .zip version? Another option you could try is go to Realteks site, and get a driver from them.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Hmmmm... Sometimes that error message can occur when the application needs a particular MS Visual C++ library that's missing / not found on your computer

    If that should be the case here, there should be a more specific message in Windows Event Log. Let's look
    [post=936481]See this post[/post] and attach a copy of the event log generated by VEW.
  7. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Good point. On the download page, on lower right, it does mention that it needs the '.net framework 2.0' installed first. That's a free download from Microsoft. Really worth doing, I think.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    And an excellent point as well! :)

    You're right. The simplest first step is downloading (and making sure) net framework 2.0 is installed. That missing library might be part of it

    If in fact turns out you're missing netframework 2.0.... it begs the question... Are you current on all your Windows Updates??
  9. Julio84

    Julio84 TS Rookie Topic Starter

    I did install netframework 2.0, i even installed sp1 & 2.. that program just didnt seem to work.. trust me if there is any computer that has a mind of its own its mine...

    But like i said i downloading at least 15 driver detectors ectt.. each one needing to be payed for lol.. i then downloaded motherboard detectors... and came across everest.. awesome program!! i have a chaintech motherboard and it was almost impossible to get drivers for it as chaintechs official site has no directory on old drivers as they dont manufacture motherboards anymore..

    But again guys thx alot for your assistance and keep the program i meantioned in mind, it really helps!
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    I've always been very suspicious and leery of driver detectives over the years. I found most all of them (except DriverMax) were scamware just trying to make you pay for a bogus product. So i was also leery of DriverEasy when mike1959 first started posting it. BUT, i've tried it, i use it, i will recommend it to others. I must credit mike1959 with a good find :grinthumb (oh, and it's much better DriverMax)

    With that said.. and back to your problem.....
    You may, in fact, have more then one problem going on here. I'd suggest the following steps in following order

    Windows Update

    Do you normally choose Custom updates?
    > Run Windows Update, choose Custom.
    > Install all critical updates. Install all Hardware Optional Updates
    > For Software Opitional Updates that appear, you can either
    ===> Install them all OR
    ===> Install all except just stuff for Microsoft Live and/or Microsoft Passport (your choice)
    > Keep re-running Windows Update until it has no new updates

    List any Problem Devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Generate and attach a DirectX report
    • Click Start->Run, enter dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save to your Desktop
    • In TechSpot, use the paper clip icon to attach the report. (If you don't see icon you may need to first click Go Advanced)
  11. Julio84

    Julio84 TS Rookie Topic Starter

    Hi Lookinaround..

    Thanks for the extremely helpful tips.. i eventually got my driver working & its working 100%.. hope this problem doesnt accure again...

    Thx again for the awesome help... this site rocks will def recommend it to any1 :)
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185


    Great News!! :grinthumb

    We're all glad to help :)
  13. Guru Raj

    Guru Raj TS Rookie

    The following error occured.
    Can you help me?

    """""Name Realtek AC97 Audio
    Manufacturer Realtek
    Status Error
    PNP Device ID HDAUDIO \FUNC_01&VEN_10EC&DEV_0883&SUBSYS_1458A002&REV_1000\4&2F790C35&3&0201
    Driver c:\windows\system32\drivers\alcxwdm.sys (5.10.5870 built by: WinDDK, 2.22 MB (2,324,480 bytes), 5/13/2012 7:33 PM)"""""
  14. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi, Do you have any sound from your pc now?
    What is the brand and model of your pc?
    Which Windows version are you using?
  15. ron111

    ron111 TS Rookie Posts: 44

    Well, after you guys recommending it, I had to try the drivereasy program as well, and I must say I do not share the positive opinion.
    The scanning is so fast that it must be loading the device and driver details from the registry, rather than enumerating the actual present hardware devices. There does not seem to be any backup and restore option, and the first download I tried never started and took several minutes to cancel. It also recommends updates on devices that do not actually need a driver.
    From my experience DriverDetective (and its many, many, many white labels) do a better job.
  16. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi ron111, Yes the FREE version of Drivereasy is slow, on purpose, but the paid for version is as fast as your connection allows. The driver backup is in the 'Tools' section on the first screen.
    After I scan my pc, I get a list of drivers that I know I don't need to update, graphic card for instance, as I use a 2007 version.
    So it's just your choice if you want to update your drivers or not. Tick the box of the one you want, then download.
    I would say if you have no problems now, then don't update the drivers.
    Where Drivereasy is very useful, is when you don't know what the driver is, or where to get it. I have found it to be accurate and to find the correct drivers for my pc.
    Remember that many other driver programs want you to give them an email address, or want you to pay for the drivers, which are really free. DriverEasy free is free, there is a fast version you can pay for. It's a good program either way.
  17. Link48

    Link48 TS Rookie Posts: 17

    I have the same problem with my audio please help! I write music with my computer so the audio is very essential.
    VIA AC'97 Audio Controller (WDM) ROOT\MEDIA\0001 This device cannot start.

    Attached Files:

  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

  19. Link48

    Link48 TS Rookie Posts: 17

    Didnt work, it says I dont have the sound card. is there a way to download that?
  20. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi Link48, Is this a PC that you have used before? You know that the sound card/chip does work?
    One possible fault is that the sound chip could have failed.
    But more likely to be a driver problem, so you could go into Device Manager, find your sound card in the list (Audio devices) right click on it and choose 'uninstall'.
    Reboot the PC and it should 'discover' the sound chip and reinstall the driver, which will still be on your PC, assuming it was working before.
    (Not in this case, but with audio 'issues' it's always worth trying headphones to see if it's a speaker or related problem, and be sure the sound is not muted or just turned down to a low level, it's been done before!)
  21. Link48

    Link48 TS Rookie Posts: 17

    This is what my audio devices look like
  22. Link48

    Link48 TS Rookie Posts: 17

    This is what my sound configuration is
  23. Link48

    Link48 TS Rookie Posts: 17

    Sorry, I had troubles uploading the screenshot Untitled 1.
    Untitled 1. Untitled 2.
  24. Link48

    Link48 TS Rookie Posts: 17

    Untitled 4. this is what the direct X Diagnostic shows, I hope these pictures help, I'm grateful for your patience :)
  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Can you give us the specs on your hardware? From dxdiag, looks like you have a Dell Optiplex GX270? Do you have an addon sound card for you machine?

    Did you recently try installing the VIA and ESS drivers we're seeing in your snaphost? or have they always been there? I ask because Dell support site for model HERE shows onboard driver is ADI. (So I wonder if those other belong there or not)

    Check your BIOS settings. Make sure onboard audio is enabled. If those VIA and ESS drivers are stuff you just installed look in Add/Remove Programs to uninstall. If onboard audio is enabled, try the ADI driver on Dell's website.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...