Audio Realtek ac97 audio issue - No Audio Device

Not open for further replies.


TS Rookie
I'm having an issue I've had before, and found the resolution for... But can't find it again.

Symptoms: Flash programs, like the sound for the MMO I tried logging into, and the part of an online job application that has a "play" button to listen to a scenario then answer the questions from what you heard... won't play. Problem wasn't there lasntight, it's there today. Winamp, etc. will still play audio. System sounds won't play. Alert sounds used to play a chime but now play the alert tone from the pc.

All drivers are updated and correct. This is a setting somewhere that needs to be fixed, I just don't remember what setting. Some people with this problem report that it fixed itself after a while, but I don't have time to sit and count on that.

I know a new piece of hardware won't fix it... It's an issue in the computer settings somewhere.

Steps taken:
Originally when I went to device manager it showed everything as working.
Down in the system tray I had the volume icon, but when I tried to left click, nothing happened.
When I went to right click>open volume controls, it gave an error saying there were no mixing devices.
Checked that realtek is set to mixing, and checked all drivers.
Went into control panel>sounds and audio devices: no audio device, and no option to set one as default.
I went into services.msc and audio's set to automatic already.
I disabled the drivers and restarted, intending to re-enable them.
Upon restart, I no longer have a volume icon in the system tray. Still no audio device through control panel. However, in Device Manager, everything's showing as enabled. And I now have "Microsoft WinMM WDM Audio Compatibility Driver" with an exclamation point.
The error is "A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)". Can't update the driver, it gives me that error again. Looked up that error and got the resolution to try reinstalling, or change the start type in the registry. The link on Microsoft's page to do that isn't present, and their info for editing the registry is like finding a needle in a haystack.

I know I didn't have to go into the registry to fix this last time and I feel I'm going 20,000 leagues under the sea to catch a trout that I could catch in a smaller lake.

Please don't tell me to get a new audio device... I've had this problem before and know that's not the resolution. If you don't know the answer and aren't familiar with this specific issue, please don't post "try reinstalling the drivers again" or "contact your manufacturer" or anything like that.

Thanks so much!


TS Ambassador
Go to the motherboards support site, under your model and operating system. Download the audio driver and install it once more
Not open for further replies.